WordPress.org

Ready to get started?Download WordPress

Forums

Sundance
[resolved] Content and sidebar don't appear until video loads (4 posts)

  1. robynover
    Member
    Posted 7 months ago #

    The video carousel (with vimeo links) takes a long time to load on my site. That wouldn't be such a big deal, except that it prevents the rest of the page elements from loading, including the main body text and the sidebar. When you hit the page, you only see the page header and a progress wheel for a few seconds.

    I'd guess this is javascript dynamically loading the videos, but I can't figure out why it's halting the rest of the page from rendering. Thinking maybe I need to move pieces of the javascript to the very bottom of the page, but having trouble tracking it down.

    The site is question: http://almoradiemedia.com/

  2. Hi there, one of our theme developers had a look at this.

    Could you please try these two tweaks and see if they help:

    In the file js/theme.js, make the code replacement you see here:

    http://snippi.com/s/7mf8lev

    In your CSS, try this tweak:

    http://snippi.com/s/npinbzq

    Let me know how it goes.

    The best way to make changes to a theme is to use a child theme. Here are some guides in case you haven't made one before:

    http://codex.wordpress.org/Child_Themes
    http://op111.net/53/
    http://vimeo.com/49770088

  3. robynover
    Member
    Posted 7 months ago #

    Thank you, Kathryn. These 2 tweaks helped get me on the right track. In the CSS one, I ended up having to change the height value to a hard-coded pixel value (in my case 400px) instead of setting it to zero as in the snippet.

  4. Great, glad you got this sorted out and thanks for letting me know what you had to tweak in the CSS.

Reply

You must log in to post.

About this Theme

About this Topic