WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[closed] Contact form sending to wrong email address (19 posts)

  1. TBakerHR
    Member
    Posted 10 months ago #

    Well...I've tried everything I know, but the Jetpack contact form is still sending the emails to an incorrect email address.

    Yes, I have tried to change the email in the contact form settings.
    Yes, the General settings in WP are correct.

    So, not sure what to do now. Every time someone sends and email, it goes to the wrong address.

    http://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    Could you open the page containing the contact form, and check the shortcode generated by the form builder? Is the email address listed in that shortcode correct? If not, could you try to change it and let me know if it helps?

  3. TBakerHR
    Member
    Posted 10 months ago #

    I don't see any email address in the shortcode. I've tried using the contact form settings to indicate a specific email address, but it isn't working.

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    When you add a specific email address to the form, it should get added to the shortcode like so:

    [contact-form to='ab@cd.com'][contact-field label='Name' type='name' required='1'/][contact-field label='Email' type='email' required='1'/][contact-field label='Website' type='url'/][contact-field label='Comment' type='textarea' required='1'/][/contact-form]

    Could you try to add your email address manually and let me know if it helps?

    Thanks!

  5. TBakerHR
    Member
    Posted 10 months ago #

    I tried it manually, but then the page shows a bunch of error codes.

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    Could you paste the shortcode that's included in your editor here?

    Thanks!

  7. TBakerHR
    Member
    Posted 10 months ago #

    This is how it shows up, even when I specify the email address to use...I added [contact-form to='tbaker@timbakerhr.com'] manually, but I get errors

    [contact-form subject='Contact from website'][contact-field label='Name' type='name' required='1'/][contact-field label='Email' type='email' required='1'/][contact-field label='Website' type='url'/][contact-field label='Subjecct' type='select' required='1' options='Comment,Question,Feedback,General Inquiry'/][contact-field label='Comment' type='textarea' required='1'/][/contact-form]

  8. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    That's interesting. This shortcode is correct; it works correctly on my test site.

    Could you send a link to your contact page, or paste the errors you see when adding the contact form shortcode?

    Thanks!

  9. TBakerHR
    Member
    Posted 10 months ago #

    here's the link to the contact page
    http://timbakerhr.com/contact-me/

  10. Genesis@WordPress
    Member
    Posted 10 months ago #

    Sorry to butt in: I had a similar problem and I finally got it solved TODAY!

    In my case the issue was with the Web host and when they finally "modified the server side settings" (direct quote from their response), I started receiving emails into the email account I wanted to use for the forms...

    Maybe this will help you too, TBakerHR...

  11. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    @TBakerHR I just tested the form, and it seems to work properly now; have you managed to solve the issue by yourself?

  12. TBakerHR
    Member
    Posted 10 months ago #

    I see that you tested it. The issue was not that it didn't work, but that it was sending to the wrong address...which it still is. I received your test email, but it was not sent to my tbaker@timbakerhr.com address...it went to my timbakerhr@gmail.com address.

    Thoughts?

  13. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    You mentioned errors when you added a custom email address to the form shortcode. Could you try to make the changes again, so I can see these errors?

    Thanks!

  14. TBakerHR
    Member
    Posted 10 months ago #

    Sure. When I add a custom email address to the short code using the "settings" in the form, nothing happens...it doesn't even add it to the shortcode. But when I manually try to add it, that's when I get the errors. Here they are...

    http://screencast.com/t/548dPXWdDttX

  15. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    That's interesting. Would you mind contacting us via email and creating a temporary admin account for us so we can run a few more tests with you?

    Be sure to mention this thread in your email so I can follow up.

    Thanks!

  16. ajedward
    Member
    Posted 7 months ago #

    Huh, weird stuff... I have the same issue!

    I got a wordpress site working on my local install, where I'm using my gmail address as the admin e-mail. English and French contact forms working perfectly as with all other elements of the site.

    I export the pages from my site to the live hosted site (it's a local musician).

    1) The contact forms work, but the e-mails are *still* going to my e-mail address (admin e-mail address of the local test site), weird.

    2) I try adding the shortcode for specifying the e-mail explicitly ([contact-form to='ab@cd.com']), it has no effect. It is still sending the information to the admin e-mail on the source *test site*.

    3) I suspect that it's because JetPack is connected to wordpress.com using my account, which has the same e-mail address. I update my wordpress.com to use my secondary e-mail address, this changes nothing, e-mails still going to the same (incorrect) e-mail address.

    4) The Dashboard - Feedback shows all of the contact form responses, the wordpress admin e-mail address on the live hosted site is most definitely set to a different e-mail address.

    Any thoughts? Great looking contact form by the way, I would hate to switch it to another plugin! The site is of a young prodigy here in Montreal, danielclarkebouchard.com (click on the 'Contact' menu in English, or 'Nous joindre' in French).

    shortcode:

    [contact-form][contact-field label='Name' type='name' required='1'/][contact-field label='Email' type='email' required='1'/][contact-field label='Website' type='url'/][contact-field label='Comment' type='textarea' required='1'/][/contact-form]

  17. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    @ajedward Could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

  18. thoughtfullyhungry
    Member
    Posted 7 months ago #

    Hello there

    I am having the same issue. I have checked all the places I could think of, but cannot figure out how the messages are being sent to the wrong email. The only hiccup I can find is in my wp.org profile my username is set as the wrong email address.

    admin page-->profile-->username-->aliciamolin@gmail.com

    I would like my emails to be sent to thoughtfullyhungry@gmail.com, but they are being sent from the contact form to aliciamolin@gmail.com.

    I am using Contact Form 7 and the only code I have in the page is

    [contact-form-7 id="49" title="Contact form 1"]

    Thank you!

  19. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 months ago #

    @thoughtfullyhungry: Could you do the same as previously requested, and create your own thread for the issue?

    Specifically, if you're using Contact Form 7, then replying in a thread for a different plugin entirely probably is unlikely to get you the help you need.

    If you visit the plugin's page directly:
    http://wordpress.org/plugins/contact-form-7/

    You'll notice that there is a Support tab where you can create new threads for that plugin specifically.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic