WordPress.org

Ready to get started?Download WordPress

Forums

contact form mail gets lost (7 posts)

  1. loudivers
    Member
    Posted 3 years ago #

    Hello,

    I hope someone here will be able to help me.
    I have a couple wordpress sites hosted on godaddy, and when I send mail from the contact forms I get the "messsage sent, thank you!" success message, but none of the messages show up in the inbox of any of the mail accounts.

    Everything was working fine just a month ago. All that I have changed is updating wordpress to 3.0.5

    So far nobody has been able to help me with this not even the "great" support team at godaddy. I am willing to try anything - Please help!

  2. Holli Graham
    Member
    Posted 3 years ago #

    I'm in the same boat. Are you using custom contact forms? Everything works fine on Hawk Host, but when I moved the site to my client's server - GoDaddy, I don't get any emails. I do get the emails from the two backup plugins I installed. I posted a question about six hours ago on here, but no one has answered yet. I'm also using 3.0.5. Since you're saying it worked until you upgraded, think upgrading to 3.1 might get it to work?

  3. loudivers
    Member
    Posted 3 years ago #

    No, but I tried custom contact forms once just to try a different form, and the mail did make it through. I have one site that is using the clean contact form and the message comes through but only with the subject, and the body of the message gets lost. Shortly afterward I get the mailer-daemon message in the same inbox that tells me "Your mail message to the following address(es) could not be delivered"
    The other 2 contact forms are built in to themes that I bought, and I do not get any messages that are being sent from them with one exception - I had the studio that I bought one of the themes from test the contact form and 9 out of 10 of their messages came through. I have not had a single message show since and I must have sent 20 myself. Their e-mail address was whoever@website.co.uk I'm begining to think that godaddy has some serious spam policy and these 10 messages may not have been as "suspicious" due to the .co.uk e-mail address.
    I have thought about updating to 3.1 to see if this fixes the problem because it was released like a week after 3.0.5, so I'm gonna go ahead and try it now. I'll let you know how I make out.

  4. loudivers
    Member
    Posted 3 years ago #

    Hello ClockfireCoder, I have had no luck with fixing this problem have you found a solution?

  5. esmi
    Forum Moderator
    Posted 3 years ago #

    GoDaddy may block any outgoing mail that doesn't go through their own SMTP server. Try contacting them to see if this is the case on your sites.

  6. Holli Graham
    Member
    Posted 3 years ago #

    No, I still haven't had any luck. What I don't get is why the backup emails all go through but none of the contact form ones do. We're not the only ones. I found this thread, and I've read it all the way through it. I've tried everything in there too, and it's still not working. Some people seem to be able to get something working, but most aren't. This is the thread if you want to see if there's something you missed. http://wordpress.org/support/topic/contact-form-7-not-working-3

  7. Holli Graham
    Member
    Posted 3 years ago #

    Check out the reply from boerbabe in the thread I provided in my last reply. I've tried it with several different email addresses. It's actually working! Crazy.

Topic Closed

This topic has been closed to new replies.

About this Topic