WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[closed] Contact Form 7 not sending emails- no confirmation, no error (48 posts)

  1. jjfergie
    Member
    Posted 1 year ago #

    I've been having the same problem, but now it's different. I don't understand what's going on. I was using my gmail account on the form creation page. It quit working after 3.5. I changed THAT address only to another one, not gmail. It works, BUT it's sending to my gmail account! WHAT? Is it using the general system email admin address for sending? It never arrived at the other email address. And it's showing coming from the email address the user puts in the contact form. Bizarre.

  2. zrnchikw
    Member
    Posted 1 year ago #

    Same here.... 3 weeks I thought no patients were having problems... then I find out the CF7 is not sending emails....

    I have the same issue as everyone else. Latest version...

  3. brasofilo
    Member
    Posted 1 year ago #

    For the records:

    in my case, using Google Apps to manage the emails, since a specific date, all emails sent by CF7 were going to the Spam box.

    Around the same date, I found that some #¢&@ started to use our email address as sender of their bloody spam.

    What I'll try now, is to set our From address to be something unique and not easily phished.

  4. brasofilo
    Member
    Posted 1 year ago #

    Update:

    now using myemail+UNIQUE_STRING@google-powered-email.com

    and setting SMTP without a plugin:
    http://wordpress.stackexchange.com/q/75956/12615

    Everything working ok ;)

  5. jocardo
    Member
    Posted 1 year ago #

    hola amigos, necesito que en wp yo pueda asignarle a cada usuario una pagina diferente,
    ejemplo: yo registro a fernando y quiero que el solo vea la pagina nosotros cuando haga login en wordpress, yo registro al usuario natalia y que ella solo vea la pagina trabajos cuando este logueada

    en fin necesito asignarle informacion de ciertos proyectos a los usuarios que registre, cada usuario verá solo la informacion que yo le asigne,
    como lo hago ??? saben graciasss

  6. janemig
    Member
    Posted 1 year ago #

    Same thing. I'm using Godaddy so I changed the "To" email address to a GD hosted name. It WAS working, but now it's not. Any solutions? And, even if it does work, what if the person sending in the form has a gmail address?

  7. mkellyrock
    Member
    Posted 1 year ago #

    Same story. Hosting at hostgator. Contact form 7 says email sent but never received. So I tried the plugin to switch to SMTP rather than PHP. Test message provided received ok, but still, using the form does not. My WP expertise is nil but I can recognize a can of worms when I see one.

  8. ana_thema
    Member
    Posted 1 year ago #

    Hello, I had the same problem, but got it solved. The solution is to both configure contact forms to be sent from an email address that matches your website domain, like <contact@website.com> and configure SMTP according to your hosting provider.

    The Contact Form should be configured something like this:

    - Inside Form:
    <p>Name
    [text* your-name] </p>
    <p>Email
    [email* your-email] </p>
    <p>Message
    [textarea your-message] </p>
    <p>[submit "Send the message"]</p>
    - Inside Mail:
    To: (the email address I want the message to go to)
    From: [your-name] <[your-email]>
    Subject: [your-name] sent you a message from Yoursite.com
    - Additional Headers:
    From: Site Visitor <not-a-real-email@websiteurl.com>
    Reply-To: [your-name] <[your-email]>
    Subject: [your-name] sent you a message from Yoursite.com

    - Message:
    From: [your-name] <[your-email]>
    Message Body:
    [your-message]

    (thanks to TheDsutty)

    To configure smtp (I'm on Dreamhost) I used the plugin Configure SMTP (http://wordpress.org/extend/plugins/configure-smtp), like this:

    - set SMTP host to be 'mail.mydomain.com' rather than 'localhost'. (This is a typical DreamHost setting, you should check with your hosting provider your e-mail client configuration. )
    - enter the username (the full email address, something like 'postmaster@mydomain.com') and password for the send from address

    (thanks to Joe Greenwood)

    Hope this helps!

  9. iWebWebdesign
    Member
    Posted 1 year ago #

    I have the self problem but i FIX it.

    I chmod all folders and files from the form 7 to 777 in the FTP. That worked for me. That gives all rights of way. For websites problems go to iwebwebdesign.nl

    Thank you.

  10. Gaurav Gupta
    Member
    Posted 1 year ago #

    hello friends......
    i recently install a CF7 plugin on my site. my problem is that i receive the confirmation message for mail send but i could not get it.....so what m doing????

  11. speedy222
    Member
    Posted 1 year ago #

    Hello Gaurav Gupta,

    Have you chmod your folders to 777 or not? In your FTP folders from your CF7?

    Let me know.

  12. Gaurav Gupta
    Member
    Posted 1 year ago #

    hey i'll solve my problem. Actually i did a stupid thing. i send the msg to my own email id. so i could not recieve mail. thanx for your reply.

  13. speedy222
    Member
    Posted 1 year ago #

    Oke your email is now good. Nice day.

  14. intelzone
    Member
    Posted 11 months ago #

    Ok everyone I hope this helps, I have probably spent over 10 solid hours in trying to work out a solid fix (some fixes other users mention here only work intermittently)

    my current setup, wordpress 3.5.2 + Contact Form 3.4.2 + WP-SMPT (plug in)

    Problem: contact form 7 confirms message has been successful, however message is not received with website hosting email address

    inside the plug in directory for contact form 7, use your FTP program
    go to: /includes/classes.php
    edit as per below
    original:
    $headers = "From: $sender\n";
    change to
    //$headers = "From $sender\n";

    (there are two changes "//" and ":" has been removed

    I thought this intitally fixed the problem because after this noticed emails coming through, however this was intermittent.
    I use godaddy hosting, half the time they would come through hours later and sometimes they would not come at all.

    it is imperative to use the correct outgoing server from your hosting company, if you notice there are different users quoting different port details and outgoing servers for the same hosting provider.

    I used the exact same one in my Godaddy email setup account, previously i was using the Godaddy outoging servers other users quoted which seemed to work fine but not always

    go to WPMPT plug in,
    use authenticate option (previously like others suggested i had this turned off, seemed to work OK but not everytime) after authenticating this ensured emails arrived on time, they didnt get lost either

    enter email and password
    try different ports, 25 or 80 (if using SSL will be different number check with your hosting provider)
    use the test emails to see if the email works with the correct port.

    I noticed using SMPT authentication and the exact outgoing server that was listed in my email setup made a big difference by ensuring the emails arrived consistenly

    and this step also made a difference, log in to your hosting providers email account (web mail with hosting), go to spam filter settings, and add your domain name and email address to the "allow list" in your filter/spam settings. this is because Contact Form 7 uses your own domain hosted email address to send you an email, your hosting provider may even block the email before it reaches your mail box or your mail box spam filter hence you never see it....

    ALSO do not updated contact form 7, I dont think it is a very reliable plug in, if you update it, you may need to play around again with the settings to fix the consistency issue of emails not always sending.

  15. buzztone
    Member
    Posted 11 months ago #

    Though the plugin successfully sends millions of emails every day, there are a host of issues that can delay or stop emails on both the sending and receiving ends of a typical email. It depends entirely on your local configuration.

    You will need to investigate this issue for your particular local configuration. See Contact Form 7 Email Issues

  16. romel_emperado
    Member
    Posted 10 months ago #

    The simple solution here is to install mail utility in your host because I think by default your contact form is using the mail utility to send the emails.

    in my ubuntu host I fixed it by installing mail utilities specially MTA

    sudo apt-get install mailutils

  17. saynw
    Member
    Posted 10 months ago #

    I have the message error message that suggest to try later. I started happening after I update to WordPress 3.6.1.

    Does anyone have the solution?

    Thanks!

  18. esmi
    Forum Moderator
    Posted 10 months ago #

    As per the Forum Welcome, please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic