WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Contact Form 7 Mail(2) "From" Attribute is Broken (2 posts)

  1. S. Wyatt Young
    Member
    Posted 2 years ago #

    Dear CF7 Support Team,

    The "From" attribute of CF7 Mail(2), whether used natively, or alongside WP-Mail-SMTP, is broken. Disabling WP-Mail-SMTP (and thus returning to the native WordPress mail functions) does not resolve the issue. However, using WP-Mail-SMTP to override whatever "From" value is input in outgoing e-mails, does resolve the issue.

    That said, the issue only seems to present itself when the web hosting and e-mail functions of a domain are performed on different networks. And while I considered that this might be a problem with the web host of choice, WP-Mail-SMTP proves otherwise. Please let me know if you have any additional questions.

    Best Regards,
    S. Wyatt Young

  2. S. Wyatt Young
    Member
    Posted 2 years ago #

    Dear CF7 Support Team,

    Upon further testing, I've found that the reason for the "From" attribute of Mail(2) not working may in fact be related to settings and policies of the web host in question (Bluehost).

    For those who are curious, I created a workaround using WP-Mail-SMTP, in which I configured WP-Mail-SMTP to use SMTP instead of PHP mail(), and set the settings to point to localhost on port 25, without authentication. Further, to ensure that all went well, I created an e-mail account with Bluehost (even though they don't handle the e-mail for the domain) that corresponded to the e-mail address I was attempting to send from.

    That said, I apologize for wasting your time, CF7 Support Team.

    Cheers,
    S. Wyatt Young

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic