WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Contact Form 7 incompatible with Akismet (17 posts)

  1. jupjam9
    Member
    Posted 3 years ago #

    Hi there, to save typing out a lot of text again, if I could point you to this thread, maybe you could take a look at it to see the problem I am having and see if anyone can help? http://wordpress.org/support/topic/spam-filters-causing-wp-pages-problems?replies=4#post-1871399

    Basically I have discovered (through testing) that CF7 causes me page editing problems when activated along with activating with Akismet spam filter.

    Any ideas?

    Thank you in advance - Justin

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 3 years ago #

    Contact Form 7 is compatible with Akismet, of course. Thousands of websites uses the pair without any problems.

  3. jupjam9
    Member
    Posted 3 years ago #

    That's as maybe, but doesn't explain why I am experiencing problems? As i said, i tested various combinations of plugins and found this combination to be causing the issue, hence why i am asking the question. Thank you.

  4. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    I've have used CF7 & Akismet on dozens of sites and I've never had a single problem with these 2 plugins.

  5. mindfullsilence
    Member
    Posted 3 years ago #

    wow...what awesome help you guys are. Who gives a crap if it works for you? It's obviously not working for jupjam9. So, I don't know, maybe talk through it and find a solution? Just sayin, pretty sure "It works for me" doesn't solve the issue.

    jupjam9, check with your hosting provider to find out what version of php you have, and make sure it's updated to the newest version. Also check your wordpress and plug-ins, and make sure they're fully updated to the newest version. You can do this pretty easily by logging into your wordpress as the admin and clicking on "Dashboard" in the sidebar to expand it's drop-down, and then clicking on "Updates". Make sure all your plug-ins, and wordpress are up-to-date. This tends to fix a lot of problems. Reply here if you still have problems and hopefully someone will be available to help.

  6. jupjam9
    Member
    Posted 3 years ago #

    Finally, someone talking some sense! Thank you mindfullsilence!

    I have contacted my hosting provider, they said that their packages use PHP4 as a default, but I can up-it to PHP5 if I want to, and they have sent me instructions on how to do this. Would you recommend I do that 1st?

    Regarding updates; CF7 is showing an update available, but that only appeared today. And WordPress has an update from 3.0.3 to 3.0.4. Unfortunately, whenever I have tried to do an auto-update it never works, it just shows a page with 'unpacking' or similar and stays like that, so I have to hit 'back' or click away. Any ideas why auto update might not work?

    I updated WP once, recently, but had to do it manually, transferring/deleting individual files. Could I have missed a file? Might that be causing a minor problem, or would it not work at all if that was the case? Also, with CF7, if I can't update that automatically, would I have to delete and reinstall? If so, I would surely lose all of my forms I created?

    Thank you in advance again.

    Justin

  7. jupjam9
    Member
    Posted 3 years ago #

    Just a thought...have been reading the PHP instructions...it says about editing the ".htaccess" file. At the top of my WP control panel it has the message:

    'Your backup folder MIGHT be visible to the public. To correct this issue, move the .htaccess file from wp-content/plugins/wp-dbmanager to /homepages/39/d346128484/htdocs/wordpress/wp-content/backup-db'

    I have done this, but it is still showing. Might this be causing a problem? Does WP somehow not know that I have moved it and is not looking for it in the new place?

  8. seriousthings
    Member
    Posted 3 years ago #

    haha, ya. "It works for me". Yay, thanks for wasting your 10secs of time that did nothing positive for the universe, haha.

    I can't say I know what the problem is, but it seems you are someone that can get around a bit in troubleshooting. This is what I personally would do..

    First, I would disable all of the other plugins one at a time and see what happens. I'd get it down to the 2 that you assume are the challenge. Enable one, disable the other...and vice versa. I'd get it down to an elimination process.. Once you know, with 100000% certainty that it is indeed down to those 2 plugins creating the conflict (and you do not experience the issues with editing at any other time), then you have narrowed it down to step 1.

    But see, your original type up shows in 1) that you have other editing page problems. Then, in 2).. you are showing more editing page problems and butting it up to the plug-ins. I'm going to suspect that it is not the plugins if you are experiencing other editing page problems w/o the plugins.

    So, if what you typed up is indeed the case, there is something else wrong that is impacting the editing page already... maybe when you enable the plugin, it just makes it worse? What I can see, the problem is elsewhere.

    I would also see if the issue can be duplicated in other browsers. Maybe you have some add-ons added that are conflicting w/ WP. I'd try WP in both IE, FF, and maybe even Chrome.. and see if it continues. If not, you have narrowed it down further..

    Try it on a different computer...see what it does. Keep going if that isn't it..

    Personally, after doing google searching around about the editing page problem in WP (minus the blame on the plugin), if I could not find someone that was experiencing it too.. I would suspect somethiing on my end. If it wasn't the computer, browser...I would suspect server side. So, I would probably back up the blog... then wipe it out and reinstall everything.

    Oh, yes..I would update to php5. See, from everything you are saying, it is obvious you are experiencing other challenges. You can't do auto WP updates cuz it just hangs on unpacking? Mine will go to an unpacking page, but at the bottom..it will eventually say done. Sometimes it takes a bit. By hitting back and not letting it finish, you could be screwing up the installs?

    Idk...from what I'm reading, there seems to be a challenge elsewhere than the plugin. The plugin is just contributing to it and making it worse. I'd wipe it all off the server and get a fresh install done if php5, 3.04, browswer, computer, and other elimination processes don't work.

  9. seriousthings
    Member
    Posted 3 years ago #

    p.s. the majority of people are running akismet. If it were a problem with this plugin and akismet, you can be rest assured that more people would be having the same problem.. 1000s of them. Almost everyone using the plugin and the same theme as you.

    So ya, it works for me too. haha. But seriously... as you can see, that is part of your elimination process. If you can't find via a google search that others are experiencing the same thing, that's because your troubleshooting has narrowed it down to an incorrect culprit. So you have to back it up a bit. "Hmmm, I can't find others that are having this editing page problem with these 2 plugins. Let me minus the 2 plugins as the culprit and do some more searching." Then you are now back to sq 1, trying to find the culprit.

    I'm feeling pretty confident in saying that it is not contact form 7. Every single time I had thought my problem was a plugin because it only happened with that plugin... my fix was some where else.

  10. jupjam9
    Member
    Posted 3 years ago #

    Hi seriousthings, thank you for your input, much appreciated! At least we're getting something constructive on here now!

    It is as you say going to need A LOT more testing to narrow down what the problem is.

    Regarding one thing you mentioned; with the auto-updates, when it says downloading/unpacking or similar, the status in the bar at the bottom says 'done' immediately, making me assume that it hasn't happened, and then doesn't change if I leave it!

    Anyway, I'm meant to be a mortgage advisor(!), and this is taking up too much of my time, so I think I'm going to pass it over to someone who can play with it and they can read your comments and do through the motions.

    They will probably post on here next week.

    Thank you again, much appreciated.

    Justin

  11. WPMuse
    Member
    Posted 3 years ago #

    @jupjam9

    I didn't see anyone answer your questions about the .htaccess file.

    The file you moved is htacess.txt. After you move it, rename the file to .htaccess and that nag bar should go away.

    HTH!@ ;-)

  12. jupjam9
    Member
    Posted 3 years ago #

    Hi WPMuse,

    Thank you, when I took another look, it hadn't been moved?? But I am sure I did it!! Anyway, done it again, and as you say the message has vanished!

    Thanks again.

    I am planning to do the testing (above) tomorrow or Thurs, so will probably post more on here then!!

  13. jupjam9
    Member
    Posted 3 years ago #

    Hi WPMuse,

    As I put, I moved the .htaccess file and the message dissappeared, however (HELP!!!) when I did, every page of my website came up with 'Error 404 cannot be found' except the homepage, which is a Post? I've moved the .htaccess file back for the time being.

    Any ideas?

    Thanks - Justin

  14. WPMuse
    Member
    Posted 3 years ago #

    Hey, Justin:

    You moved it to the wp-content/backup-db folder right? If you moved it elsewhere it can cause site propblems. Make sure that is where you moved that file.

    What you can do right now is rename the file back to htaccess.txt where it is until you figure out what is going on.

    If you did move it to the correct location and this happened, after renaming it back to htaccess.txt, you'll need to contact your hosting company and ask them for assistance.

    HTH!

  15. jupjam9
    Member
    Posted 3 years ago #

    Hey, yeah I moved it to: wp-content/backup-db.

    As I put before, I am fairly new to this so learning as I go...so here goes, prepare to be confused!! ...I have both htaccess.txt and .htaccess

    I may have done this first bit wrong, but I may have moved htaccess.txt to backup-db instead of .htaccess by mistake, because as I said I found .htaccess still in WordPress.

    As you know, when I moved .htaccess to backup-db my 'Pages' all said Error404, except the home-page, which is a post.

    I just moved htaccess.txt back out, back to WordPress, and left .htaccess in backup-db, which didn't solve the problem. So I renamed .htaccess to htaccess.txt in backup-db, which didn't solve the problem either.

    I have now moved my .htaccess back to WordPress and moved htaccess.txt to backup-db and renamed this to .htaccess and the Pages are showing OK (no Error404 message). However, now I have two .htaccess files, but the red message at the top of WP control panel has vanished even though one isn't in backup-db. Both files have different information in them and are different sizes, so do I need both or need them in the same place, or need to name them differently?

    The one in backup-db has:
    <Files ~ ".*\..*">
    order allow,deny
    deny from all
    </Files>

    And the one currently in WordPress has:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Thank you in advance for any help.

    Justin

  16. jupjam9
    Member
    Posted 3 years ago #

    Hey everyone!!

    I HAVE GREAT NEWS!! :D

    It is all sorted, all working, all updated and I am on a high!!

    It came down to one simple thing...I needed to have PHP5 (was on PHP4)!!

    As soon I went through the process with my hosting tech support (which is 1&1 by the way and would thoroughly recommend them) it was like switching a switch and I was able to have all plugins activated, view and edit Pages, update WordPress and Plugins automatically.

    So I would just like to say thank-you very much to everyone who has given me help and assistance, and I apologise if I have upset anyone by saying that plugins are not compatible etc...I was just saying what I was experiencing.

    So this maybe something to bare in mind for experiencing problems in the future! "Make sure your PHP is up-to-date"!!

    Thank you again.

    - One Happy and Relieved Person!

  17. WPMuse
    Member
    Posted 3 years ago #

    Glad to hear all is well, Justin! ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic