WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] [Contact Form 7] Emails Send, But No Success Message! (17 posts)

  1. brandonecarr
    Member
    Posted 1 year ago #

    The culprit is a newsletter plugin called MyMail. When they're both activated, contact form 7 sends the email, but the arrow just spins and I get no success message. This poses an issue because I have it set to redirect back to the main page following the success message. Please help! Thanks.

    http://wordpress.org/extend/plugins/contact-form-7/

  2. brandonecarr
    Member
    Posted 1 year ago #

    Sorry, wp 3.5

  3. brandonecarr
    Member
    Posted 1 year ago #

    I tried using WP EMAIL SMTP to force it to send through my SMTP server, and the emails still go, but I still don't get the success message, and my redirect. So frustrating! Please help.

  4. joeshock
    Member
    Posted 1 year ago #

    Does your form's message body have any content in it or is it blank?

  5. brandonecarr
    Member
    Posted 1 year ago #

    Yeah, it has content. Here's a link:

    http://boltpartybus.com/contact-us/

    You can also get there from the main page by filling out the reservation form. Same issue on both. 2 separate forms.

    Thanks Joe.

  6. brandonecarr
    Member
    Posted 1 year ago #

    If you meant when it sends the email, yes, it does have content when arriving in my inbox as well. Thanks.

  7. joeshock
    Member
    Posted 1 year ago #

    Gotcha. Yes I did mean content for the message body when arriving in your inbox.

    So your issue still is that the arrow just spins after success and no message is displayed?
    Any errors you see in the console or error log?

  8. brandonecarr
    Member
    Posted 1 year ago #

    Correct. That is the issue. I have it set to redirect back to the homepage after the success message, but it never reaches that point, even after the email goes out.

    However, it's not throwing any errors that I can see. I'm using GoDaddy, and error logs are enabled, but it's not setting off any alarms.

  9. brandonecarr
    Member
    Posted 1 year ago #

    I received a delivery error in my email with the following attachment:

    'Remote-MTA: dns; mta6.am0.yahoodns.net
    Diagnostic-Code: smtp; 554 delivery error: dd This user doesn't have a yahoo.com account (eyescai@yahoo.com) [-5] - mta1025.mail.bf1.yahoo.com
    Status: 5.0.0
    Action: failed
    Final-Recipient: rfc822; eyescai@yahoo.com
    Last-Attempt-Date: Thu, 17 Jan 2013 20:28:03 +0000'

  10. brandonecarr
    Member
    Posted 1 year ago #

    Anyone have any ideas? I would really appreciate any help, or any ideas that oyu might have. Thanks!

  11. joeshock
    Member
    Posted 1 year ago #

    Maybe try turning debug mode on in wp-config.php to see if you get some more errors?

  12. brandonecarr
    Member
    Posted 1 year ago #

    So debug mode is on. It lit up like a Christmas tree with issues. Which one is my culprit though? lol thanks joe for your help with this.

  13. brandonecarr
    Member
    Posted 1 year ago #

    'Notice: Undefined index: roomthumb in /home/content/13/10297513/html/wp-content/plugins/contact-form-7-dynamic-text-extension/wpcf7_dynamic_text.php on line 352

    Notice: Undefined variable: validation_error in /home/content/13/10297513/html/wp-content/plugins/contact-form-7-dynamic-text-extension/wpcf7_dynamic_text.php on line 284

    Notice: Undefined variable: validation_error in /home/content/13/10297513/html/wp-content/plugins/contact-form-7-dynamic-text-extension/wpcf7_dynamic_text.php on line 284

    Notice: Undefined variable: validation_error in /home/content/13/10297513/html/wp-content/plugins/contact-form-7-dynamic-text-extension/wpcf7_dynamic_text.php on line 284'

    Is what I'm showing for contact form 7. The rest is below.

    At the very top:

    'Notice: wp_register_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/content/13/10297513/html/wp-includes/functions.php on line 2944

    Notice: Undefined variable: wss_plugindir in /home/content/13/10297513/html/wp-content/plugins/wp-social-slider/wp-social-slider.php on line 20

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/13/10297513/html/wp-includes/functions.php:2944) in /home/content/13/10297513/html/wp-content/plugins/facebook-awd/inc/classes/facebook/facebook.php on line 49

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/13/10297513/html/wp-includes/functions.php:2944) in /home/content/13/10297513/html/wp-content/plugins/complete-central-backup/complete_central_backup.php on line 62

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/13/10297513/html/wp-includes/functions.php:2944) in /home/content/13/10297513/html/wp-content/plugins/complete-central-backup/complete_central_backup.php on line 63

    Notice: Use of undefined constant RC_SWT_PLUGIN_FILE - assumed 'RC_SWT_PLUGIN_FILE' in /home/content/13/10297513/html/wp-content/plugins/sweet-wordpress-testimonials/sweet-wordpress-testimonials.php on line 57

    Notice: Use of undefined constant SHOW_EDITABLE_CT_IN_MENU - assumed 'SHOW_EDITABLE_CT_IN_MENU' in /home/content/13/10297513/html/wp-content/themes/guesthouse/page.php on line 18'

    At the very bottom:

    'Notice: Undefined variable: options in /home/content/13/10297513/html/wp-content/plugins/q2w3-fixed-widget/q2w3-fixed-widget.php on line 73

    Notice: Undefined variable: options in /home/content/13/10297513/html/wp-content/plugins/q2w3-fixed-widget/q2w3-fixed-widget.php on line 73

    Bolt Limo Bus
    BoltLimoBus
    BoltLimoBus Check out our new website and let us know what you think! boltpartybus.com
    yesterday · reply · retweet · favorite
    BoltLimoBus Bolt Transportation wants to wish you and your love ones a very happy holiday season! Whether you celebrate... fb.me/2iFBFFRMy
    30 days ago · reply · retweet · favorite
    BoltLimoBus Get Jolly at your holiday party this year by providing safe rides to your guest. Bolt Transportation is the #1... fb.me/1ZkyVxfuq
    43 days ago · reply · retweet · favorite
    BoltLimoBus fb.me/Pft3M4V1
    50 days ago · reply · retweet · favorite
    BoltLimoBus Feel like letting loose at the company holiday party? Let Bolt Transportation get you there in style and home... fb.me/2lP4maoBq
    50 days ago · reply · retweet · favorite
    BoltLimoBus December bus rides are booking up fast! Book YOUR Christmas party with us today! (619)888-1267
    52 days ago · reply · retweet · favorite
    BoltLimoBus "Don't Just Show Up, Make An Appearance!" Bolt Limo Bus is offering roundtrip service tonight, $300. Call... fb.me/1hv3ysxM9
    62 days ago · reply · retweet · favorite

    Join the conversation

    Notice: Undefined property: stdClass::$displayThemebox in /home/content/13/10297513/html/wp-content/themes/guesthouse/ait-cache/_wplatte/_Templates.main-layout.php-bef9bf662636eb3b3a70d87426457388.php on line 307'

    Thanks.

  14. joeshock
    Member
    Posted 1 year ago #

    Wow!

    Glad that at least brought some more insight to the picture. Clarity, not so much.
    Maybe try disabling all the other plugins one at a time except for the contact form 7 related ones and you might get something more clear.

  15. brandonecarr
    Member
    Posted 1 year ago #

    I couldn't wait any longer. My issue ended being an option within a Newsletter I was using. This option created a custom header and footer in every email I sent out from the site. Even if it wasn't coming from the newsletter. That meant emails come and going from CF7 received this custom header/footer as well. Once I figured this out, I just took the custom header/footer, and placed in in CF7, and checked the HTML box, and everything started working just the way I wanted it to. Thanks for your help Joe.

  16. brandonecarr
    Member
    Posted 1 year ago #

    Marking as resolved.

  17. Komplexideas
    Member
    Posted 1 year ago #

    Hi brandonecarr

    Would you be able to provide the specific steps on how you resolved this issue between the two plugins? I'm going through this now and would appreciate your help. Thanks in advance.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic