WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7 doesn't work with Permalink (27 posts)

  1. gbejarano
    Member
    Posted 5 years ago #

    I have configured my wordpress to use Permalinks and the Contact Form stopped to work, any clue? is there anyone who has the same problem?

    Thank you,

  2. Samuel B
    moderator
    Posted 5 years ago #

    where is the contact form?
    page? sidebar?

  3. gbejarano
    Member
    Posted 5 years ago #

    It's in a post.

  4. gbejarano
    Member
    Posted 5 years ago #

    actually I get a 404 page. that's what happens

  5. Syrion
    Member
    Posted 5 years ago #

    You have it in a post? Isn't it used on a page?

    I have several sites with pretty URL's and contact form 7 without problems.

  6. designbuyers
    Member
    Posted 5 years ago #

    Yes, its true..
    after i edit permalinks i came back to see the contact form i just do in pages not working in website it shows me [contact-form 1 "Contact form 1"]
    i mean the code not the form as before i edit the permalinks ..

  7. digitz
    Member
    Posted 5 years ago #

    Nope, it a WP-based error you're receiving. nothing to do with CF7.

    I've been using permalinks for like light years, and no problem with or without them in CF7.

    Try this:
    1. Enable Permalinks, make sure you specify relevant permissions in your .htaccess file to display fancy links
    2. Clear all you website cache if you're using a caching mechanism e.g. Super Cache, Widget Cache etc..
    3. Clear all your browser Cache, cookies etc...
    4. Reload the page.

    Hope this helps.

  8. designbuyers
    Member
    Posted 5 years ago #

    I am using google gears dose it effect it ?

  9. gabemortoncook
    Member
    Posted 5 years ago #

    I think this issue depends on how your server is handling your permalinks.
    I am running wordpress on IIS and have to use a 404-handler to create pretty permalinks. See here. This breaks Contact Form 7 (I just get a spinning arrow, and no validation or send request occurs).

    Any thoughts on a way around this?

  10. gabemortoncook
    Member
    Posted 5 years ago #

    I found a fix for my issue.

    In wp-contact-form-7.php

    I modified line 921 to the following:

    $url = '/index.php/'.parse_url($_SERVER['REQUEST_URI']);

    This adds back in the 'index.php' that was being removed by my 404 handler.

  11. gabemortoncook
    Member
    Posted 5 years ago #

    just updated... this change is now on line 35 of /includes/classes.php

  12. Perad
    Member
    Posted 5 years ago #

    I am also having this issue.

    It is strange, the first contact form works without issue. The second contact form redirects to a 404 page instead of to the main website. Both forms are embedded in pages.

    I also have permalinks enabled.

    I will give this fix a go.

  13. Perad
    Member
    Posted 5 years ago #

    OK, the above doesn't do anything for me. You can see for yourself what is going on here.

    http://gotyou.co.uk/photographers/

    Navigating directly to here works fine.

    http://gotyou.co.uk/photographers/#wpcf7-f3-p411-o1

    If you submit the form the above url happens but a 404 is displayed.

    Please note: I made a thread about this a while ago but got no responses. I am not trying to hijack this thread. However the person who posted this thread originally hasn't responded in a month and I believe that this is a more common issue than people currently think. Especially when it comes to making more than one form on a website. I believe it would be good to have a definitive solution for this so others will be able to solve their problems.

  14. kimblim
    Member
    Posted 4 years ago #

    I have the same problem right now - did anyone ever find a solution for this problem?

  15. threedogmoon
    Member
    Posted 4 years ago #

    My problem: I hard coded a flash music player into the sidebar on these two sites: http://www.youmademedoit.com and http://www.threedogmoon.com.

    On threedogmoon.com, the player shows up on any and every page. If you click on a category for example, it is there.

    On youmademedoit.com, the player only shows up on the home page. If you click on a category or the contact page, then it does not appear.

    I found the problem: I changed the permalinks settings from default to custom --- to /%postname%/ --- that made flash mp3 player disappear on all but the home page.

    I checked .htaccess and it is correct. It is being written to with no probs. I also called my server company to see that my server has AllowOverride Enabled. It does....

    Any ideas??????

  16. David Yeagley
    Member
    Posted 4 years ago #

    I'm sorry to intrude, but due to inadequate instructions ande general geekish procedures found on WordPress, I cannot start a forum or discussion question. I have to piggy-back on someone else's. I'm terribly sorry. I tried.

    Today, suddenly, Sunday, Oct. 11, 2009, I cannot work my own WordPress dashboard. I'm trying to edit a post (two days old--I found a misspelled word), and when I press "update", I get a window in the middle of the screen that says my website host "Magic" requires a user name and password! I won't accept any I have or use.

    Sounds like a virus or something to me. I've never seen it before. Here is the quote in the window:

    The server http://www.badeagle.com at Magic requires a username and password.

    Warning: This server is requesting that your username and password be sent in an insecure manner (basic authentication without a secure connection).

    Since WordPress is please to have no communication with customers, can any fellow user help me understand what to do here? I've never seen this before.
    Thanks.
    David Yeagley

  17. David Yeagley
    Member
    Posted 4 years ago #

    And now the new password Word Press gave me doesn't work the second time! Cut and paste. Nothing. No entry.

    What's going on at "WordPress"?

  18. David Yeagley
    Member
    Posted 4 years ago #

    Sorry to be a nerd, but, I have to get some kind of attention some how. I have a large site, with a lot of traffic. I can't be crippled like this because of glitches and lack of communication. Who is in charge? Who can instruct? How does one get help?

    I can't do anything on my own WordPress site (hosted by BlueHost, whom I've already called. They know nothing about the "Magic" window. My site, http://www.badeagle.com is hosted by BlueHost, but the software program is WordPress.

  19. threedogmoon
    Member
    Posted 4 years ago #

    These forums aren't very helpful. Nearly impossible to get a reply. I see other people's questions that are 5 months old without a reply. For such good software, very poor support. But it is free...

  20. threedogmoon, if you're not going to help...

    Anyway. David Yeagley the answer to your question is this. You've been hacked. You should have made a new topic for your problem, as it's not related to the plugin Contact Form 7, and this is probably why it's being missed.

    This is a known hack and vulnerability with an out of date version of WordPress.

    http://wordpress.org/support/topic/295409?replies=20
    http://wordpress.org/support/topic/295482?replies=72

    This is patched in the latest version of WordPress, and was the reason there was a fairly widespread alert going on to upgrade when that version came out.

  21. philosophy31
    Member
    Posted 4 years ago #

    put in an .htaccess redirect link from your old contact form url to your new contact form url. you can also try getting a wp plugin contact form form.

  22. darkhorn
    Member
    Posted 4 years ago #

    yes, permalinks does not work. i've done everthyng that is necessary. it shows me 404 error. why my wiki works but wordpress does not work?

  23. zemerica
    Member
    Posted 4 years ago #

    I have been struggling for this for the past few days... thanks to gabemortoncook for direction... with IIS I also had to do the 404-redirect.php solution he links to, but his solution did not work for me because my site is currently, temporarily, under site.com/wordpress/... or, previous to 404-redirect permalink solution, site.com/wordpress/index.php/... so I had to rewrite it a bit to make it work for me... in case it might help someone in a similar circumstance, here was my fix:
    in contact-form-7/includes/classes.php,
    I replaced
    $url = wpcf7_get_request_uri();
    with

    $rest = substr(wpcf7_get_request_uri(),10);
    $url = '/wordpress/index.php'.$rest.'/';

    where "10" is the number of letters in wordpress, plus 1 for the forward slash...
    if your site is under site.com/blog/ for instance, you would replace the 10 with 5 to subtract that portion of the string, and "/wordpress/" would then be "/blog/"
    I'm no code-master by any stretch of the imagination, so I wouldn't be shocked if there's a mistake here... but it works for me, in Opera, Firefox, and Internet Explorer, and I hope it helps someone avoid the lengthy troubleshooting process I just went through...

  24. macgig
    Member
    Posted 4 years ago #

    same problem here, worked for me until I changed default permalinks. now it wont work.

    what should I put in the htaccess file to fix it?

  25. macgig
    Member
    Posted 4 years ago #

    worked for me at first, until I changed themes, when I went back to the theme I had, it stopped working.

  26. esmi
    Forum Moderator
    Posted 4 years ago #

    @macgig: Post a new topic

  27. gabemortoncook
    Member
    Posted 4 years ago #

    Another update for latest version. See my posts above.

    If you are running wordpress on IIS and using a 404handler file for pretty permalinks, you need to go into wp-content\plugins\contact-form-7\includes\classes.php and add the base path to your index file on line 41:

    before: $url = wpcf7_get_request_uri();
    after: $url = '/index.php/'.wpcf7_get_request_uri();

Topic Closed

This topic has been closed to new replies.

About this Topic