WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7 - Captcha gets lost with WP SUperCache (3 posts)

  1. cmhwebster
    Member
    Posted 5 years ago #

    I've already raised this issue once, but got no reply, so here goes again.

    I'm using Contact Form 7 (1.9.5.1) on WordPress 2.7.1 with ReallySimpleCAPTCHA 1.0. I also have WPSuperCache on my site.

    Every couple of days, I find the Captcha images disappear from my forms - I get a broken image-link in the browser. If I clear the cache in WPSuperCache and then re-load the pages containing the forms in my browser, the Captcha is now OK.

    This is becoming a real nuisance, so does anybody know what might be happening here, and how I could fix it?

    If not, I'll have to abandon CF7 and try using some other solution.

  2. orbalon
    Member
    Posted 5 years ago #

    I'm curious about the answer to this as well. Though, I figure worse case I can always use the settings in SuperCache to exclude my contact form pages. Not ideal though.

  3. Kajover
    Member
    Posted 4 years ago #

    Use the option provided by WP Super Cache (quoted below) and add your page for instance "/contact/" to the list.

    Add here strings (not a filename) that forces a page not to be cached. For example, if your URLs include year and you dont want to cache last year posts, it’s enough to specify the year, i.e. ’/2004/’. WP-Cache will search if that string is part of the URI and if so, it will not cache that page.

Topic Closed

This topic has been closed to new replies.

About this Topic