WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form DB
Contact Form 7’s “Failed to send your message” error (7 posts)

  1. gvenguer
    Member
    Posted 2 years ago #

    for some reason i am getting: Contact Form 7’s “Failed to send your message” error once i submit the form. The issue is that the info appears on the back end of wp while the user is getting that message. Any ideas of how to fix this? thanks!
    http://www.massagekctoday.com/enter-to-win-a-free-massage/

  2. Michael Simpson
    Member
    Plugin Author

    Posted 2 years ago #

    Does it always happen or just sometimes?

  3. gvenguer
    Member
    Posted 2 years ago #

    it was just installed and its happening to me every time. my info does get registered but it says error. thanks for getting back to me.

  4. Michael Simpson
    Member
    Plugin Author

    Posted 2 years ago #

    I'm assuming you have version 1.8.5 installed.

    What I propose is in the Admin panel, go to Plugins, Editor, and select Contact form to DB Extension. Find and click CF7DBPlugin.php on the right side.

    Delete its content and replace with the content of this file.

    I simply added a little code to stop exceptions from being thrown from my plugin which might bubble up into CF7 and make it think it had an error with mail.

    Let me know if it works. If it does...I still don't know what the error is. check that all the info from the form submission ends up in the DB.

  5. Michael Simpson
    Member
    Plugin Author

    Posted 2 years ago #

    Try with new version 1.8.7

  6. kostas123
    Member
    Posted 2 years ago #

    Hi ,
    I have the same problem “Failed to send your message”.
    The messages are normal stored in the Database .

    CFDB is Version 1.8.7
    Contact Form 7 : Version 2.4.5
    The test is made on localhost with XAMP .

    Any ideas of how to fix this?
    Thanks!!!!

  7. aware
    Member
    Posted 2 years ago #

    @kostas123 If you are running on xampp you may want to go into your form and add in the setting

    demo_mode:on within the "additional settings" of your form(s). You probably cannot sent out smtp over port 25 is my guess by either your local firewall or by that port being blocked by almost all ISPs

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic