WordPress.org

Ready to get started?Download WordPress

Forums

Constant errors with strpos in WP 2.8 (6 posts)

  1. bishopneo
    Member
    Posted 4 years ago #

    Any time I add or edit an existing page or post in a clean install of wordpress 2.8 I get errores such as these:
    Warning: strpos() [function.strpos]: Empty delimiter in /Users/anthony/workspace/bishopneo/wp-admin/includes/file.php on line 73

    Warning: strpos() [function.strpos]: Empty delimiter in /Users/anthony/workspace/bishopneo/wp-admin/includes/file.php on line 73

    Warning: Cannot modify header information - headers already sent by (output started at /Users/anthony/workspace/bishopneo/wp-admin/includes/file.php:73) in /Users/anthony/workspace/bishopneo/wp-includes/classes.php on line 1586

    I can't find anything either here or on the web in general as to why this is happening all of a sudden. Again, this is a clean 2.8 install with no active plugins and using the default theme.

  2. whooami
    Member
    Posted 4 years ago #

    do you have a trailing forward slash after either your site or home url settings?

  3. bishopneo
    Member
    Posted 4 years ago #

    there is on the siteurl. But it's been that way for a year and never caused problems before.

  4. whooami
    Member
    Posted 4 years ago #

    that's immaterial really, and Im pretty confident that earlier versions of wordpress told you not to do that on that page :)

    at any rate, let's remove the / and see if your problem goes away. believe it or not, wordpress is smart enough to add its own trailing / if one is neccessary.

  5. bishopneo
    Member
    Posted 4 years ago #

    I did and it works. Thanks.

  6. missadventures
    Member
    Posted 4 years ago #

    Hi there,

    This is the exact problem I am having. Could you tell me what you mean by:

    do you have a trailing forward slash after either your site or home url settings?

    I looked in my settings in my admin panel and found no forward slash in my blog address URL. Am I looking in the right place?

    I need to fix this among many other problems on my site. I think this may help solve some of the other ones though.

    Thanks,
    Melanie

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.