WordPress.org

Ready to get started?Download WordPress

Forums

constant cycling of b2login.php (21 posts)

  1. Dorsai65
    Member
    Posted 10 years ago #

    Every time I try to log in, I'm taken back to the login page. I've verified my admin & password in the database, so I'm comfortable that I'm entering the correct data. Any idea what gives?
    Dorsai65

  2. Dorsai65
    Member
    Posted 10 years ago #

    Followup:
    This also happens when other users try to log in, as well.
    Dorsai65

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    Double check that the siteurl value is correct in your options table.

  4. Dorsai65
    Member
    Posted 10 years ago #

    My settings table does NOT have anything like a siteurl entry/value. What would the correct field name & other settings be, so I can enter it manually?
    Dorsai65

  5. Cena
    Member
    Posted 10 years ago #

    It's in the wp_options table.

  6. Dorsai65
    Member
    Posted 10 years ago #

    ???
    I don't have one of those - and I did a search for the wp_options string in all the files in the zip file I downloaded from SourceForge, too. How/when/where is it created, if I can't find a reference to it in any of the files?
    (very confused)
    Dorsai65

  7. Cena
    Member
    Posted 10 years ago #

    It's a database table created during the WP install. Do you have a tool like phpMyAdmin that you can use to work directly with your database?

  8. Dorsai65
    Member
    Posted 10 years ago #

    I do have phpMyAdmin.
    I would have thought that if the table was created during the WP install, the wp_options string would have shown up in one of the files.
    ah, well....
    Dorsai65

  9. Mike Little
    Member
    Posted 10 years ago #

    Dorsai65, which version of WordPress are you running?
    Mike

  10. Dorsai65
    Member
    Posted 10 years ago #

    From SourceForge, I got wordpress-071-gold.zip; unzipped it into it's own directory, then copied that to my web server's html directory.
    Dorsai65

  11. Cena
    Member
    Posted 10 years ago #

    Shoot. I told you wrong. Technically, the table created is not *necessarily* going to be 'wp_options'. The 'wp' part is a prefix for your db tables that you can set in wp-config, although the default IS 'wp'. So in other words, if you'd set your prefix to 'somethingelse', your db table would show up as 'somethingelse_options'.
    That's why you weren't able to find wp_options in any of your files.
    If you're curious, take a look at lines 16-25 of wp-config.php:
    $table_prefix = 'wp_'; // eg 'wp_' or 'b2' or 'mylogin_'
    $tableposts = $table_prefix . 'posts';
    $tableusers = $table_prefix . 'users';
    $tablesettings = $table_prefix . 'settings'; // only used during upgrade
    $tablecategories = $table_prefix . 'categories';
    $tablecomments = $table_prefix . 'comments';
    $tablelinks = $table_prefix . 'links';
    $tablelinkcategories = $table_prefix . 'linkcategories';
    $tableoptions = $table_prefix . 'options';

    I hope this clears it up for you a bit, and I have to say, my own curiosity about your problem led me to figuring out a little more about how WP works, so I should thank you for that. :)

  12. Dorsai65
    Member
    Posted 10 years ago #

    Hmmmm. I don't have wp-config.php; the zip file decompressed a b2config.php, which I duly edited with care.
    b2config.php includes the lines:
    // database tables' names (change them if you want to have multiple b2's in a single database)
    $tableposts = 'b2posts';
    $tableusers = 'b2users';
    $tablesettings = 'b2settings';
    $tablecategories = 'b2categories';
    $tablecomments = 'b2comments';
    // tables for link manager
    $tablelinks = "b2links";
    $tablelinkcategories = "b2linkcategories";
    but I'm still not finding any reference to a url field in any of the tables.
    Dorsai65
    (somewhat relieved I'm not being TOO much of a pain :-)

  13. Dorsai65
    Member
    Posted 10 years ago #

    I'd love to - except that .71 was all that SourceForge had to offer :-(
    If you could point me at a patch or the .72 files, I'd appreciate it.
    Either way, *nobody* can log into the blog until I get this resolved....
    Dorsai65

  14. Cena
    Member
    Posted 10 years ago #

  15. Dorsai65
    Member
    Posted 10 years ago #

    Cool. Got it. I can only hope this fixes the original problem :-/
    Dorsai65

  16. Dorsai65
    Member
    Posted 10 years ago #

    *shriek!*
    Did the upgrade to .72b - same problem (only prettier).
    Dorsai65

  17. Cena
    Member
    Posted 10 years ago #

    *Now* go look at your db (through phpMyAdmin) at the options table, and make sure your siteurl is correct.

  18. Anonymous
    Unregistered
    Posted 10 years ago #

    I had similar problem, and I did upgrade php to new version( 4.3.3 ).
    Wordpress(0.71) is working now. Why don't you try? :)

  19. Dougal Campbell
    Member
    Posted 10 years ago #

    You might also try clearing out your cookies.

  20. Anonymous
    Unregistered
    Posted 10 years ago #

    Simply make sure your session.save_path = in your php.in is set to a real folder like D:Temp (note I have missed out the forward slash as this board has html turned on and it gets translated into / )

  21. Anonymous
    Unregistered
    Posted 10 years ago #

    lol now it prints the / correctly...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.