WordPress.org

Ready to get started?Download WordPress

Forums

Easy WP SMTP
[resolved] Connection Refused (5 posts)

  1. mcdougaf
    Member
    Posted 10 months ago #

    Just tried setting this up and so far I cannot get the test email to work. I keep getting the same error message "Email could no be sent".

    The SMTP bug is: "SMTP -> ERROR: Failed to connect to server: Connection refused (111)
    "

    The full debug message is as follows (note, I removed the password for security reasons, but have confirmed that I am using the correct password):

    object(PHPMailer)#901 (58) {
      ["Priority"]=>
      int(3)
      ["CharSet"]=>
      string(5) "UTF-8"
      ["ContentType"]=>
      string(10) "text/plain"
      ["Encoding"]=>
      string(4) "8bit"
      ["ErrorInfo"]=>
      string(43) "SMTP Error: Could not connect to SMTP host."
      ["From"]=>
      string(23) "info@wildeyedesigns.com"
      ["FromName"]=>
      string(16) "Wild Eye Designs"
      ["Sender"]=>
      string(23) "info@wildeyedesigns.com"
      ["Subject"]=>
      string(5) "dfgdf"
      ["Body"]=>
      string(5) "dfgdf"
      ["AltBody"]=>
      string(0) ""
      ["MIMEBody":protected]=>
      string(6) "dfgdf
    "
      ["MIMEHeader":protected]=>
      string(484) "Date: Thu, 20 Jun 2013 19:34:45 +0000
    Return-Path: info@wildeyedesigns.com
    To: fiona@studiocartogram.com
    From: Wild Eye Designs <info@wildeyedesigns.com>
    Reply-To: Wild Eye Designs <info@wildeyedesigns.com>
    Subject: dfgdf
    Message-ID: <e8e36f7576396c3942590d60d0084f42@www.wildeyedesigns.com>
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.1 (http://code.google.com/a/apache-extras.org/p/phpmailer/)
    MIME-Version: 1.0
    Content-Transfer-Encoding: 8bit
    Content-Type: text/plain; charset="UTF-8"
    
    "
      ["SentMIMEMessage":protected]=>
      string(0) ""
      ["WordWrap"]=>
      int(0)
      ["Mailer"]=>
      string(4) "smtp"
      ["Sendmail"]=>
      string(18) "/usr/sbin/sendmail"
      ["PluginDir"]=>
      string(0) ""
      ["ConfirmReadingTo"]=>
      string(0) ""
      ["Hostname"]=>
      string(0) ""
      ["MessageID"]=>
      string(0) ""
      ["Host"]=>
      string(22) "Smtp04.sherweb2010.com"
      ["Port"]=>
      string(3) "587"
      ["Helo"]=>
      string(0) ""
      ["SMTPSecure"]=>
      string(3) "ssl"
      ["SMTPAuth"]=>
      bool(true)
      ["Username"]=>
      string(19) "info_wildeyedesigns"
      ["Password"]=>
      string(8) "*******"
      ["Timeout"]=>
      int(10)
      ["SMTPDebug"]=>
      int(2)
      ["SMTPKeepAlive"]=>
      bool(false)
      ["SingleTo"]=>
      bool(false)
      ["SingleToArray"]=>
      array(0) {
      }
      ["LE"]=>
      string(1) "
    "
      ["DKIM_selector"]=>
      string(9) "phpmailer"
      ["DKIM_identity"]=>
      string(0) ""
      ["DKIM_passphrase"]=>
      string(0) ""
      ["DKIM_domain"]=>
      string(0) ""
      ["DKIM_private"]=>
      string(0) ""
      ["action_function"]=>
      string(0) ""
      ["Version"]=>
      string(5) "5.2.1"
      ["XMailer"]=>
      string(0) ""
      ["smtp":protected]=>
      object(SMTP)#902 (8) {
        ["SMTP_PORT"]=>
        int(25)
        ["CRLF"]=>
        string(2) "
    "
        ["do_debug"]=>
        int(2)
        ["do_verp"]=>
        bool(false)
        ["Version"]=>
        string(5) "5.2.1"
        ["smtp_conn":"SMTP":private]=>
        bool(false)
        ["error":"SMTP":private]=>
        array(1) {
          ["error"]=>
          string(38) "Called Reset() without being connected"
        }
        ["helo_rply":"SMTP":private]=>
        NULL
      }
      ["to":protected]=>
      array(1) {
        [0]=>
        array(2) {
          [0]=>
          string(25) "fiona@studiocartogram.com"
          [1]=>
          string(0) ""
        }
      }
      ["cc":protected]=>
      array(0) {
      }
      ["bcc":protected]=>
      array(0) {
      }
      ["ReplyTo":protected]=>
      array(1) {
        ["info@wildeyedesigns.com"]=>
        array(2) {
          [0]=>
          string(23) "info@wildeyedesigns.com"
          [1]=>
          string(16) "Wild Eye Designs"
        }
      }
      ["all_recipients":protected]=>
      array(1) {
        ["fiona@studiocartogram.com"]=>
        bool(true)
      }
      ["attachment":protected]=>
      array(0) {
      }
      ["CustomHeader":protected]=>
      array(0) {
      }
      ["message_type":protected]=>
      string(5) "plain"
      ["boundary":protected]=>
      array(3) {
        [1]=>
        string(35) "b1_e8e36f7576396c3942590d60d0084f42"
        [2]=>
        string(35) "b2_e8e36f7576396c3942590d60d0084f42"
        [3]=>
        string(35) "b3_e8e36f7576396c3942590d60d0084f42"
      }
      ["language":protected]=>
      array(17) {
        ["provide_address"]=>
        string(54) "You must provide at least one recipient email address."
        ["mailer_not_supported"]=>
        string(25) " mailer is not supported."
        ["execute"]=>
        string(19) "Could not execute: "
        ["instantiate"]=>
        string(36) "Could not instantiate mail function."
        ["authenticate"]=>
        string(35) "SMTP Error: Could not authenticate."
        ["from_failed"]=>
        string(35) "The following From address failed: "
        ["recipients_failed"]=>
        string(45) "SMTP Error: The following recipients failed: "
        ["data_not_accepted"]=>
        string(30) "SMTP Error: Data not accepted."
        ["connect_host"]=>
        string(43) "SMTP Error: Could not connect to SMTP host."
        ["file_access"]=>
        string(23) "Could not access file: "
        ["file_open"]=>
        string(33) "File Error: Could not open file: "
        ["encoding"]=>
        string(18) "Unknown encoding: "
        ["signing"]=>
        string(15) "Signing Error: "
        ["smtp_error"]=>
        string(19) "SMTP server error: "
        ["empty_message"]=>
        string(18) "Message body empty"
        ["invalid_address"]=>
        string(15) "Invalid address"
        ["variable_set"]=>
        string(30) "Cannot set or reset variable: "
      }
      ["error_count":protected]=>
      int(2)
      ["sign_cert_file":protected]=>
      string(0) ""
      ["sign_key_file":protected]=>
      string(0) ""
      ["sign_key_pass":protected]=>
      string(0) ""
      ["exceptions":protected]=>
      bool(true)
    }


    [Please use the code buttons when posting things like this]

    http://wordpress.org/extend/plugins/easy-wp-smtp/

  2. wpecommerce
    Member
    Plugin Author

    Posted 8 months ago #

    Hi, this error usually occurs when your user credentials are wrong. please make sure the all the information entered in the settings is correct.

  3. vagabond360
    Member
    Posted 8 months ago #

    I have the same problem as above and have the correct settings. checked, rechecked and checked again. But when I run a test it still says email could not be sent. what is wrong?

  4. project18
    Member
    Posted 7 months ago #

    I have the same problem. Also tried different email accounts to see if I could get any to work, but having no luck. Does anyone on this thread have some tips for me?

  5. silvercolt45
    Member
    Posted 4 months ago #

    Same issue here. I have also confirmed credentials a number of times. Also insured my [mail function] php ini settings were in place and correct. I have also tried ssl and non-ssl connections (465/25). I have also tried placing smtp account email address in the from name field as some have suggested. No luck all around.

Reply

You must log in to post.

About this Plugin

About this Topic