WordPress.org

Ready to get started?Download WordPress

Forums

[closed] "Connection lost..." problem in 3.9 (13 posts)

  1. saintandrews
    Member
    Posted 4 months ago #

    After the upgrade to 3.9, I've begun experiencing interminable "Connection lost. Saving has been disabled until you’re reconnected. We’re backing up this post in your browser, just in case." lockups.

    The two posts successfully posted since that upgrade threw these calls which no prior update has

    REQUEST.data.wp_autosave.content

    POST.data.wp_autosave.content

    both to /wp-admin/admin-ajax.php

    As I mentioned in this thread,

    http://wordpress.org/support/topic/382-update-likely-false-connection-lost-message?replies=4

    I was able to make the second post successfully after logging back in and pasting in the complete text, whereupon I discovered the second PHP alert never seen previously.

    Because no plugins or other variables have yet been introduced or altered, the 3.9 upgrade itself seems to be driving those novel calls.

  2. Please post all your details in this thread :) the point of having separate threads is that no two people have identical set ups.

    Include your plugins, what debugging steps you've taken, and what tweaks you made already.

  3. saintandrews
    Member
    Posted 4 months ago #

    Very well, since my initial post

    - a privately published post was successfully made, viewed, trashed, and permanently deleted without any "Saving..." issues or PHP calls

    - a public draft post was successfully made and previewed. When I attempted to trash it, the "Saving..." issue presented itself, then a 404. Refreshing the 404 page showed the test draft successfully trashed, whereafter it was successfully deleted permanently. No PHP calls were recorded

    - no plugins were altered

    - the only variable changed was that the autosave interval in wp-config.php was increased from 120 seconds to 300 seconds. I may now double that as well to 600, just to be sure.

  4. ccolotti
    Member
    Posted 4 months ago #

    I have started seeing this too with the 3.9 upgrade on multiple sites. I started editing and when it goes to seemingly autosave it posts the disconnection issue and never comes back. I need to close the browser completely yo get it to work. Sounds like a bug to me!

  5. ccolotti
    Member
    Posted 4 months ago #

    I recently installed Broken Link Checker through IWP and disabled it the connection problem went away....so it could be a plugin issue.

  6. saintandrews
    Member
    Posted 4 months ago #

    I recently installed Broken Link Checker through IWP and disabled it the connection problem went away....so it could be a plugin issue.

    After increasing my autosave interval to 600 seconds, I also disabled Broken Link Checker per your comment simply as a precaution. Overnight, two users each made a post, and each post produced the same

    REQUEST.data.wp_autosave.content

    POST.data.wp_autosave.content

    calls to /wp-admin/admin-ajax.php previously noted.

    I don't know what they experienced in the process of creating their posts, which were ultimately successful.

    This leads me to conclude, first, that the BLC plugin is not the culprit, at least not on my site and, second, that the autosave line in my wp-config.php

    define('AUTOSAVE_INTERVAL', 600 );

    is either no longer effective, incorrect, incorrectly placed, or now simply ignored by WordPress, at least with respect to producing this phenomenon.

    As I previously mentioned, I myself have not been able to consistently duplicate the interminable "Connection lost. Saving..." problem with all plugins enabled, leaving me to question the value of laboriously testing with plugins randomly on/off; as mentioned, with BLC disabled the problem recurred.

    I'm continuing to research this across the many information stovepipes available, and I'm seeing others with the same autosave-related experience with 3.9, some claiming to be related to plugins, some not.

  7. vtrs
    Member
    Posted 4 months ago #

    Did you send that logs in your hosting provider?

    I think its a server side problem not wp

  8. As I previously mentioned, I myself have not been able to consistently duplicate the interminable "Connection lost. Saving..." problem with all plugins enabled, leaving me to question the value of laboriously testing with plugins randomly on/off; as mentioned, with BLC disabled the problem recurred.

    Just to be clear, you're saying that it always (or mostly) happens with BLC on, but rarely with it off?

    That sounds like it's twofold

    1) You're running out of PHP memory at some point in the publishing process

    2) BLC is making it worse

    Can you bump your PHP memory AND the timeouts? I think vtrs is right, though, and something's wonky on the server. Why would this crop up now? Things are being re-cached since you upgraded, or maybe happenstance. I go through periods where my site is hella popular too.

  9. saintandrews
    Member
    Posted 4 months ago #

    Sorry, Mika, I've been off the grid for a week and haven't been online at all.

    Just to be clear, I was saying that, first, since bumping my autosave interval immediately upon experiencing the problem myself (and perhaps having had a re-cache occur during that posting/problem process), I myself have not been able to reproduce the problem. I subsequently turned BLC off after ccolotti's post simply as an added precaution since BLC is not a critical plugin.

    The main thing I've noticed, again, is that my PHPIDS plugin has been registering REQUEST/POST.data.wp_autosave.content calls on /wp-admin/admin-ajax.php on every post and post edit continuously since 3.9, which it had never been doing previously.

    I first noticed these alerts at the time I myself experienced the interminable saving problem. Since changing my autosave interval to 10 minutes, I myself have experienced no problem, multiple other authors have made multiple posts and have said nothing yet about having any difficulty (although I have yet to pointedly inquire), and PHPIDS keeps clicking off alerts on ajax.php. After having been gone a week, it's up to 99 alerts or so.

    This, to me, points to a rewiring of autosave and ajax in the new 3.9 as being implicated in the process, regardless of the actual autosave interval. Because I raised my interval to 10 minutes and thereafter haven't yet reproduced the problem, I'm imagining it may be related to the specific autosave interval itself; the PHPIDS alerts are ultimately only a response to new code previously invisible or considered benign.

    Finally, it could very well be my shared server. Every time I inquire of my dreamy host, however, server loads are nominal and everything is working perfectly; my host, therefore, will never be a problem I can actually address.

    I'm confident WordPress will get around to fixing this. The autosave thing is not a new problem. It was a nuisance some time back, prompting a flurry of queries on how to raise the interval; I myself raised it back when to 120.

    Plugins may indeed aggravate the problem, but they are not generating previously unseen code calls on ajax.php as detailed above: the root of the problem seems to lie there, at least from all the reliable information I have.

  10. saintandrews
    Member
    Posted 3 months ago #

    I should update this to stress that just a few days after I deactivated Broken Link Checker - again, after I had reset my autosave interval to 10 minutes, upon which the problem seemed to disappear - I reactivated BLC and have yet to have had any problems since.

    My personal feeling remains that this problem may be related to an increased reliance on admin-ajax.php which at least one plugin author has previously noted, by having previously offered configuration alternatives to using it, can be resource intensive, and so it may be the case that it is the increased calls to admin-ajax.php which are spiking CPU memory usages beyond their allowed limits and in so doing severing the connection.

  11. luongxuancong77
    Member
    Posted 3 months ago #

    i have Same error WP 3.9 Connection lost. Saving has been disabled until you’re reconnected. We’re backing up this post in your browser, just in case.
    Help me

  12. cbrendlinger
    Member
    Posted 2 months ago #

    I have the same error when editing both posts and pages. It does not seem to cause a problem overall, although I guess that nothing is actually getting autosaved. However, all of my updates seem to work just fine. I have tried re-installing WordPress and adding the define('AUTOSAVE_INTERVAL', 160 ); to wp-config.php but have had no success. I am running WordPress 3.9.1 and would love a resolution if anyone has found one. Broken Link Checker is not installed on my site. Thanks for your help.

  13. esmi
    Forum Moderator
    Posted 2 months ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else's topic.

    I am now closing this month old topic as it references an older version of WordPress.

Topic Closed

This topic has been closed to new replies.

About this Topic