WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Congifuration Nightmare - home server setup problems (38 posts)

  1. robatbentley
    Member
    Posted 1 year ago #

    I moved away from raw HTML/Jquery to WordPress to avoid complicated integration issues every time I changed my web-site. Now I've replaced it with post-installation configuration issues where I fix one thing and another breaks. Need some help on this.

    Problem Scenarios:
    1) Log into my wordpress dashboard. Go to "Visit Site" and then can't get back to Dashboard. Have to create new Dashboard sessions. Yikes!
    2) Have dynamic IP address allocation from my router. When router IP address changes, my site can't display pictures. Path references old IP address.
    3) www users can't see my blog - timeouts or lost formatting.

    My setup:
    1) Domain (bentleyridingcentre.co.uk) set to point to routers IP address. e.g. http://31.54.133.60/wordpress/
    2) WordPress Address (URL) set to my web-servers IP in wp-config. i.e. define('WP_SITEURL', 'http://192.168.1.66/wordpress');
    3) WordPress Site Address (URL) set to http://bentleyridingcentre.co.uk in settings/general
    4) Router setup with port-forwarding on 80, 443, 3306, 3389 & 4125.

    Been trying to figure this out for days. Tried configuring based on some of the forum related issues. e.g. Set both wordpress & site address to my domain but then lost localhost login to dashboard.

    Can anyone help or point me to a tutorial/video that actually goes thru this step-by-step?
    Thanks in anticipation.

    PS: The only success I had today is when I finally lost it with my router and opened up all ports to my web-server. Everything worked except I now had a server that was vulnerable. Stepped back from there and now trying to get it working properly.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have dynamic IP address allocation from my router

    I don't think that is ever going to work. You need a static IP address.

  3. robatbentley
    Member
    Posted 1 year ago #

    I don't think that is ever going to work. You need a static IP address.

    Not quite there with dynamic DNS. Just trying to see if I can get the basics up and running first. ...and not doing too well so far.

  4. Putting aside the static vs dynamic (really should be static on your side) if the DNS name bentleyridingcentre.co.uk resolves to the external IP of your router then this should work. Right now that does not seem to be the case.

    bentleyridingcentre.co.uk. 3600	IN	A	213.171.195.53

    Try configuring your router if you can to use one of the many dynamic DNS. The one I use is from dyndns.org and once my router had the config I just had to alias the record I wanted to that one.

    In your case (as an example) it would look like this instead of an A record.

    bentleyridingcentre.co.uk.	1800	IN	CNAME	bentleyridingcentre.dyndns.org.

    http://31.54.133.60/wordpress/readme.html does work so your port forwarding is good.

    As a temporary work around try changing the WordPress Address (URL) to http://31.54.133.60/wordpress/ like you did with the WordPress Site Address (URL).

    That will let you access your WordPress installation externally by IP address.

  5. robatbentley
    Member
    Posted 1 year ago #

    As a temporary work around try changing the WordPress Address (URL) to...

    Changed as you recommended (in WP_CONFIG). i.e.
    "define('WP_SITEURL', 'http://31.54.133.60/wordpress');"

    Tried various URLs to link to the wordpress dashboard login page (which I'm doing from my LAN behind the router - no alternative!) but browser just times out (after few minutes) and produced the unformatted login page.

    I will be doing all of my wordpress site development from inside my router LAN.

    Any suggestions?

  6. robatbentley
    Member
    Posted 1 year ago #

    Just to help set the context of my problem.
    I have a web-server (WHS 2011) & a Windows 7 PC running behind my routers firewall.

    I want to host my live site on my webserver
    I want to be able to develop my WP site by logging into WP (on the webserver) from my Win7 PC.
    I want customers to see my WP site hosted on my webserver

    None of the above currently work.
    This is why I'm looking for help. I am totally stuck as to how to get this environment working.

  7. This URL for logging in may work for you.

    http://31.54.133.60/wordpress/wp-admin/

    Using that will let you go out (not really out) and make a u-turn to log into your installation.

    I will be doing all of my wordpress site development from inside my router LAN.

    Any suggestions?

    For development have you considered running an installation on your PC via localhost?

  8. robatbentley
    Member
    Posted 1 year ago #

    Jan,

    This URL for logging in may work for you.
    http://31.54.133.60/wordpress/wp-admin/

    Nope. Just hangs my browser until it eventually provide the login page without nay formatting.

    For development have you considered running an installation on your PC via localhost?

    Yup. ...and it's currently the only WP instance that actually works. Based on XAMPP stack. The web-server is based on Web Platform Installation (IIS et al). My preference is to go for a dual stack: develop techniques on my Win7 PC and then implement them on my webserver.

  9. robatbentley
    Member
    Posted 1 year ago #

    As a temporary work around try changing the WordPress Address (URL) to http://31.54.133.60/wordpress/

    Sorry Jan, had to change this back to my web-server IP as define('WP_SITEURL', 'http://192.168.1.66/wordpress'); as it was killing all my access to the WP dashboard.

    Current status (post reboot of web-server & above changes)

    Router IP: 31.54.133.60
    Web-Server IP: 192.168.1.66
    On my Win7 PC using "http://31.54.133.60/wordpress/wp-admin/", I can now log into my web-server WP instance.
    On Win 7, I can view my live WP site using the router IP http://31.54.133.60/wordpress/ and bentleyridingcentre.co.uk
    Unknown - can anyone see my site from www?

    Configuring my web-server WP instance just can't be that difficult.
    Surely, there are only a limited number of variables that are currently killing my setup?

    The variables:

    My domain config of forwarding bentleyridingcentre.co.uk to my router IP. i.e. http://31.54.133.60/wordpress/ I am reasonably confident that this is the correct way to go. i.e. I can see my live site when using bentleyridingcentre.co.uk in browser.
    My router port forwarding. As stated above (and feedback from Jan "http://31.54.133.60/wordpress/readme.html does work so your port forwarding is good." leads me to believe that this is also okay.
    WP setting for Site URL - reasonably confident this is correct! I can now log into the dashboard.
    WP setting for blog URL - reasonably confident that this is also correct

    So what am I having problems with?
    Testing if my live site is viewable from WWW. Any kind people out there?

  10. ClaytonJames
    Member
    Posted 1 year ago #

    Just ball-parking here...

    //192.168.1.66/wordpress/xmlrpc.php

    //192.168.1.66/wordpress/wp-content/plugins

    If your domain is being forwarded to your external ip address, and the router is forwarding to the server successfully (which it seems to be) what purpose is there for a static internal network ip address in your wordpress urls instead of your domain name?

  11. ClaytonJames
    Member
    Posted 1 year ago #

    Just an afterthought here; you can probably solve the localhost (lack of) access issue by placing an entry in the hosts file (the machine hosts file, not the web-server/IIS config) that resolves your domain name to 127.0.0.1, although I can't image that a properly configured virtual host container would fail to resolve your domain name back to the machine properly.

  12. robatbentley
    Member
    Posted 1 year ago #

    what purpose is there for a static internal network ip address in your wordpress urls instead of your domain name?

    Good point, so I'll experiment.

    Current setup and status:
    * bentleyridingcentre.co.uk forwards to http://31.54.133.60/wordpress
    * Router IP: 31.54.133.60
    * Webserver IP: 192.168.1.66
    * WordPress Address (URL): http://192.168.1.66/wordpress
    * Site Address (URL): http://bentleyridingcentre.co.uk

    ** Using http://31.54.133.60/wordpress/wp-admin successfully takes me to the web-server WP login page from my Win7 PC.
    ** Still have problem visiting site from dashboard. Unable to return to dashboard.
    ** Can't test www access to my site

    ...and now modify...
    WordPress Address (URL): http://192.168.1.66/wordpress
    to
    WordPress Address (URL): http://bentleyridingcentre.co.uk
    i.e. define('WP_SITEURL', 'http://bentleyridingcentre.co.uk');
    After a server reboot and clear cache...
    ** Using bentleyridingcentre.co.uk presents unformatted site.
    ** Ditto when using http://31.54.133.60/wordpress/wp-admin. i.e. Can't logon from Win7 PC
    ** Ditto when using http://192.168.1.66/wordpress/wp-admin

    Worth a try but no go on this change.
    I'll reset WordPress Address (URL) back to IP address of the server to get it partially working again. Not sure if there's anything learned from this except the combination of internal port forwarding and WP settings don't behave as predicted.

    Reset, rebooted and cleared cache - back to where I was before this experiment.

  13. The problem is that you really need to have the Site URL and WordPress address pointing to the same thing. And that same thing has to actually work. ;)

    The DNS name bentleyridingcentre.co.uk points to 213.171.195.53. Your router IP is 31.54.133.60 so using that DNS name in your WordPress install just will not work. Until you get that DNS name resolving to your address don't use it.

    You can use a WordPress address and site URL of http://31.54.133.60/wordpress (they need to be the same) but apparently that does not work for you (but will work for people off of your network). Maybe your router doesn't like u-turns?

    If you use 192.168.1.66 for anything, that may work for you but it will not and cannot work for anyone on the Internet. That's private address space and will only work for you behind your router.

    This is the setup that works for me. My basement server is behind my router with a 192.168.1.x address too. The DNS name I use resolves to my routers external IP address (I use DynDNS) and I set my WordPress address and Site URL to the DNS name that I use.

  14. robatbentley
    Member
    Posted 1 year ago #

    The DNS name bentleyridingcentre.co.uk points to 213.171.195.53. Your router IP is 31.54.133.60 so using that DNS name in your WordPress install just will not work.

    Jan, Looks like changes to my domain name have not yet been flushed thru to other DNS serves. I had to change the forwarding of my domain name from 213.171.195.53 to 31.54.133.60 about 2 days ago.

    How did you test the IP that my domain was pointing to? ...as I can't "see" this from inside my router LAN.

    The reason for the domain update was because I configured my router to open all ports to my server. ...which actually made everything work! ...but had to change it back again cos I was concerned about security issues. ...and in the process of rebooting my router, it updated my routers IP address (and the internal server one too) so had to update my domain forwarding. I've also removed the "masked" option on my domain name so that I should be able to see where it's actually pointing to in future.

    The problem is that you really need to have the Site URL and WordPress address pointing to the same thing.

    This makes a lot of sense, and is supported by the fact that when I opened-up all ports (to my server) on my router both the router and the server ended-up with the same IP address. ...and updated WP settings accordingly. Don't know if this is just a quirk of my BT2700HGV v2 router or it's meant to do this with any router.

    Sounds like I will have to wait until my domain changes have been flushed thru before I try WO setting updates. As per my question above, I don't know how I can check my domain forwarding setup (from an external network users perspective) from inside my router LAN. Any suggestions?

  15. robatbentley
    Member
    Posted 1 year ago #

    I don't think that is ever going to work. You need a static IP address.

    Oh blimey limey! BT have just updated my router from dynamic to new static IP address of 81.149.17.79. ...so all change then! Thought the on-line order would take days to come thru but they did instantly.

    The problem of seriously delayed flushing (a few days by the look of it) of any dynamic IP changes on my domain would be a serious problem to my business, so thought I'd get that one fixed (no pun intended).

    I'll update all the settings and wait a few days (fush updates to domain forwarding) to see if this fixes my problem. Will report back here either way.

    Thanks to all the support you've given me. Really appreciate it.

  16. robatbentley
    Member
    Posted 1 year ago #

    A friend tried accessing my sited using my new static router IP address. i.e. http://81.149.17.79/wordpress/
    ...but failed! ...in that it only produced an unformatted version after about 3 minutes of searching.

    Not a good sign...

  17. ClaytonJames
    Member
    Posted 1 year ago #

    Yep'. Because now you have placed the word "server" in your urls where the domain name should be.

    //server/wordpress/xmlrpc.php

    //server/wordpress/wp-includes

  18. robatbentley
    Member
    Posted 1 year ago #

    Yep'. Because now you have placed the word "server" in your urls where the domain name should be.

    If I change my WP Address (URL) from
    http://server/wordpress
    to my domain (which has been modified to my routers NEW static IP address only hours ago) then surely I'll be back in the same situation where nothings works in above experiment? ...because the updated domain won't yet be accessible anyone else yet

    The Site Address (URL) is already set to the domain.
    What are suggesting I now set my WP Address (URL) to? ...servers private IP, new router static IP, recently modified but unflushed domain?

  19. robatbentley
    Member
    Posted 1 year ago #

    Yep'. Because now you have placed the word "server" in your urls where the domain name should be.

    There you go, reset it back to domain name to be cooperative:

    define('WP_SITEURL','http://bentleyridingcentre.co.uk');

    Result:
    I can't fully load (unformatted) my own live site using http://bentleyridingcentre.co.uk despite my browser indicating that it's translating to http://81.149.17.79/wordpress/ (which is my routers new static ip address).

    Attempts to log into dashboard also fail - time-out!

    Any suggestions?

  20. ClaytonJames
    Member
    Posted 1 year ago #

    Let me ask this; why are you manually defining the url in wp-config?

  21. robatbentley
    Member
    Posted 1 year ago #

    Let me ask this; why are you manually defining the url in wp-config?

    ...because I was experimenting with the WP Address (URL) settings via the dashboard which ended-up preventing me from logging-in. I then reset it back to it's original setting but could only do this via the WP-CONFIG file. Thereafter, the value was grey'd-out in the dashboard general setting. Even tried commenting the offending line of code in the WP-CONFIG file but then couldn't get the dashboard login page to appear - timeout problems.

    Any suggestions as to how to resolve this?

  22. Humor for a minute and just for testing can you put both of these into your configuration?

    define('WP_HOME','http://bentleyridingcentre.dn7.me/wordpress');
    define('WP_SITEURL','http://bentleyridingcentre.dn7.me/wordpress');

    Please reply back here when that's done (I'm subscribing to this topic) and leave that there for now. Both lines not just one.

  23. robatbentley
    Member
    Posted 1 year ago #

    Humor for a minute and just for testing can you put both of these into your configuration?

    Done! ...both lines!

  24. Okay! So static content works for me:

    http://bentleyridingcentre.dn7.me/wordpress/readme.html
    http://bentleyridingcentre.dn7.me/wordpress/wp-content/plugins/akismet/readme.txt

    But dynamic content such as

    http://bentleyridingcentre.dn7.me/wordpress/

    And

    http://bentleyridingcentre.dn7.me/wordpress/index.php

    is tossing 500 Server errors.

    Do you have any plugins activated? You can comment out those lines and try to get in via the native IP address (after those lines are removed). The web server is fine but it looks like something in WordPress is well and truly confused. ;)

    http://192.168.1.66/wordpress/wp-admin/

  25. robatbentley
    Member
    Posted 1 year ago #

    Do you have any plugins activated? You can comment out those lines and try to get in via the native IP address (after those lines are removed).

    Not sure what you mean. Is there a file where plug-ins are defined or do you want me to reset the wp-config and remove the plug-in content from the pages themselves? i.e. via dashboard.

    ...but yes, I have 1 active plug-in, one of the AnythingSliders or similar. ...but a couple of other sliders that I'd deactivated as they looked too heavy.

    But dynamic content such as

    I've successfully tested www access to one of my dynamic (but not WP) dummy sites hosted on the same server under the brs06/index.html instead of /wordpress. This brs06 has loads of sliders and my mate (in www land) can see all this stuff fully formatted.

    I agree. I also think there's something messed-up in either the WP installation of config.

  26. Do you mind starting from scratch? You don't have to delete anything just try these steps.

    1 - Make a backup copy of your existing wp-config.php file. I suggest renaming it to wp-config-old.php.

    2 - Copy wp-config-sample.php to wp-config.php and edit that new copy with your database settings.

    3 - Make one more change to that new wp-config.php file: change the line that says

    $table_prefix  = 'wp_';

    to read

    $table_prefix  = 'brc_';

    Then visit http://bentleyridingcentre.dn7.me/wordpress/wp-admin/install.php and create a new empty WordPress installation.

    What that will do is let you create a new installation using a different table prefix. This will (hopefully!) let you start from scratch.

  27. robatbentley
    Member
    Posted 1 year ago #

    Do you mind starting from scratch?

    Followed your steps...
    Tried using http://bentleyridingcentre.dn7.me/wordpress/wp-admin/install.php but the browser just hung - waiting for...

    Just wondering if a total re-instal via Web Platform Installer is on the cards

  28. *Jan weeps.*

    I'm out of ideas. :( Put the old wp-config.php file back and you'll be right where you were.

    It looks like your router really does not like doing u-turns. From the Internet the installer screen comes up without any issue. From your home 192.168.1.x network it looks like that u-turn just will not work.

    It's odd as many of us do host a WordPress installation that way but it's just not working for you.

  29. robatbentley
    Member
    Posted 1 year ago #

    Thanks for giving it a go.
    I'm calling it a day and re-introducing myself to my family.
    Fresh start tomorrow...

  30. robatbentley
    Member
    Posted 1 year ago #

    Think this problem is related to my BT2700HGV v2 router and it's inability to bounce domain URLs from my Win-7 PC to router to web-server.

    So am off to buy a BT Business Hub 3 to see if this makes any difference. ...if not, then I have a spare (with uPnP).

    Any feedback as to whether this is a good or bad idea will be appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic