WordPress.org

Ready to get started?Download WordPress

Forums

Better WordPress Minify
conflict with Use Google Libraries 1.5.2? (12 posts)

  1. Steve Taylor
    Member
    Posted 1 year ago #

    FYI, I think Use Google Libraries 1.5.2 has created a conflict with the Better WordPress Minify plugin. They've been playing fine together until now. Not sure where the conflict is, but thought I'd flag it.

    http://wordpress.org/extend/plugins/bwp-minify/

  2. Khang Minh
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm never had a problem with that plugin before. I will check it, thank you.

  3. Steve Taylor
    Member
    Posted 1 year ago #

    I've never had problems either. I checked the 1.5.2 changes on the changelog and there seem to be changes that may have affected things. I would dig into it myself, but no time - thought I would let people know anyway.

  4. Jason Penney
    Member
    Posted 1 year ago #

    Starting with WordPress 3.5, the script loader supports protocol-relative URLS, to more easily support SSL. With 1.5.2 I added support for this to Use Google Libraries as well.

    At a guess I'd say that BWM's is_local returns true for these, when it should return false. WordPress's own registrations for some older scripts work this way now.

    Update: It seems this is a "limitation" of php's parse_url and won't be fixed in php, so it may need to be handled directly.

  5. Steve Taylor
    Member
    Posted 1 year ago #

    Thanks Jason! Will pass this on to the BWM author.

  6. Steve Taylor
    Member
    Posted 1 year ago #

    OK, I got the wrong thread :-) I'll leave this open for discussion here.

  7. Bill Dennen
    Member
    Posted 1 year ago #

    I'm seeing a conflict, too, after upgrading.

  8. Khang Minh
    Member
    Plugin Author

    Posted 1 year ago #

    This will be fixed in the next version.

  9. fuzzyness
    Member
    Posted 11 months ago #

    Great news. Any idea when the next version may land?

  10. Jason Penney
    Member
    Posted 9 months ago #

    FYI: this is still not fixed.

    The test for protocol-relative URLS is incorrect.

    It seems to be checking for URLSs that start '://' but protocol-relative URLs start with '//'.

    You can see this is WordPress core inside wp-includes/script-loader.php:

    $scripts->add( 'prototype', '//ajax.googleapis.com/ajax/libs/prototype/1.7.1.0/prototype.js', array(), '1.7.1');

  11. andersha
    Member
    Posted 6 months ago #

    Hi Jason or oddoneout,

    Any news on this topic? I am experiencing the same conflict between BWM and libraries.

    Best Anders

  12. Khang Minh
    Member
    Plugin Author

    Posted 6 months ago #

    1.3.0 will fix this issue, you can follow dev update here: https://github.com/OddOneOut/Better-WordPress-Minify

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic