WordPress.org

Ready to get started?Download WordPress

Forums

jQuery Pin It Button For Images
[resolved] Conflict with Theme - I think bc JQUERY loaded 2x (4 posts)

  1. brightonkeller
    Member
    Posted 6 months ago #

    Hi,

    First I want to say that I am BEYOND impressed with the progress of this plugin and I want to applaud you for all your hard work and success. I've been following/using (off and on along the way of version and updates) for almost a year now I think! Good work!

    Secondly, I want to preface my support question by giving you a heads up that I'm using Pagelines DMS, which is a (interestedly enough, a phrase Pagelines coined themselves) "Design Management System". As such, the framework or whatever you want to call it already load a number of scripts and such for the different sections offered within the system. JQUERY is already loaded within the Pagelines Framework. Although I do not know if this is the issue - this was the only possible reason I could find.

    The plugin works wonderfully! BUT it actually deactivates the frontend editor provided by DMS. Typically, the interface is a sort of tabbed admin screen that pops up at the bottom (when logged into blog) that resembles a code inspector. Anyway, when I have your plugin enabled, the web editor is all messed up.

    Questions:
    1. Is there a way to disable jquery being loading w/ your plugin since I already have it loaded? (I looked at version 11 source code and couldn't figure out where it was being loaded. I saw the section within .js where it said "add all neccessary scripts", but I couldn't figure out how to disable JQUERY from loading)
    2. Do you have any more insight into this issue?

    Thanks so much in advance for your TIME and for considering my issue!!!

    ps: CODE DEBUG is ENABLED!

    website:

    http://wordpress.org/plugins/jquery-pin-it-button-for-images/

  2. mrsztuczkens
    Member
    Plugin Author

    Posted 6 months ago #

    Hi,

    first off, thanks for the kind words.

    Now to the problem itself. I'm 99% sure loading jQuery isn't the issue. If a plugin/theme is written well (I assume Pagelines is), it lets WordPress manage loading dependencies (libraries like jQuery). I've checked your website and it uses jQuery 1.10.2 (default for the current version of WordPress) and loads the jQuery library only once, so everything is fine.

    To address your questions:

    1. If you really want to, you might turn off the requirement of loading jQuery with my plugin by modifing jquery-pin-it-button-for-images.php file. Change:

    wp_enqueue_script( 'jquery-pin-it-button-script', plugins_url( '/js/script.min.js', __FILE__ ), array( 'jquery' ), JPIBFI_VERSION, false );

    to

    wp_enqueue_script( 'jquery-pin-it-button-script', plugins_url( '/js/script.min.js', __FILE__ ), array( ), JPIBFI_VERSION, false );

    As I mentioned above, I'm pretty sure that won't help.

    2. Unfortunately, I don't have any more insight into this issue. I believe it's a theme-plugin incompatibility and probably can be fixed, but (probably) would require a custom version of the plugin. Unfortunately, I don't provide this kind of support here on the forum, I'm sorry.

  3. brightonkeller
    Member
    Posted 6 months ago #

    thanks so much for responding! I have NO idea how I fixed it.....but somehow everything is working perfectly now.

    #happycamper

  4. mrsztuczkens
    Member
    Plugin Author

    Posted 6 months ago #

    Good for you!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags