WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] Conflict with single.php pagination - previous and next not showing (3 posts)

  1. alitscha
    Member
    Posted 1 year ago #

    Hi,

    I am using Portfolio-Press theme, so it is actually about single-portfolio.php, anyway it has a gallery and text and the previous/next link were working fine before I installed Polylang.

    If I disable Polylang they're there again...

    Here's my code for prev/next navigation in single-portfolio.php

    <nav id="nav-below">
    <h1 class="screen-reader-text"><?php _e( 'Post navigation', 'portfolioplus' ); ?></h1>
    <div class="nav-previous"><?php previous_post_link( '%link', '%title <span class="meta-nav">' . _x( '&rarr;', 'Previous post link', 'portfolioplus', '1000' ) . '</span>' ); ?></div>
    <div class="nav-next"><?php next_post_link( '%link', '<span class="meta-nav">' . _x( '&larr;', 'Next post link', 'portfolioplus', '1000' ) . '</span> %title' ); ?></div>
    </nav>

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    This occurs most probably because you did not activate the languages and translation management for portfolio post type in Polylang settings. However, this is a valid bug. It should now be corrected in the development version (1.0.3.4)
    http://downloads.wordpress.org/plugin/polylang.zip

  3. alitscha
    Member
    Posted 1 year ago #

    you were right. sorry for not checking better the settings before asking and many thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic