WordPress.org

Ready to get started?Download WordPress

Forums

Post Types Order
Conflict with qTranslate breaks nav menus on archive pages (3 posts)

  1. aaemnnosttv
    Member
    Posted 1 year ago #

    This is weird, but I seem to have found a conflict with the multilingual qTranslate plugin.

    What happens is -- with the default post types order settings -- my nav menus are all coming up empty. That is, a function like wp_get_nav_menu_items( $menu_id ) returns an empty array.

    If I disable the Auto Sort option, things return to normal working order.
    Auto Sort does not cause the same problem when qTranslate is disabled.

    This also only appears to happen on archive pages like the blog home, category archive, or cpt archive page (I haven't tested others). Single posts & pages don't appear to cause problems with both turned on.

    I can't say for sure that this plugin is the source of the problem as it's conflicting with another, but due to the nature of PTO, it seems like the more likely offender.

    Any suggestions?

    http://wordpress.org/extend/plugins/post-types-order/

  2. fecar
    Member
    Posted 1 year ago #

    I have exactly the same problem!
    My site is also multilingual with qTranslate, when I enable both plugins, Post Type Order + qTranslate, happens the same!

    Did you get some clue how to fix this?

  3. vadims00
    Member
    Posted 1 year ago #

    I'm having the same problem too!

    I use both qTranslate and Post Types Order and my top menu disappears only on my taxonomy archive page. All others are working fine.
    If anyone come up with a solution please let us know here!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic