WordPress.org

Ready to get started?Download WordPress

Forums

Milestone
Conflict with Google Analytics Plugin (2 posts)

  1. IanWaring
    Member
    Posted 7 months ago #

    Thank you for publishing this plug-in. It's been a lifesaver.

    I did try to install the Google Analytics Plugin for my WordPress MU network (http://wordpress.org/plugins/google-analytics-dashboard-for-wp/), but the install process ended up repointing the location of the Milestone CSS to a directory that didn't exist. See: http://wordpress.org/support/topic/how-to-remove-16?replies=3

    On my site, it resulted in the CSS file location being changed to stick his dashboard name in the Milestone CSS path definition, which didn't exist:

    <link rel='stylesheet' id='fergcorp-milestone-style-css' href='http://www.loddonlodge.com/wp-content/plugins/google-analytics-dashboard-for-wp/css/fergcorp_milestone-style.css?ver=20120208' type='text/css' media='all' />

    The author of that plug-in reckons the error is in the Milestone plug-in, where a variable is not initialised properly:

    ++
    You should ask the developer or that plugin. The funny thing is that he is using a $plugin variable without initializing it in any way :)))

    $my_plugin_file = __FILE__;
    
    if (isset($plugin)) {
    	$my_plugin_file = $plugin;
    }

    So, it's looking for the current directory of his plugin using $my_plugin_file and then uses $my_plugin_file = $plugin; :))
    --

    Removing the Google Analytics MU plugin puts the CSS file location back.

    So, something to add to the bug tracker?

    http://wordpress.org/plugins/milestone/

  2. IanWaring
    Member
    Posted 6 months ago #

    Bug still seems to be there. Any plans to fix the issue cited so that the plugin works with MU sites?

Reply

You must log in to post.

About this Plugin

About this Topic