WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
[resolved] Conflict with FV Flowplayer? (11 posts)

  1. simonjh
    Member
    Posted 1 year ago #

    Hi!

    I upgraded to the latest WP and then my plugins including BPS.

    After, running WordPress Flowplayer Version 2.1.20 | By Foliovision, my videos started not working and I got this error on the page where the video should load:

    "Admin: Video Issues
    Analysis of http://www.youremploymentbarrister.com/wp-content/uploads/2013/01/Intro-Video.mp4 (local):
    Error: Access to video forbidden (HTTP 403)!
    Format: mp4
    Meta Data (moov) position: 28
    Seek points: 3465 (stts sample count)
    Audio: 1 stream, mp4 (ISO/IEC 14496-3 AAC) 44100Hz, 2 channels, 16bit, stereo
    Video: avc1 (H.264 Encoder) codec, mp42 (MS-MPEG4 v2 Decoder) file type
    Settings are as follows:
    Website Root Folder: http://www.youremploymentbarrister.com
    Document Root Path: /home/sharding/public_html
    WP ABSPATH: /home/sharding/public_html/
    Parent Directory: /home/sharding
    Server Type: Apache
    Operating System: Linux
    Server API: cgi-fcgi - Your Host Server is using CGI.
    cURL: cURL Extension is Loaded
    Zend Engine Version: 2.3.0
    Zend Guard/Optimizer: Zend Guard Loader Extension is Loaded
    ionCube Loader: ionCube Loader Extension is Loaded Version: 40202
    Suhosin: Suhosin-Extension is Loaded
    APC: APC Extension is Not Loaded
    eAccelerator: eAccelerator Extension is Not Loaded
    XCache: XCache Extension is Loaded but Not Enabled
    Varnish: Varnish Extension is Not Loaded
    Memcache: Memcache Extension is Not Loaded
    Memcached: Memcached Extension is Not Loaded

    I am guessing BPS has caused an issue that is preventing the plugin from reading the media files?

    Many thanks

    Simon

    http://wordpress.org/extend/plugins/bulletproof-security/

  2. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    I checked the link you posted to your video and it is playing correctly. Did you put BPS in Default Mode or was this some other issue or problem?

    If this issue/problem is related to BPS you will see an error logged in your BPS Security Log file. Please post that error here.

  3. FolioVision
    Member
    Posted 1 year ago #

    Hi Simon!

    We provide comprehensive support for FV Flowplayer and other FV plugins at http://foliovision.com/support

    Thanks for using FV plugins!

    [signature moderated]

  4. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Is the issue/problem still occurring?

  5. simonjh
    Member
    Posted 1 year ago #

    Hi,
    Yes. The video should appear on the home page. SO the page appears normal but the video does not appear or the player. The above "Admin: Video issues" is the error message I get as an Admin.

    Thanks for your help!

    Simon

  6. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Check your BPS Security Log and post the Flowplayer error here. The BPS Security Log entry logs exactly what is being blocked so that a skip/bypass/whitelist rule can be created based on that error log entry.

  7. simonjh
    Member
    Posted 1 year ago #

    Hi
    The error I see is this:
    >>>>>>>>>>> 403 GET or Other Request Error Logged - July 12, 2013 - 12:46 pm <<<<<<<<<<<
    REMOTE_ADDR: 81.19.185.200
    Host Name: uk11.myserverhosts.com
    SERVER_PROTOCOL: HTTP/1.0
    HTTP_CLIENT_IP:
    HTTP_FORWARDED:
    HTTP_X_FORWARDED_FOR:
    HTTP_X_CLUSTER_CLIENT_IP:
    REQUEST_METHOD: GET
    HTTP_REFERER:
    REQUEST_URI: /wp-content/uploads/2013/07/Intro-Video.mp4
    QUERY_STRING:
    HTTP_USER_AGENT: WordPress/3.5.2; http://www.youremploymentbarrister.com

    but I see no Flow player error specifically - just this file.

    Oddly, I can see the video load fine if I oogin from my iphone just not through my laptop.

    Perhaps this is not a BPS issue after all? Odd. . .
    SH

  8. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Ok well you have your answer then since the video plays fine for me and plays fine for you on your iphone, but not on your laptop. There is a codec or other video problem with your laptop. Try installing DivX on your laptop. DivX comes bundled with the latest codecs.

    Additional info related to Server Protocol HTTP/1.0
    There was a similar issue/problem posted here.
    http://forum.ait-pro.com/forums/topic/digital-access-pass-dap-fix/#post-6919

    The error shows that Server Protocol HTTP/1.0 is being used. Server Protocol HTTP/1.0 is used by hackers and spammers or outdated proxy software or other outdated software, etc. and has been replaced by Server Protocol HTTP/1.1 as of 1997-1999. All legitimate requests should be using HTTP/1.1 and NOT HTTP/1.0.

    http://en.wikipedia.org/wiki/Hypertext_Transfer_Protocol
    http://stackoverflow.com/questions/246859/http-1-0-vs-1-1

  9. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    I tested the FV WordPress Flowplayer with BPS and the 403 error is just a nuisance error that can be resolved by following the instructions in the link below.

    http://forum.ait-pro.com/forums/topic/fv-wordpress-flowplayer-foliovision-403-error/#post-7694

  10. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Have you applied the solution above? If so, and if the error is no longer occurring then please resolve this Thread. Thanks.

  11. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Resolving. If the issue is still occurring post a status update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.