WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Conflict with Buddypress and Contact Form 7 (4 posts)

  1. locomo
    Member
    Posted 2 years ago #

    I'm observing 2 different conflicts between Buddypress and Contact Form 7. I've disabled all other plugins and am pretty sure that I have the conflict isolated between these 2.

    Problem 1:
    With Buddypress enabled, messages submitted from Contact Form 7 are sent from no-reply@my-website.com instead of [your-name] <[your-email]> as I have specified. This is a pain because I can't just simply reply to the messages as they come in to my email account. When I disable Buddypress messages from the contact form arrive correctly from: [your-name] <[your-email]>

    Problem 2:
    Buddypress interferes with Contact Form 7 ajax - for example normally when a user submits a form a spinning graphic is displayed next to the submit button provide user feedback. With Buddypress enabled this graphic doesn't appear and at first its confusing to the user whether the form has been submitted or not.

    Has anyone else experienced these issues? Any idea for fixes?

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    With Buddypress enabled, messages submitted from Contact Form 7 are sent from no-reply@my-website.com instead of [your-name] <[your-email]> as I have specified.

    I suppose BuddyPress does it as a feature.
    http://plugins.trac.wordpress.org/browser/buddypress/tags/1.5.6/bp-core/bp-core-filters.php#L52

    With Buddypress enabled this graphic doesn't appear and at first its confusing to the user whether the form has been submitted or not.

    This may be caused by a conflict with a theme as well.

  3. locomo
    Member
    Posted 2 years ago #

    thanks for the fast reply

    regarding the first issue - is there a way for me to tell if Contact Form 7 vs Buddypress has called wp_mail ? Buddypress hooks into "wp_mail_from" to override the From address .. I'm thinking I could conditionally apply this filter if I can determine which plugin is calling wp_mail ... does that make sense?

    regarding the second issue - I'm pretty sure it has to do with Buddypress - when i disable it the spinning "send" graphic appears. Would this be a jquery conflict? I have firebug installed but I'm not really sure how to track it down

    cheers!

  4. kgraff
    Member
    Posted 2 years ago #

    I too noticed that Contact Form 7 is not working with the most recent version of BuddyPress using the Custom Community theme. I get an orange unable to send message from all three of the contact forms I have set up.

    Not sure if this will help, but I was able to send a message from a draft page preview -- not sure why.

    The contact form seems to be working on my other sites that don't use BuddyPress.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic