WordPress.org

Ready to get started?Download WordPress

Forums

WP Vegas
[resolved] Conflict with 3.6.1? (8 posts)

  1. sarahwnyc
    Member
    Posted 9 months ago #

    Hey there, Is there a known issue with WP 3.6.1? Since upgrading http://www.davehause.com, I get these errors in the admin dashboard when I go to write a new post:

    Warning: array_keys() expects parameter 1 to be array, null given in /wp-includes/wp-db.php on line 1310

    Warning: Invalid argument supplied for foreach() in wp-includes/wp-db.php on line 1312

    Warning: implode() [function.implode]: Invalid arguments passed in wp-includes/wp-db.php on line 1321

    (I copy/pasted from a local version I created to test what the issue was, so I edited the file paths above to remove personally identifying information)

    The errors entirely prevent me from publishing a new blog post.

    I deactivated all the plugins to trace which one was causing the errors, and it's definitely Vegas Slider. I also deactivated everything and only activated Vegas Slider and the problem still occurs, so the plugin isn't conflicting with another plugin.

    Any ideas?

    Thank you!

    - Sarah

    http://wordpress.org/plugins/vegas-fullscreen-background-slider/

  2. jamesdbruner
    Member
    Plugin Author

    Posted 9 months ago #

    That was an error in 1.4 that I was getting but I wasn't aware of it in 1.5 Can you just verify for me really quick that you are using version 1.5?

  3. jamesdbruner
    Member
    Plugin Author

    Posted 9 months ago #

    I don't know how familiar you are with php/coding but the last time I checked the issue was originating from the force_vegas_private function. What I did was just comment the whole thing out in 1.5 and I'm removing it completely in 1.6 and I'm also checking for existing array keys and making sure variables are set where ever necessary. So if you give me until next Tuesday, maybe sooner, I should have version 1.6 officially out.

  4. sarahwnyc
    Member
    Posted 9 months ago #

    Hey James, I am indeed using version 1.5. I will stay tuned.

    I'm decently familiar with PHP though not a wizard by any means.

    Thanks!

  5. jamesdbruner
    Member
    Plugin Author

    Posted 9 months ago #

    Honestly, if you wanted to create a user with administrative rights and email me the username/password I'll go in there and fix it for you. I've got some free time at the moment. Or you can wait for 1.6 either way!

  6. sarahwnyc
    Member
    Posted 9 months ago #

    Hey James, thanks! Just emailed you an admin username. You rule!

  7. sarahwnyc
    Member
    Posted 9 months ago #

    Fixed! Thanks, James!

  8. jamesdbruner
    Member
    Plugin Author

    Posted 9 months ago #

    For anyone wondering, the issue was with the force_vegas_private function which I've removed from future versions of the plugin. It's unnecessary code and settings all posts to private can be done within WordPress.

    If you're experiencing a similar error and would like to fix it yourself, the code is at the bottom of the index.php

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.