WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Confirmed/Public Subscribers not receiving email notifications (21 posts)

  1. jim.smoak
    Member
    Posted 1 year ago #

    I have installed this plugin and bulk uploaded subscribers via the plugin. When I post a new blog post, the only email notifications that go out are to the site registered users. The Subscribe2 Public Subcribers (confirmed) users are not getting the email notifications. Is there a setting I'm missing?

    Many thanks!

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @jim.smoak,

    This sounds typical of a hosting restriction. You are almost certainly sending too many emails at once and your provider is dropping them. Speak to your hosting provider.

  3. jim.smoak
    Member
    Posted 1 year ago #

    I just got off the phone with the tech-support folks at my host and the email threshold they set is higher than I need. Also, they checked the logs, and they don't even see email going through their servers from my domain...

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @jim.smoak,

    I'm not surprised by this. They probably looked on the mail log when the emails are generated and sent on the PHP web server. Install a WordPress mail log plugin to see what emails are being generated, if it is as you'd expect you can raise with your provider again.

  5. illysia
    Member
    Posted 1 year ago #

    Hi there,
    I'm having the same problem at http://www.madlychic.com, but not even registered users are getting an email. I had been using Subscribe 2 for 5 months without a problem, and I didn't change any of my settings. Three weeks ago, the emails just stoppd sending when a new post went live. I looked through the troubleshooting and saw that this problem usually is an issue with the host. I can send a manual email to everyone though, so when I called my host, they said it wouldn't be a problem with them if I can do it manually. Help please:-)
    Illysia

  6. bpawebman
    Member
    Posted 1 year ago #

    I am having the same problem as Illysia namely no emails to subscribers or registered users when posts are generated - only to me as administrator. This is not a fluke dear plugin author. I subscribed myself with another email account and also registered with yet a different email account - and no email messages. Any thoughts of what's happened with subscribe2?

  7. bpawebman
    Member
    Posted 1 year ago #

    To provide more information regarding previous post: I am using WordPress version 2.4.2, Suffusion theme version 4.2.5 and Subscribe2 version 8.5

  8. bpawebman
    Member
    Posted 1 year ago #

    I meant to say WordPress version 3.4.2 --- typing error.

  9. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @bpawebman,

    If you are having the exact same problem as Illysia then maybe you should look at her other thread:
    http://wordpress.org/support/topic/not-sending-emails-to-subscribers-after-5-months-wo-a-problem?replies=9

    It seems she was using JetPack alongside Subscribe2 - in her case this resulted in Subscribe2 not working.

    I know sending issues are not a fluke, unsurprisingly for a plugin that functions to send emails it's the most common issue reported but after 6 years of coding and supporting this plugin I find it is most often it is due to hosting side server restrictions to prevent spam.

  10. illysia
    Member
    Posted 1 year ago #

    Hi,
    Unfortunately, my emails are not sending again, but they are logging in the mail log plug-in, so I know that its not Subscribe2. The only thing I changed was to deactivate my SEO plug-in and reactivate to check another problem I'm having. @Mattyrob do you do any consulting on the side? Can you email me at illysia@madlychic.com if you do?
    Illysia

  11. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Illysia,

    If this is that case you need to open a dialog with your hosting provider about what email restrictions they impose.

    All hosts have some limits in place these days in order to combat spam. Ask them what you need to do to comply with their policies when informing your readers about your new blog posts.

  12. illysia
    Member
    Posted 1 year ago #

    That was my first mode of attack when I had the problem. They told me it wasn't them because I could manually send an email to all my subscribers. Sigh...

  13. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Illysia,

    Keep going back to your hosting provider, you are paying them for a service so they need to investigate properly, not just dismiss it.

    When you say you can send manually, do you mean via an email client or via Subscribe2->Send Mail?

    Bear in mind that in version 8.5 sending manually will send to a smaller subset of users at any one time depending on the drop down selection. Also, it will send the emails as if they are coming from the currently logged in user. If this does indeed work then perhaps select this user account as the email sender in the Subscribe2->Settings page.

  14. illysia
    Member
    Posted 1 year ago #

    I mean via Subscribe2->Send Mail.

    I went back to my provider and they said there are no spam filters or anything set that would prevent the emails from going out. My limit for emails per hour was 150, which is slightly less than my subscriber list, but they said it should have sent to 150 users at least. Anyway, they set the number higher and we'll see when I post something again on Wed...

    Thanks for your time @mattyrob

  15. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Illysia,

    Let's see if the limit change has an effect. If the 150 was slightly under your subscriber list the emails may well have been silently dropped on the server rather than being sent, especially if the number of recipients per email is set to 0 in your Subscribe->Settings page. Try changing that to 1 if it is currently 0.

  16. illysia
    Member
    Posted 1 year ago #

    It was set to zero so I could send to an unlimited number. I did change it to 175 at some point to see if that would help, but it didn't. I will set it to 1. That won't make it send to only one person, I'm assuming. I shouldn't change it to 175 instead?
    Thank you! Thank you! Thank you for your help!
    Illysia

  17. illysia
    Member
    Posted 1 year ago #

    I just went to change the limit and it's been set for 200 people. SHould I change it to 1?

  18. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Illysia,

    Changing that setting to 1 will send all of your emails still but each email will be sent direct to them rather than using the BCC email header. I would suggest that 1 is a better setting than 200.

  19. illysia
    Member
    Posted 1 year ago #

    @mattyrob
    You rock:-)
    I'm keeping my fingers crossed!

  20. illysia
    Member
    Posted 1 year ago #

    Unfortunately, it didn't work. Sigh. I'm ready to start some serious drinking!

  21. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Illysia,

    I've just sent you a contact on your site.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.