WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Confirmation link goes to page not found (12 posts)

  1. jenifera2
    Member
    Posted 1 year ago #

    I've got the latest versions of wordpress and Subscribe2. I've created a page with the S2 token. I've told the widget and the Subscribe2 settings under Appearance to use this page. I'm sending emails from an email address associated with my domain name. Confirmation emails are being sent, but when the user clicks the confirm link, they are taken to a "page not found" error message and are not confirmed.

    I have disabled all my plugins except Subscribe2, though I'm not using any SEO plugins because this is a personal website.

    This was working a couple of days ago, and I'm not sure what I might have changed that has now broken the Subscribe2 functionality. Any ideas?

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @jenifera2,

    It's difficult to say without seeing your site. It may be down to entries in Settings -> General under the WordPress URL and Site URL, especially if your site is installed in a sub-domain.

  3. jenifera2
    Member
    Posted 1 year ago #

    Thanks for the reply. The site URL is http://www.a2millers.com

    The wordpress URL is http://www.a2millers.com/wordpress which it has been since I first created the installation more than 2 years ago. I recently accidentally deleted the subscribe2 plugin and had to reinstall, which is when the problems started.

    I didn't previously have the page set up with the S2 token, but have added that and changed the email that sends out notifications to one that is the same as my domain, so if anything, functionality should have been improved. Several people (including me, with a dummy email address) have been able to subscribe to the site, click the confirmation link, and be taken to the page with the S2 info on it, but suddenly it's not working, and I can't think of anything I changed during that time.

    Are there any likely culprits that would cause that error that I can look into? I checked on everything that was obvious to me, but I didn't dig into the plugin code to see if I could figure out where else to look.

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @jenifera2,

    Having had a go myself I suspect a plugin or theme conflict. Something is not allowing $_GET requests to be recognised as such and they are interpreted as pages which don't exist.

    Disable all of your other plugins and try again, if that works, re-activate the plugins one at a time until it breaks again to find the culprit.

  5. jenifera2
    Member
    Posted 1 year ago #

    OK, I've got all other plugins disabled, but it still doesn't work. I've looked through all my wordpress settings to see if anything jumps out at me, but I'm stumped.

    I'm using the twenty-ten theme, fully updated, customized through the theme options, but I haven't added a stylesheet or modified any of the theme code.

    Any other ideas? Thank you!

  6. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @jenifera2,

    Are your WordPress files in a subfolder in relation to your domain?

    See this article:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    I'm not sure if that'll be having an impact but it's worth investigating.

    Also, review your .htaccess file and consider rebuilding your permalinks. This htread might help for that:
    http://wpquestions.com/question/show/id/7321

  7. jenifera2
    Member
    Posted 1 year ago #

    I checked both of those, and everything seemed fine. I did rebuild my permalinks, but the problem continued.

    I then went into my Subscribe2 settings and onto the Appearance tab just to double check that I had the page set correctly, which I did.

    On a whim I decided to change the "Set the number of Subscribers displayed per page" from 25 to 100, though I've only got 16 subscribers total. This worked, and I was able to successfully subscribe two separate email addresses. It's not clear to me what this setting is actually used for, and it doesn't seem like it should affect this, but I'm happy to have subscriptions working again!

    Thank you for your help.

  8. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @jenifera2,

    That's very strange. The only thing I can imagine it might have been was corrupt settings in the database which was apparently fixed when you made that change in the Settings.

    Anyway, I'm glad it's now working for you.

  9. jgirardnrg
    Member
    Posted 1 year ago #

    Having this same issue with one of the sites I help admin... any advice?

  10. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @jgirardnrg,

    Without knowing more information I can't really offer any insight at all. What version of Subscribe2 and WordPress are you using? What have you tried already that has already been discussed in this thread? Where is the site?

  11. jgirardnrg
    Member
    Posted 1 year ago #

    @mattyrob
    Subscribe2 8.6 (free version)
    Wordpress 3.5
    I tried everything in this thread before posting, including disabling other plugins. Kind of stumped on this one. the sites is http://chronicle.umbmentoring.org/ running Solostream wp-bold

  12. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @jgirardnrg,

    Where is your WordPress page that handles subscriptions?

    The Link is being confirmed - it just doesn't look very good on your site. I suspect that your site has no 'Pages' available for the plugin to use to provide feeback to the users.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic