WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Icons - SVG
[resolved] Confilic with Font Awesome plugin (3 posts)

  1. williamr4j
    Member
    Posted 9 months ago #

    Hello,

    I am using both your wonderful plugin and the font awesome plugin: http://wordpress.org/plugins/font-awesome/
    When using one or the other it is great, when activating both I get un readable characters that are not the font images. I'm not sure what is conflicting but if you could figure it out that would be great.

    Thank you.

    http://wordpress.org/plugins/svg-vector-icon-plugin/

  2. Evan Herman
    Member
    Plugin Author

    Posted 9 months ago #

    I am fairly certain the conflict arises because the 'Font-Awesome' plugin uses unicode that are also declared within my plugin.

    One work around would be to go through the entire plugin and change each icons Unicode to something else.

    I will have a look at this and see if I can come up with a resolution. Sorry you are encountering a problem running the two. I will do my best to get the issue resolved by the end of the day, and will post back here when it is.

    Thank you for pointing out this major issue.

    Evan

  3. Evan Herman
    Member
    Plugin Author

    Posted 9 months ago #

    I just downloaded the 'Font Awesome' (from http://wordpress.org/plugins/font-awesome/) plugin and I have just installed and activated it on a fresh WordPress install on a 2013 theme.

    Using the 'Font-Awesome' dropdown inside of new posts, I was not able to get any icons displaying.

    But using the provided short codes that come with that plugin I was able to get the icons to display properly.

    Example: [icon name=icon-pencil]

    If you use the above method to include 'Font-Awesome' icons, and then use my plugin to include more icons you will have no issue.

    I was able to have both plugins active and displaying icons properly as intended, using the following code:
    [icon name=icon-pencil]<span data-icon=""></span>

    The first icon is a font-awesome icon. The second is an icon from my plugin.

    Ultimately the problem lies in the 'Font-Awesome' plugin and the way you are choosing to display their icons. Hopefully I was able to help you out and resolve your issue.

    -Evan

Reply

You must log in to post.

About this Plugin

About this Topic