WordPress.org

Ready to get started?Download WordPress

Forums

Configured WordPress upload directory doesn't exist (15 posts)

  1. bkss
    Member
    Posted 2 years ago #

    I get the error "Configured WordPress upload directory doesn't exist, Please make sure that the directory exists and is writeable."

    It for sure exist and I have tried to change all permissions to 777 from folder "wp-content" and all subfolders but nothing helps.

    Will a reinstallation of WP 3.3.1 help?
    Is there a risk that a reinstallation will cause more damage?

    Thanks for all help I can get.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Check your uploads path in Settings->Media. It should be blank in most installs.

  3. bkss
    Member
    Posted 2 years ago #

    I have checked the upload path in Settings->Media, both leaving it blank and with "wp-content/uploads", it makes no difference.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Is this a fresh install?

  5. bkss
    Member
    Posted 2 years ago #

    No, it has been up and running for a while, almost a month now from were it is located now on the server. Before that I was running it on a test platform for about a year on the same server.
    I've got help from an engineer from the hosting company and it has been working perfectly until recently, something must have gone corrupt in the WP-installation, can a reinstallation of WP 3.3.1 solve the problem, is it worth a try?

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    can a reinstallation of WP 3.3.1 solve the problem

    Unlikely. What folder is it trying to access?

  7. bkss
    Member
    Posted 2 years ago #

    I think it is trying to access the uploads-folder. I first discovered the problem yesterday when the plug-in CataBlog could not show the images in its library. The images are located in uploads/catablog/.
    I then tried to deactivate and then activate the plug-in anf got following error message:
    CataBlog could not detect your upload directory or it is not writable by PHP. Please make sure Apache and PHP have write permission for the configured uploads folder. Contact your hosting company or IT department for more information. Thanks.
    But then I discovered the there were a general problem with WP to find its upload directory.
    Is there anyway to see the settings of the uploads/directory in a php-file?

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    The uploads directory is (usually) wp-content/uploads. There are no "settings" to see within WordPress that relate to this folder. However, this could be a server issue. Have you spoken to your hosts about it?

  9. bkss
    Member
    Posted 2 years ago #

    I was in contact with them yesterday, but we couldn't figure out what was wrong. Non of us are WP-experts, do you have any suggestion what the server issue could be?

  10. esmi
    Forum Moderator
    Posted 2 years ago #

    You could ask them to investigate a possible folder ownership issue.

  11. bkss
    Member
    Posted 2 years ago #

    I'll ask them to check this once again and let you know how it goes.

    Thanks a lot for you assistance so far!

  12. bkss
    Member
    Posted 2 years ago #

    I've checked with the engineer at the hosting company and he can not understand how the ownership can be an issue when we have set 777 on all folders in the uploads-directory.
    Do you mean something else maybe?

  13. esmi
    Forum Moderator
    Posted 2 years ago #

    Ownership is completely different to permissions.

  14. bkss
    Member
    Posted 2 years ago #

    Who shall be the owner?
    As it is now it's the owner of the home-folder that also owns all subfolders including wp-content/uploads-folder.
    Shall it be the owner that runs the web server that shall be the owner of the folders?

  15. bkss
    Member
    Posted 2 years ago #

    FYI, I also tried to change the name of the upload folder to upload (w/o the s in the end) and set this path in Settings->Media.
    The only obvious change was that no images at all were shown on the website and WP still complained that there was no upload directory. So when I changed it all back again the images (header image for example) are shown again.

Topic Closed

This topic has been closed to new replies.

About this Topic