WordPress.org

Ready to get started?Download WordPress

Forums

Configuration of xmlrpc.php?rsd in self hosted blog (4 posts)

  1. johnllarkin
    Member
    Posted 6 years ago #

    Hi all,

    I have a self hosted WordPress blog. I was attempting to blog to it via the Flock browser yet it would not work.

    Following a closer look at the blog it seems it is not configured correctly.

    I would be happy to receive advice on this. When one runs the file,
    "xmlrpc.php?rsd", the message that is received is "Precondition Failed
    The precondition on the request for the URL /xmlrpc.php evaluated to false."

    Any ideas on how to correctly configure this?

    Regards

    John

  2. harperbruce
    Member
    Posted 6 years ago #

    John,

    Try this solution, since it seems to echo similar situations. First, download the file .htaccess from your blog's root directory and copy it. (Odds are it will be blank, 0 bytes, but be sure.)

    Next, in the copy, insert the following lines:

    <Files xmlrpc.php>
    SecFilterInheritance Off
    </Files>

    Finally, upload the new .htaccess back to the blog's root directory, then try your procedure again. That should clear it up.

    Bruce -- Harper Blue

  3. whooami
    Member
    Posted 6 years ago #

    that may or may not work, depending on the version of mod_security being used.

    2.5, for instance requires that the httpd.conf be edited directly. I just went through this, but it's repeatable, and googlable.

  4. Don_Rieb
    Member
    Posted 5 years ago #

    Hi,

    I have my own servers I host wordpress on. I am trying to have my online photo filer send a photo to my blog. If I configure the potofiler to try to logingo mysite.com/wordpress it tells me it can't log into account. If I use mysite.com/wordpress/wp-admin then it states "Your blog does not support RSD. Contact your blog service provider to learn about adding this feature to your blog." . The closest plugin I coulf find that said it had RSD was 7uploads, but I still have the same problem. Not sure how to turn on RSD in wordpress of If I am loing in correctly. It also stated I needed a API aware blogger.

Topic Closed

This topic has been closed to new replies.

About this Topic