WordPress.org

Ready to get started?Download WordPress

Forums

Simple Intranet Directory
[resolved] Configuration (3 posts)

  1. jimhu
    Member
    Posted 1 year ago #

    I think I'm missing something. I installed the plugin and can get an employees page and manage info. But I can't figure out how to upload images for them from the manage avatars button.

    I set up a directory preference for a new directory that I created and made writeable by Apache

    wordpress/wp-content/avatars

    When I go to a user profile and click the manage avatar button I get a dialog to upload a photo. I do this and get an error message "upload directory doesn't exist". But I can't tell what directory it's looking for. In the apache log I'm seeing

    File does not exist: [webroot path]/wordpress/wp-content/plugins/profile, referer: http://localhost/wordpress/wp-admin/admin-ajax.php?action=avatars_manage&act=INIT&uid=2&

    Is there a way to use images that have already been uploaded to the regular WordPress image/media uploads?

    Thanks

    http://wordpress.org/extend/plugins/simple-intranet-directory/

  2. Chris Charlwood
    Member
    Plugin Author

    Posted 1 year ago #

    See our FAQs at http://www.simpleintranet.org/faqs/ and also copied below;
    My Employee Photos aren’t showing up after uploading, why?
    This is typically a file folder issue or a server permission issue. First, go to “Users / User Photos” in the Dashboard, and scroll to the bottom option settings area where it says “Photo Options”. Find the “User Uploads” checkbox, and check it and add a directory such as “/avatars”. Retest uploading. If still no luck, check that your server allows read/write/execute permissions, or CHMOD 755 at least on that folder. Filezilla for example is an FTP client that allows you to right click on folders to see and set permissions. Failing that, check the box that says:
    “Or, use legacy (v7.3 and lower) $_SERVER['DOCUMENT_ROOT'] method , this option often helps when using sub-domains.”

    Retest and try a different folder and set permissions if problems persist. Be sure to right click on any broken image/photos and “Copy Image URL” to see where the folder is on your server. Look for that file and folder on your server, or within the default “wp-content/uploads” folder. Search elsewhere. Check also your settings under “Settings / Media” and uncheck the box next to “ Organize my uploads into month- and year-based folders.” Retest uploading and again check the image URL source by right clicking, check your server and check permissions.

  3. Chris Charlwood
    Member
    Plugin Author

    Posted 1 year ago #

    In this free version, the menu is under Users / Employee Photos and also try manually adjusting the local image URL column to test finding where your photos are....

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic