WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
"Compress pages" gives garbled output on LiteSpeed server (6 posts)

  1. RavanH
    Member
    Posted 3 years ago #

    Sadly, when I activate Compress pages on my site running on LiteSpeed, the result is pages and posts with only weird characters.

    Even after deactivating the runtime compression by adding the rule RewriteRule . - [E=no-gzip:1] to .htaccess, the same thing happens. So I guess the problem occurs during the creation of the gzipped files rather than while serving them 'double compressed'...

    Is this a know issue on LiteSpeed?

    Let me know if there is anything I can do like testing in debugging mode and searching for errors or even switching server components on/off (my server admin is really helpfull in that respect :) ) to help solve it...

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Unfortunately I don't have access to LiteSpeed so I don't know what to suggest. You probably should just enable compression in your server and disable it in the plugin.

  3. Delete Me
    Member
    Posted 3 years ago #

    Litespeed gzips content by DEFAULT at the server level. I don't know if an htaccess rule can prevent that either, so you are better off leaving the setting to uncompressed. I've had this issue before on Litespeed hosts and since Litespeed is configured to gzip automatically, there's no need to enable it at the client level, not even in cPanel (for those hosts that have cPanel administration.)

  4. RavanH
    Member
    Posted 3 years ago #

    Adding RewriteRule . - [E=no-gzip:1] to .htaccess does succesfully switch off compression on my hosts server. Sadly, turning it off does not solve the garbled pages issue when compression is enabled in Super Cache.

    Of course, Compress pages is disabled now but I was wondering if there is any possibility to use that excellent Super Cache feature to alleviate the server even further. And if there was any way I could help testing :)

    Ah, well... As long as it's working ;)

  5. Uma Sumeros
    Member
    Posted 3 years ago #

    Hi RavanH:

    I experienced the very same issue today when testing my website which is also on a LiteSpeed server. When using WP-HTML Compression, alon with Super Cache and Better WP Minify the testing service displayed garbled text, but view the site from several different points it looked fine.

    It may not be of much help but one solution may be to change your theme if your goal is to increase the speed and performance. I found several when I queried Googl for the "fastest loading WordPress themes."

    Then I set up a demo site and tested eac one with the same plugins and some content so I could choose the one that performed best. The webhosting companies are not too eager to implement server side caching solutions, unless you are on a VPS server, but if you haven't asked, about this, it might be worth your time to pursue it.

  6. RavanH
    Member
    Posted 3 years ago #

    Thanks for the tip, Uma. Because I'm using WordPress to host a large number of websites (multi-site mode) so it is not just one site where I can switch the theme, I will stick with server side on-the-fly compression and "Compress pages" switched off in WP-Super-Cache.

    The LiteSpeed/WPSC combination is super fast already so I'm quite happy :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic