WordPress.org

Ready to get started?Download WordPress

Forums

DMSGuestbook
[resolved] Complications after server upgrade and Spam attack (6 posts)

  1. steveb123
    Member
    Posted 1 year ago #

    After using DMS for many years with no problem, upgrading as things became available etc, I started getting so much spam that it started to slow down my ISP's server!!

    Predominately from 2 IPs, one in China and one in Russia.

    I have a good relationship with my ISP and they offer a great service but as a result of the attacks they have put in a htaccess block on that guest book page and asked me to come up with a solution.

    Last w/e they upgraded to PHP Version : 5.2.17-0.dotdeb.0
    PHP Safe Mode : Off
    PHP Allow URL fopen : Off

    I downloaded the anti-spam plug-in and set about moving the guest book to a new page.

    On opening the new page I received a stream of Error messages commencing with

    WARNING function.fopen URL file access is disabled in the server configuration in ........../dmsguestbook.php on line 691.

    So many error messages the browser crashed!

    I tried in the 2012 theme with all other plug-ins disabled with the same result.

    I tried some stuff that I found in support forums, not really understanding what I was doing, but still no joy.

    http://wordpress.org/extend/plugins/dmsguestbook/

  2. DanielSchurter
    Member
    Plugin Author

    Posted 1 year ago #

    Hi

    Insert ini_set('allow_url_fopen', '1'); at the beginning of dmsguestbook.php but after <?php.

    DMSGuestbook comes with a build-in spam solution. See that on "DMSGuestbook -> Guestbook settings -> Captcha / Akismet".

    Greetings,
    Dani

  3. steveb123
    Member
    Posted 1 year ago #

    Hi Dani,

    As ever, many thanks for your incredibly prompt response. Could you be a little more specific. I have done as you said:-

    <?php ini_set('allow_url_fopen', '1');
    if(preg_match('#' . basename(__FILE__) . '#', $_SERVER['PHP_SELF'])) { die('You are not allowed to call this page directly.'); }

    however when I click on the new page it takes forever to load and then nothing.

    Both the spam options are in place and have been since I started using the plug-in, it's just that the site is being targeted and the server is being overwhelmed by requests even though the filters are working for the most part as they should

    The site is http://www.paulbrady.com and the new guestbbok is GB2 (not guestbook)

    Steve

  4. steveb123
    Member
    Posted 1 year ago #

    Update:

    My ISP has told me that he has now set fopen to be on for my site (although the server settings displayed in the site overview still say it is off!)
    With the 2012 theme and all other plugins off I get the same errors as before, whilst with my Filmix theme and plugins I get a blank page.

    As I said before I have used the Guestbook for many years with no issues, this is the first time I have had any problems.

  5. DanielSchurter
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Steve

    Yes, you can't set allow_url_fopen in a script because it's a security reason, I saw it too late, sorry.

    Please create a WordPress admin account and send the credentials to DMSGuestbook {├Ąt} DanielSchurter ( dot ) net. After that I will take a look on it.

    Greetings,
    Dani

  6. steveb123
    Member
    Posted 1 year ago #

    Sorted....Many thanks Dani...The Best

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic