WordPress.org

Ready to get started?Download WordPress

Forums

Author Avatars List
[resolved] Completely Broken? (10 posts)

  1. poopertropper
    Member
    Posted 11 months ago #

    Is there any version of this plugin that is working? I've tried 1.6.1, 1.6.2, and 1.7.0. All of them are throwing errors on each and every page. One of them even breaks all posting from the backend. Does anyone have this working on the latest version?

    http://wordpress.org/extend/plugins/author-avatars/

  2. Pbearne
    Member
    Plugin Author

    Posted 11 months ago #

    Sorry to hear that you are have problems

    I have not heard of other people having problems so can do a few test on you setup

    Have tried load a default theme (2012) in case it that and / or disabling all the other plug-in's

    If you are able to work what is conflicting I can looking at fixing it

    Many thanks for any help you can give

    Paul

  3. poopertropper
    Member
    Posted 11 months ago #

    Thanks Paul. The errors I'm getting are from using the default 2012 theme. On the backend I'm getting the following errors:

    Notice: Undefined index: blogs in /var/www/vhosts/htdocs/voices/wp-content/plugins/author-avatars/lib/AuthorAvatarsWidget.class.php on line 194

    On the front end I get a giant mess of code that says:

    Notice: get_usernumposts is deprecated since version 3.0! Use count_user_posts() instead. in /var/www/vhosts/htdocs/voices/wp-includes/functions.php on line 2839

    That error is repeated about 500 times on the side bar where the widget is located. Finally the plugin completely fails after the 500 warning messages with this code"

    Fatal error: Call to undefined function atrim() in /var/www/vhosts/htdocs/voices/wp-content/plugins/author-avatars/lib/UserList.class.php on line 478

    This is with using the latest 1.7 dev version.

    I tried 1.6.1 and 1.6.2 but only had more issues. Any ideas why so many warrnings?

    P.S. I'm using SQL 5.1.67 and PHP 5.3.3

  4. Pbearne
    Member
    Plugin Author

    Posted 11 months ago #

    Hi thanks for you freed back`

    there is dev version at https://github.com/pbearne/wp-author-avatars/tree/development

    which is stable just waiting for me to get time to release

    you are welcome to download and install that

    I believe that I have fixed the bugs you list

    if you still get get_usernumposts

    I ahve some code to handle of version

    if ( AA_is_version(3.0) ) {
      $total += count_user_posts($user_id);
    }else{
      $total += get_usernumposts($user_id);
    }

    so any feedback on if you still see errors would help

    Paul

  5. poopertropper
    Member
    Posted 11 months ago #

    As I said before, this was with me using the latest dev verson.

    This is with using the latest 1.7 dev version.

    So the fatal error and other warnings are all part of the 1.7 dev branch.

  6. Pbearne
    Member
    Plugin Author

    Posted 11 months ago #

    Just for you!

    I have removed the code that supported wordpress version pre 3.0 in order to stop the errors you are seeing :-)

    can you please get the lastest dev version from https://github.com/pbearne/wp-author-avatars/tree/development

    This labeled as 1.7 but is ahead of the SVN version on wordpress.

    Many Thanks

  7. poopertropper
    Member
    Posted 11 months ago #

    Wow that is fantastic Pbearne! I'm only seeing one issue within the Widget settings. There is an error that reads:

    Notice: Undefined index: blogs in /var/www/vhosts/devtest.suntimes.com/htdocs/voices/wp-content/plugins/author-avatars/lib/AuthorAvatarsWidget.class.php on line 195

  8. Pbearne
    Member
    Plugin Author

    Posted 11 months ago #

    thanks for very quick feedback

    I am not seeing this error so have fixed it blind

    can you pull the code again and see if this has fixed it?

    Many thanks for your help

    Paul

  9. poopertropper
    Member
    Posted 11 months ago #

    Notice: Undefined index: blogs in /var/www/vhosts/devtest.suntimes.com/htdocs/voices/wp-content/plugins/author-avatars/lib/AuthorAvatarsWidget.class.php on line 195

    Still there. It only shows when i place the widget into a sidebar location from the widget page.

    http://i.minus.com/iZoEx8jS7Y0D1.png

  10. Pbearne
    Member
    Plugin Author

    Posted 11 months ago #

    OK added some more production this is not what I have at line 195

    $adv_right = "";
    // incase we don't have any blogs
    if (AA_is_wpmu() && !empty($instance['blogs']))
    $adv_right .= $form->renderFieldBlogs($instance['blogs']);

    so it only gets called if it is multi-site and there are blogs

    Please try again

    Paul

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.