WordPress.org

Ready to get started?Download WordPress

Forums

Complete and utter greenhorn here (4 posts)

  1. Veshka
    Member
    Posted 10 years ago #

    I'm what I was hoping to be an ex MT user by now. Last night was the last straw when my user files went corrupt and I lost all ability to log in, back up, etc. So, I backed up what I could, deleted the whole thing, and was hoping that the 5 minute installation would be all the time it would take cause it was nearing 1 am and I was tired. However, it's noon the next day, and although I did sleep in between, I got up a number of times thinking "OK, what if I tried this?" to find out that I'm still not a WP user just yet.
    Truth be told, I have absolutly no clue about mySQL. Never used it before, and I wouldn't know what to do with it if I wasn't given detailed instructions. But I followed all the steps for setting up wp-config.php, ran the install, and all I get is that it can't find the wp-config.php file, goes through all the steps and says it's installed (but it can't figure out what my url is and doesn't give me a password). I'm at a loss here. Can anyone help?

  2. lane
    Member
    Posted 10 years ago #

    Do you have a database already setup? Does your host provide you one? You really won't have to work with MySQL unless you have to create a new database (if you have the ability on your host to create more than one database). If your host provided you with one, enter the information for database name, database username and the password they provided (leaving localhost the same). Then just let the script run. The install script will autodetect the address.
    Can you provide which is your setup (database provided by host or your own server with the ability to create more than one database) if you need more help.

  3. Veshka
    Member
    Posted 10 years ago #

    Thus far, this is my wp-config.php file's editable stuff:
    // ** MySQL settings ** //
    define('DB_NAME', 'thoughtpud'); // The name of the database
    define('DB_USER', 'thoughtpud'); // Your MySQL username
    define('DB_PASSWORD', 'passwordgoeshere'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    There's two databases my webhosts have set up on my account, and since the first one's named "test", I didn't think it would be a good idea to run things out of there (that and the fact I've tried and it still doesn't work).
    The thing is, either way, when running the install file, I get the following:
    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."); require_once('../wp-config.php'); require('upgrade-functions.php'); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; ?>
    And then it proceeds to go through steps 1 through 4, spits out code everywhere, doesn't guess my url, and tells me I can log in with the user name "admin" and no password (which doesn't work, the page won't come up at all). *Shrugs* Any ideas? Everything's in the proper directories. I've CHMODed everything to death (tried default, tried 755, tried 777)... And I don't have the ability to make any new databases, nor do I know how really. Like I said, I'm so new to this it's embarrassing. The first time I've ever seen anything mySQL was last night at midnight. Any help would be appriciated.

  4. lane
    Member
    Posted 10 years ago #

    Veshka, email me: noise at laneallen dot com
    I went to view what you were talking about, and it worked for me. What browser are you using? Anyhow, email me and I'll send the default password so you can change it. Sorry, thought it was already setup since you were posting here.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.