WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce MercadoPago
[resolved] Compatibility Problem (8 posts)

  1. @sefod
    Member
    Posted 8 months ago #

    Hi, I contact you because after installing a WooCommerce add-on, had a problem activating MercadoPago as a gateway with your plugin. Then I investigated, and following This Link I found that is a very simple change that can solve the problem, and improve the plug. There is a possibility to fix that on the next release?
    I've checked out and the fix seems to be working perfect.

    Thanks in advance!

    Cheers

    http://wordpress.org/plugins/woocommerce-mercadopago/

  2. Claudio Sanches
    Member
    Plugin Author

    Posted 8 months ago #

    Actually I'm not concerned with support for plugins premium.
    But how did you fix?

  3. @sefod
    Member
    Posted 8 months ago #

    It seems that it's also a generic problem that can generate other compatibility issues, but not sure.
    This is what it says:

    Payment gateway plugins have a property called enabled, which can have one of two values: yes, if gateway is enabled, or no, if the gateway is disabled. The MercadoPago plugin, instead, incorrectly returns a boolean value, i.e. true when it's enabled and false when it's disabled.

    To fix it you just need to change a line, and that worked for me. But I'm not sure if that affect another part of your plug. Apparently no.

    Cheers!

  4. Claudio Sanches
    Member
    Plugin Author

    Posted 8 months ago #

    I do not understand.
    WooCommerce's PayPal does that too.
    What's the problem?

  5. Claudio Sanches
    Member
    Plugin Author

    Posted 8 months ago #

  6. Claudio Sanches
    Member
    Plugin Author

    Posted 8 months ago #

    Read here:
    https://github.com/woothemes/woocommerce/blob/master/includes/abstracts/abstract-wc-payment-gateway.php#L37-L38

    It is bool.

    You broke the plugin and forced it always be true!

  7. Claudio Sanches
    Member
    Plugin Author

    Posted 8 months ago #

    Fixed in 1.7.0 version.

  8. @sefod
    Member
    Posted 8 months ago #

    Thanks man!
    Cheers!

Reply

You must log in to post.

About this Plugin

About this Topic