WordPress.org

Ready to get started?Download WordPress

Forums

Compact WP Audio Player
Compact WordPress Audio/Music Player Plugin - Audio not playing (30 posts)

  1. mames40
    Member
    Posted 8 months ago #

    Hi,
    I can see the control for the player but the audio doesn't play.
    Here is my shortcode:

    [sc_embed_player volume="100" fileurl="http://elliottequineconnections.com/wp-content/uploads/2013/11/01-05-Standing-Outside-The-Fire.mp3"]

    The link to my site is elliottequineconnections.com

    I don't see any errors. Where would I find them?
    thanks,
    Margaret

    http://wordpress.org/plugins/compact-wp-audio-player/

  2. mames40
    Member
    Posted 8 months ago #

    Hi,
    The plugin works on my iPhone just not desktop version with all major browsers. (ie, chrome, firefox).

  3. jockoe
    Member
    Posted 8 months ago #

    I just had the same issue and found that my problem was caused by the CSS I had written for this plugin, specifically for the element "#sm2-container".

    Hope that helps you.

  4. mames40
    Member
    Posted 8 months ago #

    Thanks for your reply. :).

    I haven't written any css for this plugin just the css for the theme.

    I did deactivate all of my plugins but that didn't help either. :(.

  5. jockoe
    Member
    Posted 8 months ago #

    Wish I had other suggestions for you. I only downloaded this plugin this morning.

    Hope you find your solution.

  6. jockoe
    Member
    Posted 8 months ago #

    Do you have a link to your site?

  7. mames40
    Member
    Posted 8 months ago #

    Hi,
    Yes it's http://elliottequineconnections.com

    thanks for your help!
    Margaret

  8. jockoe
    Member
    Posted 8 months ago #

    I can't help much, but I did compare yours to my setup. Nothing raised a red flag for me. Maybe try it on a page by itself to see if you can get it to work at all. I doubt there is a problem with having it in a table, but who knows.

  9. mames40
    Member
    Posted 8 months ago #

    Thanks!
    Not sure why it works on my iPhone but not my desktop. My theme isn't standard. (Don't have the standard header.php, footer.php..) Just an index.php and template files for each of my pages. Maybe that's causing a problem. Not sure why it would work on my iphone with that theme setup and not my desktop.

    Perplexed!

    I will try one page and build from there.

  10. jockoe
    Member
    Posted 8 months ago #

    That's how mine was. Worked on my phone, but not the desktop.

    I would not think it'd be your theme since, as you said, the same theme is used on your phone and it is working there. I guess it would not be caused by "tables" either, using that logic. The only difference between your phone and the desktop is probably some CSS. (it's all I can think of being different) I'm just grasping at straws.

    Good luck with this.

  11. mames40
    Member
    Posted 8 months ago #

    It must be my css because I created a template and just used the style sheet with the body of the html document being short code.

    Still didn't work.

  12. mames40
    Member
    Posted 8 months ago #

    Hi,
    I was running the javascript debugger and received the following error while running internet explorer 10

    'soundManager' is undefined

    I deleted the version of the plugin I had and downloaded v1.6 again of the compact player and reactivated. Still the same error.

    Please advise.

  13. jockoe
    Member
    Posted 8 months ago #

    Where are you downloading it from? the repository or the author's site? (I got my, working copy, from the repository.)

  14. mames40
    Member
    Posted 8 months ago #

    I got mine from the repository:http://wordpress.org/plugins/compact-wp-audio-player/.
    Tried changing browser modes to ie9 from ie10 still the same javascript error.

  15. jockoe
    Member
    Posted 8 months ago #

    Looking in the comments section of the author's page for this plugin I found this exchange. It isn't a solution, but might help in finding the issue.
    -------------------------------------

    Jerrod Long says:
    April 4, 2013 at 11:35 pm
    I am trying to utilize your plugin but it isn’t showing either button and I am getting a “Uncaught ReferenceError: soundManager is not defined”

    I tried deactivating then reactivating the plugin but that didn’t help.

    I am on WP 3.5.1

    Thanks.

    ...and this was the reply
    admin says:
    April 5, 2013 at 2:17 am
    @Jerrod, do you have a URL of a webpage where I can go and see this error? It is likely that the webpage has other JavaScript errors that is preventing this plugin’s JS code from working correctly.

  16. mames40
    Member
    Posted 8 months ago #

    Hi,
    I ran the debugger on the page that I created that has no javascript that I have introduced and still get the same error. :(.

    Thanks for your help. I posted a question on the authors page but I have not heard back from him.

    Margaret

  17. jockoe
    Member
    Posted 8 months ago #

    Sorry I couldn't help. Hope you get it figured out.

  18. Mr Red
    Member
    Posted 8 months ago #

    Works on IE 10.0.92 for me but only because I checked in desperation. Chrome 30.0.1599 Works but sounds pretty echoey (same headphones different PC)
    FireFox 24.0 seems to ignore it. (I am editing the site currently)
    Have just updated to 25.0 but not restarted yet. Will report back when I do
    WP 3.7.1
    SC 1.6
    Win 7
    http://stories.stroudfm.co.uk

    My misgivings are: the set-up has to work for everyone or it is of no use to me. The one thing that annoys me intensely is a webmeister (etc) saying "Well it works on my PC"

    Well give me your PC then!

  19. Mr Red
    Member
    Posted 8 months ago #

    FF 25.0 no better. Not editing site at that time.
    I can't test other browsers at the moment or Macs or legacy browsers. So it looks like pulling the plug(in) time anyway.
    Next!

  20. Mr Red
    Member
    Posted 8 months ago #

    Is it using Flash? I don't in FF - only in IE.
    Is this the cause? If it is a setting in FF it still has to work for everyone.

  21. Mr Red
    Member
    Posted 8 months ago #

    found this line in plug-in set-up
    soundManager.useFlashBlock = true; // optional - if used, required flashblock.css
    & this JavaScript (Presume ClientSide)

    ontimeout: function() {
    		// SM2 could not start. Missing SWF? Flash blocked? Show an error.
    		alert('Error! Audio player failed to load.');
  22. mames40
    Member
    Posted 8 months ago #

    Hi,
    The plugin uses both Flash and javascript.

  23. Mr Red
    Member
    Posted 8 months ago #

    As I surmised. Does this answer anyone elses question?

    Now mine:
    Are we locked-in to client-side plugins &/or HTML5 or are there server-side solutions that don't need to assume the surfer has either of the above?

    TIA

  24. Mr Red
    Member
    Posted 8 months ago #

    Works on all major browsers - IE7, IE8, IE9, Safari, Firefox, Chrome

    it says, but the caveat is: it doesn't fallback to HTML5. If they are the only options I do need to have it automatically choose a workable option. Legacy browsers most likely have Flash, FF may not, but modern FF has HTML5. Covers the ground, if automatic.

  25. mames40
    Member
    Posted 8 months ago #

    I haven't seen any server side solutions for plugins for wordpress.

    Have you been able to get it to work on all major browsers?

  26. urssax
    Member
    Posted 8 months ago #

    Is a great player. Unfortunately it does not work with IE 11.

  27. jockoe
    Member
    Posted 8 months ago #

    @urssax. I just upgraded to IE 11 to see if the plugin would not work with it. The plugin works fine with IE 11 on my site.

  28. mames40
    Member
    Posted 8 months ago #

    Anyone try using the pickle audio player in wordpress? http://www.pickleplayer.com They don't have a plugin so you have to set up the player manually. Wondered if anyone has tried it? Does it work in wordpress?

  29. Mr Red
    Member
    Posted 8 months ago #

    I am currently asking people to try it on the priciple they have the mix of browser/OS/Plugin combos. I will report back in a while

  30. Mr Red
    Member
    Posted 8 months ago #

    I have traced the source of my own problems. Firefox has never had Flash installed/updated by me. In fact none of the plug-ins were activated, by choice. So SC player thinks that Flash exists, and assumes it works. By disabling Flash (& other things I don't want) SC assumes there is no Flash.
    Is the detection of Flash that ambiguous? I would have thought there were flags/properties that could identify that.
    My take is that there will be few surfers who will think like me.
    But I will be putting a caveat on the website. FF plays OK now, but I have installed another player to play with its Look&Feel. It doesn't know if Flash is "not activated" either!
    IE has Flash.

Reply

You must log in to post.

About this Plugin

About this Topic