WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Comments/Links not working new install (11 posts)

  1. Zartage
    Member
    Posted 5 years ago #

    http://www.donaldjenkins.com/blog/index.php

    I've been looking for a "how to" or a post about problems with new install issues but cant seem to find one for "comments not working" nor "links not working.

    For comments issue I have tried the following.
    1. Make sure comments is turned on. Check
    2. Make sure comments are allowed on each post.. check no luck.

    I think the comments are working but the 2nd problem I have is causing it to go to a non existing page.

    As for links not working.. well I have no idea.. I'm using the template from WP 2.7.

    Set up an About page from the "Page" area on my dash board and can see the link from the index page but no luck when clicking on it.

    This goes for just about every link on the index page. Pages, Archives, Categories, comments, post.

    Links work for Blogroll/new.. but they are external links.

    Am i missing something here?

    Please direct me to a forum or documents that can help.. been looking for a few hours and cant find anything that helps.

  2. MichaelH
    Member
    Posted 5 years ago #

    When I visit http://www.donaldjenkins.com/blog/ I see a directory listing. Need to solve that first.

    Solution 1
    If allowed by your host, putting this in an .htaccess file will solve the problem:
    DirectoryIndex index.html index.htm index.php

    Solution 2
    Some hosts allow you to make a change, via their hosting control panel, to the DirectoryIndex. It's typically described as Indexes or Index documents, but may also require you to type something like
    DirectoryIndex index.html index.htm index.php
    or specify index.php as an index type file.

    Solution 3
    Instruct Apache to treat index.php as an index file. If you own the server, or have access to the http.conf file, simply modify the DirectoryIndex line in httpd.conf to:
    DirectoryIndex index.html index.htm index.php

    Solution 4
    Contact your host

  3. Zartage
    Member
    Posted 5 years ago #

    Thanks Michael, but WP is set up on /blog/index.php you missed out the index part I think? or maybe you are saying it should be /blog only?

    this is the link that I can see from both my pc's http://donaldjenkins.com/blog/index.php

    The main page is working.

    Currently I have a html site running http://www.donaldjenkins.com and dont want take it down or change the index file until I get WP up and running.

    I kept the WP folders all the same just made a folder called "blog" on directory then input all off the WP stuff.

    The index works but are you saying all of the code needs to go from the root director? for example it should look like the below?
    http://www.donaldjenkins.com/blog (index page)
    http://www.donaldjenkins.com/about
    http://www.donaldjenkins.com/photos etc..

    can you confirm?

  4. MichaelH
    Member
    Posted 5 years ago #

    The index works but are you saying all of the code needs to go from the root director? for example it should look like the below?

    No I am saying if I visit http://www.donaldjenkins.com/blog I should see your blog and I don't.

    Please follow this solution if necessary:
    Solution 4
    Contact your host

  5. Zartage
    Member
    Posted 5 years ago #

    Ok Michael I have http://www.donaldjenkins.com working now but the comments section is still not working. The server is on windows and I was told .htaccess will not work.

    Solution 2
    Some hosts allow you to make a change, via their hosting control panel, to the DirectoryIndex. It's typically described as Indexes or Index documents, but may also require you to type something like
    DirectoryIndex index.html index.htm index.php
    or specify index.php as an index type file.

    I did this and tried 3 different combinations all 3 each one .. tested still no luck.

    I've been online with my host helpdesk and they dont know how or what the problem is?

    can you take a look again?

  6. Zartage
    Member
    Posted 5 years ago #

    this is what my host provider said

    : But these links should be configured by the admin

    : If you can access your admin panel in wordpress you should there correct your links

    I can not find out where on the dashboard to change these settings.

    Tried Links/Pages etcs..

    Thanks again for your help in advance!

  7. MichaelH
    Member
    Posted 5 years ago #

    Looks like blog is deleted.

  8. Zartage
    Member
    Posted 5 years ago #

    Sorry michael, been working with my host to resolve the problems. I havent given up yet and seems I'm to a point where its almost working.

    http://www.donaldjenkins.com/blog is now working.

    However still having the same issue of unable see the following: post page, comment page, about page etc.

    Test post which is viewable on the main page but when I click on it says page doesnt exist.
    http://www.donaldjenkins.com/blog/testing-again/

    Error Message
    The page cannot be found
    The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    --------------------------------------------------------------------------------

    Please try the following:

    If you typed the page address in the Address bar, make sure that it is spelled correctly.

    Open the http://www.donaldjenkins.com home page, and then look for links to the information you want.
    Click the Back button to try another link.
    HTTP 404 - File not found
    Internet Information Services

    The same goes for commenting

    http://www.donaldjenkins.com/blog/testing-again/#respond

    My host is saying its still something to do with the Dash board settings.

    Also I found out the server I'm on is windows so dont think the .htaccess file will work (or will it?) my host said it wont. IX Webhosting is the company.

    Please let me know if I'm going in the right direction and any thoughts you might have on the next step.

  9. Zartage
    Member
    Posted 5 years ago #

    This will help no one but just to give you an example of what it took to get this program to work..

    Total time for wordpress in stall (3 weeks)

    Sergey Beletskiy: Thank you for coming, my name is Sergey. How may I help you?

    you: hello sergey, i'm following up on ticket number 957268

    you: I think we almost have this fixed but still cant get wordpress to work right

    you: unable to leave comments on post nor see new pages

    Sergey Beletskiy: Please hold on, let me check

    you: http://wordpress.org/support/topic/237673?replies=8

    you: that is the link from the Moderator on WordPress maybe it will help

    Sergey Beletskiy: thank you

    you: if you want I can give you the login information for wordpress dashboard page. I'm pretty sure all the settings are right as I had a friend of mine who uses WP check it out.

    Sergey Beletskiy: ok provide me please login and password so I can add a post to your wordpress page

    you: you can use the admin, login name (deleted login info)i will change it later

    Sergey Beletskiy: ok

    Sergey Beletskiy: please check I can write to your blog http://www.donaldjenkins.com/blog/?p=14&preview=true

    you: hm.. it goes to a blank page

    you: wait I mean after I click submit

    Sergey Beletskiy: is it ok now?

    you: not sure the link you sent me works but if i post it just goes to a blank page

    Sergey Beletskiy: provide me please a page where you make a post

    you: the link you sent me

    Sergey Beletskiy: do you see Hello message?

    you: yes

    Sergey Beletskiy: ok

    Sergey Beletskiy: I have write a post here donaldjenkins.com/blog/

    you: i can write a post but no one can comment thats the problem

    Sergey Beletskiy: then I go to site admin

    Sergey Beletskiy: ok where I should try this please give me step by step instruction how to proceed

    you: k sec

    you: http://www.donaldjenkins.com/blog/

    you: click on Testing again

    you: post

    you: and it goes to a blank page

    you: error page

    Sergey Beletskiy: checking

    Sergey Beletskiy: please recheck there is no such folder donaldjenkins.com/blog/testing-again/

    you: i know thats the problem

    you: it is there because I made it on the dashboard do you see main page?

    you: its ont here

    you: there

    you: its something on the host side settings

    you: the post is there

    you: but non one can access it

    Sergey Beletskiy: Please try it now

    you: dude you are awsome

    you: what did you do?

    you: to make it work

    Sergey Beletskiy: The meter is that you can't use Permalinks at Windows plan

    you: the meter?

    you: please explain

    Sergey Beletskiy: I have set Permalinks to default so your blog use exact url and no redirects

    you: so i cant use permalinks?

    Sergey Beletskiy: you can see this from your admins panel at Settings section->Permalinks

    Sergey Beletskiy: Yes you can't use it on windows server, but it work with default settings too

    you: ok so if i change to /%permalinks%/ it should change with no problems?

    Sergey Beletskiy: please do not use permalinks

    you: why?

    Sergey Beletskiy: because you are on the windows server and it's not support htaccess file

    you: ah ok

    you: ty for fixing wordpress

    ME PUTS A GUN TO HIS HEAD AND PULLS THE TRIGGER>>> ITS WORKING NOW BUT HOLY CRAP SCREW YOUR 5 MIN INSTALL THIS WAS BS

  10. Zartage
    Member
    Posted 5 years ago #

    So in short guys if you are on a windows sever there is no possible way to use permalinks and forget what everyone tells you on the forum.. just use the default setting (which i did from the start and it still wansnt working).. however my host helpdesk person changed some setting on the dashboard to make it work.. still have no clue what they did different from the start.

    Solution 4... thanks for nothing:)

  11. dthomas301
    Member
    Posted 4 years ago #

    Since this thread was posted so long ago, no one may every see this, but your last post, Zartage, about the Permalinks totally solved my problem. Sorry you went through so much, but just wanted you to know that you helped me.
    Thanks,
    Debbie

Topic Closed

This topic has been closed to new replies.

About this Topic