WordPress.org

Ready to get started?Download WordPress

Forums

WP Opulus
[resolved] Comments turned off/heading still on page (10 posts)

  1. tsturgell
    Member
    Posted 1 year ago #

    A page using the default template and comments turned off, is still showing the comments header. Where do I get rid of this?

    http://www.thedowntownbarre.com/about-downtown-barre/

  2. PurplePigDesign
    Member
    Posted 1 year ago #

    I'm having the same issue. I've noticed that the problem is not appearing on your site - did you get this resolved? If so, please share.

  3. tsturgell
    Member
    Posted 1 year ago #

    Not sure if this is a "resolve" or not, but it'll work. And know that I'm a hunt and peck html-er. I try stuff, it sometimes works. I rarely know why.

    Open up comments.php
    Change Line 2 from:
    <h2><?php comments_number(__('comments', 'nimbus'), __('1 Comment', 'nimbus'), __('% Comments', 'nimbus')); ?></h2>

    to

    <h2><?php comments_number(__('', 'nimbus'), __('1 Comment', 'nimbus'), __('% Comments', 'nimbus')); ?></h2>

    Just delete the word "comments" in the first double brackets.
    Not sure if that's a long-term fix or not. If I change to "resolved" we might not get a clearer answer as to why that was in there in the first place...

  4. PurplePigDesign
    Member
    Posted 1 year ago #

    Wow - that totally worked. Thank you so much. I didn't think to look in the comments - I was looking in the style sheet. BTW - I like your site, good job.

  5. NimbusThemes
    Member
    Theme Author

    Posted 1 year ago #

    Hi all,

    This will be resolved in the next version we release. Please watch for an update.

  6. Swissgebby
    Member
    Posted 1 year ago #

    Has this been resolved? I changed the comments.php like 'tsturgell' mentioned and it did not change a thing. Still have comments on every page. Can anyone help?

  7. PurplePigDesign
    Member
    Posted 1 year ago #

    Hi Swiss,

    I followed the steps posted by tsturgell and it worked for me. I'm not sure what to suggest here. You can email me directly to discuss if you like: info@purplepig.ca

    Thanks,

    Andrew.

  8. tsturgell
    Member
    Posted 1 year ago #

    Swissgebby,

    Sorry my solution didn't work for you. Did you copy and paste the line from my post above, or type it in your self?

    The only change I made to comments.php line 2 was to remove the word comments from this snippet of code: ('comments', 'nimbus')

    Which resulted in this: ('', 'nimbus')
    Note that I left the two apostrophes. What that does is leave everything in place to add a word where comment appears, but adds nothing instead. You might try replacing it with just an empty space like this: (' ', 'nimbus')

    The blank word will appear on the site. Of course, you won't see it.
    This isn't pretty or clean code in any way. It's a temp solution.
    Hopefully the Nimbus Themes update will happen soon.

  9. NimbusThemes
    Member
    Theme Author

    Posted 1 year ago #

    Hi all,

    This was addressed in the last update. Please make sure you are using the latest version.

    If the issue persists please let me know.

  10. Swissgebby
    Member
    Posted 1 year ago #

    Thanks so much all for your responses. It was finally quite easy when I found out how to do it. I just installed the Plugin 'disable comments' and it took care of it. :) Still had to get into the php to erase the line 'be the first to comment' but that was manageable, even for me :) You guys are all wonderful and thanks so much for helping us 'newbies' here xoxo

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic