WordPress.org

Ready to get started?Download WordPress

Forums

Comments, simply not working (9 posts)

  1. applejack
    Member
    Posted 9 years ago #

    Hi All, I have a new installation of WP1.5 - New posts are added fine, but noone can 'comment' on anything. All checkmarks are removed so that anyone can post w/o my okay. Note that when clicking on the 'Comments RSS' link on the menu, my browser comes up with "Page cannot be displayed" and this is what is in the address bar "feed:http://www.mydomain.com/myblog/wp-commentsrss2.php"
    When you click on the 'No Comments' link, the comment box appears, and allows you type in your comment, and click the submit button. Then the typed in text disappears, and there you are, still in the comment window. The comment never posts. HELP? Thanks, AJ

  2. oriecat
    Member
    Posted 9 years ago #

    Care to share your url so we can see it in action?

  3. lawtai
    Member
    Posted 9 years ago #

    Do you have "Logged in as . Logout" written above the box? If so, you'll need to go into your admin panel -> authors/users -> delete the blank user.

  4. Liyanna
    Member
    Posted 9 years ago #

    My commenting system does not seem to be working at all. Can anyone come to my site and explain what's wrong, please? http://capriquarius.lovable-monkey.net Thanks in advance, I really appreciate it.

  5. prissed
    Member
    Posted 9 years ago #

    You probably saw my comments in your blog, but both your RSS feed and your comments are working fine. I don't see a problem at all.

    It may just be a browser issue.

  6. applejack
    Member
    Posted 9 years ago #

    URL for applejack's (beginner's) blog is:
    http://www.lawrencegang.com/lawrenceblog
    Thanks for taking the time to look, any help appreciated, still inop

  7. applejack
    Member
    Posted 9 years ago #

    I did some snooping around in myphp database on my server (hosted). It seems as though ALL of the comments that have been submitted are stored in the comments table, but have ALL been marked as SPAM. The selections for approval are '0','1','spam' . I removed the 'spam' and tried again but to no avail. I edited ALL comments and manually changed them to 1's and they now show up on my blog. I am not running any anti spam plugins or anything. My provider runs a spam assasin of some kind on the pop srvr, but i don't think that would apply here. Any ideas guys?

  8. applejack
    Member
    Posted 9 years ago #

    I figured it out, so it would seem. ADMIN/Options/Discussions, "Blacklist comments from open and insecure proxies." was checkmarked. Removing this checkmark enabled me to place a comment. Thanks - now onto antispam issues.....AJ

  9. paulzag
    Member
    Posted 9 years ago #

    I'm having the same problem. If the checkbox is ticked and there is anything in the Comment Blacklist, all comments get marked as spam. I've tested with a long list and a single word without whitespace.

    If I uncheck the box then the Comment Blacklist works as advertised.

    But I'd rather shut out open and insecure proxies as well.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.