WordPress.org

Ready to get started?Download WordPress

Forums

Comments RSS Not Working (10 posts)

  1. Terry
    Member
    Posted 9 years ago #

    I did do a search for this first, but either the problems aren't the same or I'm not understanding how to fix this.

    My blog:

    http://superaff.com/

    Comments Feed:

    http://superaff.com/index.php/comments/feed/

    error message:

    The XML page cannot be displayed

    Reference to undefined entity 'raquo'. Error processing resource 'http://superaff.com/index.php/comments/feed/'. Line 22, ...

    =================

    Can someone help me figure out how to fix this? Or what's causing the problem? Please?

    :)

  2. Selladore
    Member
    Posted 9 years ago #

    I am having the same problem with the RSS feed for my blog. I get the message:

    The XML page cannot be displayed
    Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.
    --------------------------------------------------------------------------------

    An invalid character was found in text content. Error processing resource 'http://www.gregmulholland.org/wordpress/wp-rss2....

    <title>

    Not quite sure what has happened as this was working fine last time I looked. Would really appreciate some help with this.

    Thanks

  3. Terry
    Member
    Posted 9 years ago #

    I can see there's a problem with the raquo - but my problem is this, I'm not inserting the raquo - WordPress is, I thinks so because I know I'm not lol. At least that's how I understand the error? That it's choking on raquo given the message displayed here:

    http://superaff.com/comments/feed/

    I admit I am very newbie at this feed/blog stuff, so if I'm misunderstanding the problem and how I need to fix this, I'd really appreciate this. :)

  4. Terry
    Member
    Posted 9 years ago #

    Ummm I meant to say I'd really appreciate help on this lol!

    <quote>
    I admit I am very newbie at this feed/blog stuff, so if I'm misunderstanding the problem and how I need to fix this, I'd really appreciate this. :) </quote>

  5. Kafkaesqui

    Posted 9 years ago #

  6. Terry
    Member
    Posted 9 years ago #

    Kafkaesqui you absolutely saved the day!!!

    Thank you very, very much.

    :)

    It's perfect!

  7. 2bak860
    Member
    Posted 9 years ago #

    Hi All

    http://feedvalidator.org/check.cgi?url=http%3A%2F%2Frosschapman.com%2Fcomments%2Ffeed%2F

    I'm having just one error, which I can't explain. It's on line 59:

    <title>by: Ross Chapman » Blog Archive » Sony HVR-Z1E</title>

    and I believe it's supposed to be:

    <title>by: Ross Chapman</title>

    Any ideas on how I can change this. Much appreciated.

  8. Tim Griffin
    Member
    Posted 9 years ago #

    Ok,
    I have tried several things to get this feed thing to work.
    http://www.griffhome.com/comments/feed/
    returns this parsing error:
    This feed does not validate.
    *
    line 299, column 22: XML parsing error: <unknown>:299:22: not well-formed (invalid token) [help]
    <title>by: Cynthia & Terry Toland</title>

    (as checked on http://www.feedvalidator.org)

    I just installed the "entitytoNCR" plugin - and nothing changed...

    From the browser I go to wp-commentsrss2.php or to comments/feed/ and I get the same error...

    I have not found a solotion... I am using permalinks, the feed for the posts appears to be working just great...

    a little perplexed... :-

    thoughts?
    solutions?

    tGriff

    PS - when will 1.5.1 be available...? I have two more upgrades to go - but might wait...

  9. Novac
    Member
    Posted 9 years ago #

    tGriff, if Entity2NCR didn't help you out and you simply want a quick fix until you are able to upgrade to 1.5.1, just look through all of your comments and manually edit anything that has the ampersand-raquo. You'll want to edit the title to remove that special symbol or change it to the numeric equivalent if WP allows you to. Once you have that out of there, you should be all set.

    But, like I said, that's a temporary fix. If someone posts or trackbacks with raquo again, it will break again and you'll need to do some more editing.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.