WordPress.org

Ready to get started?Download WordPress

Forums

Sunspot
[resolved] Comments on posts becomes too narrow (5 posts)

  1. Scottbdoug
    Member
    Posted 1 month ago #

    I have found that when users comment on a posting, each new comment in indented from the previous comment. Once four comments have been made the text area has become much too narrow and even a simple paragraph takes up more than a page-length in space.

    Here is what I mean:

    http://nclcollecting.ca/?p=6203

    Is there anyway to have the comments stay the width they originally started at?

    Thank you

  2. The simplest option is to turn off comment nesting under Settings > Discussion.

    Uncheck the box next to "Enable threaded (nested) comments [X} levels deep.

    You could alternatively keep comment nesting, but just reduce the level of nesting to 1 or 2 deep.

  3. alchymyth
    The Sweeper & Moderator
    Posted 1 month ago #

    you can change the comment indents by adding some CSS via a custom CSS plugin or a child theme;

    example:

    .commentlist li.comment { padding-left: 1em; }
    .commentlist .comment-author { margin-top: -0.4em; padding: 1em 0em 2.9em 5em; }
  4. If you decide to go the CSS route, since you're already using Jetpack, an easy way to add custom CSS is to activate the Custom CSS module. You'll then add your custom CSS in the new stylesheet editor that'll appear in your dashboard, under Appearance > Edit CSS. Don't edit the theme files directly, otherwise your changes will be overwritten when the theme is updated.

  5. Scottbdoug
    Member
    Posted 1 month ago #

    Thank you everyone i used the setting-discussion option katheryn suggest and its great.

    Scott.

Reply

You must log in to post.

About this Theme

About this Topic