WordPress.org

Ready to get started?Download WordPress

Forums

Customizr
[resolved] Comments on Posts (10 posts)

  1. sdevendorf
    Member
    Posted 5 months ago #

    I am using Customizr and I have a Blog (Post) page. Under Screen options, I have unchecked Comments but when I go to my site, I still see Comments at the bottom of each post.
    I have a select by Category dropdown in my right sidebar. If I select a Category, then it opens the post and says Category Archives.
    What makes something go in Archives and why do I still see Comments on my posts.

    Thank you.

  2. sdevendorf
    Member
    Posted 5 months ago #

  3. nikeo
    Member
    Theme Author

    Posted 5 months ago #

    Hi,
    to disable your comments, go to settings > discussion and select your comments options
    About categories : you select a category for a post when you edit it. Then this post is linked to this category and there's a page for each categories. This is the taxonomy logic of WordPress.

    Hope this will help and enjoy the theme
    PS : thanks for your review by the way!

  4. sdevendorf
    Member
    Posted 5 months ago #

    I am still seeing Comments. I might take the Post off and put it back on again and see what happens. On each Post, I have selected Screen options, and unchecked Discussion and Comments.
    Under Settings, Discussion I have the following
    Attempt to notify any blogs linked to from the article Check
    Allow link notifications from other blogs (pingbacks) Check
    Allow people to post comments on new articles Uncheck
    Comment author must fill out name and email Check
    Users must be registered and logged in to comment Check
    Automatically close comments on articles older than 14 days Check
    Enable threaded (nested) comments Uncheck
    Break comments into pages with 50 top level comments Uncheck
    Email me when anyone posts a comment Check
    Email me when a comment is held for moderation Check
    Before a comment appears comment must be manually approved UnCheck
    Before a comment appears Comment author must have a previously approved comment Check

  5. sdevendorf
    Member
    Posted 5 months ago #

    I just Deleted my Posts and reposted them. Now they are not allowing comments which is what I wanted.
    Thank you for your help.

  6. nikeo
    Member
    Theme Author

    Posted 5 months ago #

    Ok fine. Thanks for this feedback @sdevendorf.

  7. hassan.Zia
    Member
    Posted 3 months ago #

    I Have about 190 posts and i want to remove "comments" on them.
    i did what was told above. but i cannot delete and make my posts again. what to do?

  8. ElectricFeet
    Member
    Posted 3 months ago #

    This is not a Customizr-specific question, but a WordPress one. Google gives some suggestions if you search on "delete all comments in wordpress" (without quotes).

    Otherwise, there are some plugins that do this, though I don't know how good they are. Check here.

  9. jbush82
    Member
    Posted 3 months ago #

    ElectricFeet is correct hassan.Zia, this is not a Customizr issue but I think I can help. WordPress does not modify the post settings (such as allowing comments) on existing posts or pages when you change the settings, only new posts or pages will inherit the changes. As such, each post will need to be edited to update the allow comments option. To do this, follow these simple steps.

    1. Login to your admin panel
    2. Click posts or pages, whichever you want to disable comments on
    3. Hover over the title of the post or page, then click Quick Edit
    4. Uncheck the box, "Allow Comments"
    5. Click Update
    6. Rinse and repeat

    Hope this helps!

  10. hassan.Zia
    Member
    Posted 3 months ago #

    i guess you are right. oh well. unchecking all "allow comments" initiate.
    thanks for the guidance :)

Reply

You must log in to post.

About this Theme

About this Topic