WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "Comments off" despite all discussion settings saying otherwise (5 posts)

  1. paulcoholic
    Member
    Posted 4 years ago #

    First, I did a search and found answers, but they seem inapplicable.

    Second, my problem:

    I have a new blog using WP 3.0.1. At the end of each post it says, "Comments off", despite the Dashboard-->Settings-->Discussion-->Discussion settings are all set to allow comments to be posted.

    "Allow people to post comments on new articles" is checked.

    In the "Other comment settings" section, nothing is checked except enabling nested comments. Therefore, no one has to fill out a name and email address, or even be a prior commenter.

    The only other thing that is checked is that I get emailed whenever someone posts a comment.

    So, what's wrong? My blog was imported from Blogger, where I did have comments moderated. Is that somehow interfering?

    Thanks!

  2. Find a post that has comments off.

    Edit that post.

    Find the "Discussion" box on that page. There should be a box with two checkbox fields:
    Allow comments.
    Allow trackbacks and pingbacks on this page.

    Is allow comments checked?

  3. paulcoholic
    Member
    Posted 4 years ago #

    Thank you, ipstenu.

    I went to where you said, and did what you said. "Allow comments" is now checked, and comments are now allowed for that post. But comments are still off for all the older posts. I do not want to have to go back to each post for the past few weeks and do this.

    I do not post to my blog from the WordPress editor. I use a Mac blog editor called "Mars Edit".

    How do I enable comments for all new and future posts? I will poke around Mars Edit and see if anything can be done there, but I am curious if anything can be done within the WordPress end.

    Thanks!

  4. paulcoholic
    Member
    Posted 4 years ago #

    Never mind. I found the answer to this within my MarsEdit app.

    Problem solved.

  5. I was going to suggest an SQL change :) I just wanted to see if I was right about the cause. Glad Mars Edit worked.

Topic Closed

This topic has been closed to new replies.

About this Topic