WordPress.org

Ready to get started?Download WordPress

Forums

Comments notification not emailed anymore. (36 posts)

  1. Anonymous
    Unregistered
    Posted 9 years ago #

    As suggested, a new thread:
    I've been using wordpress for...well quite sometime now. I'm currently using wordpress 1.2.1
    My problem, which just sprung out of nowhere is that when someone posts a comment I no longer get notification emailed to me.
    I've tried changing email addresses thinking that perhaps it was my mail server, so I've tried my other pop3 accounts and various webmail (gmail, yahoo, hotmail, etc.) but to no avail.
    Curious to know if anyone has or has had this problem and if they know how to correct it.
    Thanks,
    Jessica.

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Have you contected your host and asked of anything has changed on their side ?
    If it was working, and now it does not, then someone has introduced a change somewhere.

  3. Anonymous
    Unregistered
    Posted 9 years ago #

    Nothing has been changed on the server side that's why I'm so perplexed

  4. deb5376
    Member
    Posted 9 years ago #

    Jessica, the same thing has happened to me. I haven't made any changes and neither has my host. The notification problem just sprung up out of the blue.
    I hope you find out what's caused it and hope someone here can help because it's obviously not an isolated case.
    Will be checking back...
    Thanks.

  5. Anonymous
    Unregistered
    Posted 9 years ago #

    the same thing has happened with me too, i think this happens only in the 1.21 version.... it was working fine till the last version.

  6. Anonymous
    Unregistered
    Posted 9 years ago #

    I still haven't been able to fix it, anyone else find anything new?
    Thanks.
    Jessica

  7. James
    Happiness Engineer
    Posted 9 years ago #

    Out of the off chance that it's just a weird glitch, go to Options/General, change the email address to anything, hit save, then change it back to whatever you prefer, and hit save again. I've never had this problem, so I'm not sure how to fix it. But I am running v1.2.1.

  8. Anonymous
    Unregistered
    Posted 9 years ago #

    I've tried before but just by chance tried again because of your suggestion, but no luck. Thanks though.
    Jessica

  9. stainofink
    Member
    Posted 9 years ago #

    Just trying to boost this discussion back up, wondering if anybody has figured out this problem yet? It's been months and I still haven't figured out the culprit.

  10. Chris
    Member
    Posted 9 years ago #

    I'm having the same problem on 2 wp sites. One running 1.3-alpha-4 and the other 1.5-beta-1 2005-01-15 but the notifications haven't worked since 1.2.

  11. Just wanted to bump this thread. #

  12. *sigh* I'm sorry. Nevermind for me.

  13. Martijn
    Member
    Posted 9 years ago #

    I had the same problem on my new installation (1.2.2). After a quick trace in the code I could find nothing wrong there. Then I tried mailing using the "mail" command on a console.
    ( type "mail you@email.address" <enter> "some text" and ctrl-d ctrl-d. )

    This also didn't work indicating that wordpress was not the problem. It turned out to be a rights issue on the dir where the mail command drops the mail.

    Hope this can help somebody.

  14. whoneedsoxygen
    Member
    Posted 9 years ago #

    Thanks for the input Martijn. Your post actually headed me into the right direction. I logged onto my server via FTP to check the permissions for all my files (by checking the properties for the directories). It turns out that my dirs have all the wrong permissions set. Which now has me in a new problem...

    I chmod the files and folders to the correct permissions only my FTP client [leapftp] spit back and error: "500 Unknown Command". Now I'm doubly perplexed.

    Jessica

    Guess it's time to figure this problem out now too.

  15. dalziel
    Member
    Posted 9 years ago #

    Same problem over here. Version 1.5. I tested the mail command & it works fine on the server.

    I dug out the functions.php file in the wp_includes directory which contains the wp_mail function. Flagged around the
    return @mail($to, $subject, $message, $headers, $more);
    line, which showed it is running that command.

    Took the @ off the front of the function & it still returned no errors. However the function returns a blank value (ie. false) so the php mail command isn't working.

    So I replaced the command with mail('**my email address**', 'Hello', 'This is atest'); and it worked! So there seems to be a problem in the arguments being sent to the mail function.

    Still looking...

  16. dalziel
    Member
    Posted 9 years ago #

    OK, I've found that if I remove the $more parameter from the
    return @mail($to, $subject, $message, $headers, $more);
    function it works.

    Funny thing is that the $more variable is empty, no value at all.

    Very weird.

  17. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

    Is safe_mode turned on? That could be the problem. We should probably get rid of the more argument.

  18. dalziel
    Member
    Posted 9 years ago #

    Nope, no safe mode.

    I would agree with removing it (I have) as long as we're sure it's not needed for anything.

  19. dalziel
    Member
    Posted 9 years ago #

    I've just checked & I can't find anywhere that uses the $more parameter in any of the WP code, unless there's a plugin that needs it, but then I suppose they can write their own function :)

  20. stoermer
    Member
    Posted 9 years ago #

    Howdy!

    I upgraded to 1.5 a few days ago. Very nice, btw. I found the mail() problem this morning. So from reading these posts, I can safely remove all the $more variables from all the phps.....right?

    Is there a planned patch for this soon?

  21. Daisyhead
    Member
    Posted 9 years ago #

    I just tried the above fix (removing the $more variable from @mail($to, $subject, $message, $headers, $more);) and it didn't work for me. Still not getting any comment notification emails. =(

  22. Daisyhead
    Member
    Posted 9 years ago #

    Actually, I just got my problem fixed! Resolution can be found here, http://wordpress.org/support/topic.php?id=23920

  23. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

    The $more problem will be fixed soon. Track the issue with this bug:

    http://mosquito.wordpress.org/view.php?id=855

    If removing $more works for you, add a note to the bug.

  24. Daisyhead
    Member
    Posted 9 years ago #

    Should I add it back if I've already removed it? Or if I'm not experiencing any problems, can I just leave it?

  25. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

    We'll be removing it, so if you have removed it there's no need to add it back.

  26. Daisyhead
    Member
    Posted 9 years ago #

    Thank you!

  27. amydef
    Member
    Posted 9 years ago #

    "If removing $more works for you, add a note to the bug"

    How do you add a note to the bug? I just went over there and registered, but I'm somehow not seeing where you add your comment. Or is it closed? At any rate, thanks for the fix.

  28. silverh
    Member
    Posted 9 years ago #

    i have this problem too. sadly, removing the $more argument didn't work for me...

  29. umar
    Member
    Posted 9 years ago #

    me too... upgraded to 1.5 a week ago... got emails for new comments for a day but then it stopped... removed $more argument but that also didnt work... gotta be some other problem.

  30. silverh
    Member
    Posted 9 years ago #

    bump.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.