WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] comments not working and post permalinks not right (6 posts)

  1. lutetia
    Member
    Posted 4 years ago #

    Hello all,

    I have a website that up till now has consisted only of pages.I have enabled comments on pages and these work fine.

    Recently I started a blog on the first page. So far I have only posted two posts (one is a sticky). I have enabled comments in the general settings, as well as manually for each post.

    Yet when one clicks on the "no comments" beneath the posts, nothing happens. The front page simply reloads.

    In fact, when you click on the title of either post, instead of loading a page with only that post on it, the whole front page simply reloads showing both posts.

    Now, trying to figure this out, I saw in another message in the forum that a user with the same problem was missing a single.php file, however I do have one in my template. So I assume that's not the problem.

    Also, I just noticed my post permalinks are weird, i.e. I only have two posts so far and they both end like this "/archives/%post%20name%/" (i.e. not with the file name itself, but with that exact string).

    In my permalink settings, it's set to custom structure : /archives/%post name%; The permalinks for my pages are fine and all end with the page title; it's only the posts that aren't showing the actual post name. I have All in One SEO plugin installed also.

    Based on the above, could anyone please help me troubleshoot the malfunctioning comments (and permalinks). I do not have a clue what to do.

    My website is here.
    Thank you

  2. lutetia
    Member
    Posted 4 years ago #

    Another clue - I just noticed that when I click on the "change permalinks" button when editing a post, I get redirected to the permalinks setting page (where the default option is set), whereas, when editing a page, I have an option editing the page permalink right then and there...

  3. lutetia
    Member
    Posted 4 years ago #

    I am beginning to wonder if this might not be a conflict between All in One SEO and WP Permalink settings, at least as far as post permalinks are concerned.

    Anyone have any suggestions on what to try?

  4. lutetia
    Member
    Posted 4 years ago #

    OK, I've solved this by changing the permalink structure from the custom structure indicated above to "month and name". I also deactivated the All in one SEO plugin, just in case.

    Comments are now working and permalinks look normal.

    Maybe someone else will find this useful.

  5. lutetia
    Member
    Posted 4 years ago #

    By the way, I have since reactivated the All in One SEO plugin and have not had any problems with it.

  6. Pearlpod
    Member
    Posted 3 years ago #

    Thanks for your posts. I was having the exact same issue. Looks like I'll have to learn the custom permalinks a little better!

Topic Closed

This topic has been closed to new replies.

About this Topic