WordPress.org

Ready to get started?Download WordPress

Forums

Comments Not Working (10 posts)

  1. ameljor322
    Member
    Posted 1 year ago #

    Hi,
    I have just discovered my comments is not working, I have a feeling this has been going on for some months now. Thanks to a nice person, who sent me an email....

    When a comment is added and submitted, this page appears.

    Error:
    EN: please enable JavaScript and don`t spam me anymore.
    Thank you !

    RO: Salutare botule, te rog fugi d`aici, nu am nevoie de comment-urile tale pline de spam.
    Daca nu esti robot activeaza JavaScript in browser si revino.
    Multumesc!

    Does anyone know how I may fix this? I have searched and searched for answers but to no avail. Also, I have not been able to check if it is theme related as the Twenty Ten theme is installed, yet the template is missing so I am unable to use it. Not sure what that is all about either.

    Really need someone to check it out, but for now, if I can get the comments fixed that would be good.

    Thanking you in advance,
    Pauline.

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Site URL?

  3. inclouddesign
    Member
    Posted 1 year ago #

    I also have problems with comments and have most likely set up WordPress incorrectly. I have played around with it in the past and always end up getting a huge amount of spam comments. Not sure how to set the comments to avoid spam. Akismet is set up and right now I have it set to users must be registered and for me to receive an email to moderate. The spam comments don't notify me and other than the spam, I get absolutely no comments at all. Any info that could help us out in getting a better comments system down would be highly appreciated. Thanks in advance for any and all support on this matter.

    [signature moderated]

    Blog

  4. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    1. Reset your discussion settings, checking and unchecking various options to see if it works.
    2. Try plugins like:
    http://wordpress.org/extend/plugins/spam-free-wordpress/
    http://wordpress.org/extend/plugins/commentluv/

  5. inclouddesign
    Member
    Posted 1 year ago #

    Thanks for such a quick response, I've toyed around with quite a few settings and plugins and always end up reverting back to high security and no comments. I will look into the above mentioned and see if my luck changes. Is there any way without reinstall to reset a specific part of WordPress to default. The discussion section in this case?

  6. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    The discussion section in this case?

    Personally I do not use any plugins to manage comments. I use only the dashboard settings (Settings > Discussion). You can try various options there. Most importantly you can use the boxes at the bottom of the page for blocking/ blacklisting certain words or parts of words in contmments such as name, URL, e-mail, IP, address, etc. so that they will be held in moderation queue.

  7. inclouddesign
    Member
    Posted 1 year ago #

    I'd actually prefer to stay as light as possible as far as plugins myself. WordPress seems to get sluggish as you load it with plugins. Thanks for your response above. I did go back in and lessen my security. After logging out and posting a comment to test, I still never receive an email for moderation of comments. I'll take your suggestion and go clean out my blacklist and start new with some basics as stated above by yourself. Thanks again!

  8. ameljor322
    Member
    Posted 1 year ago #

    Hi Krishna,
    my site is; foreverlookingood.com
    All was fine, so I have no idea what went wrong, unless it was a recent plugin?? I don't know, I am totally at a loss.
    Having said that, I have not deactivated and reactivated plugins, so perhaps I should do that.
    thanks.

  9. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    @inclouddesign

    please start your own topic

    - hijacking someboy else's topic is confusing, to say the least...

  10. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    @ameljor322
    I find your comment box and get the error message quoted by you. As you mentioned, it can be because of some plugin.
    Anyway, deactivate all plugins and revert to Twenty Eleven theme and see if the problem persists. You can revert to your current theme later.

Topic Closed

This topic has been closed to new replies.

About this Topic