WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Comments Not Working (5 posts)

  1. jrbcalendar
    Member
    Posted 5 years ago #

    Using inove 1.2.3 theme for http://www.johnnyrodgers.com/wordpress .
    Comments do not work - click on "No comments" to leave a comment, get an http 404 error.
    Does not seem that I can edit the various files in the template editor?

    Have seen some posts re: single post php file... other forum posts suggest changing out the comments-popup.php or the comments-post.php files... or doing something to the comments db table.

    I am VERY new at wp - and still learning. Advice much appreciated.

    ALSO - the WP-POLLS shows on the template - but after the first poll, it is showing only results and does not let others participate in the POLLS. Any ideas here? Not sure if the problems are related.

  2. jrbcalendar
    Member
    Posted 5 years ago #

    OK - I figured out that I need to edit files on my host... so that issue is resolved....the dashboard template editor shows the files, but does not allow editing apparently?

    Any way my comment adding problem AND my WP-Poll problem still exist.

    I am using 2.7 - new blog at http://www.johnnyrodgers.com/wordpress and comments will not work ...Have tried several templates to no avail.. I think that all the templates do not have separate comments files - so it must be something in the comments php files themselves?

    I get a "webpage can not be found" error http 404.
    The following code for adding comments in the single.php file goes to a href #respond acording to the URL....

    <span class="comments"><?php _e('Goto comments', 'inove'); ?></span>
    <span class="addcomment"><?php _e('Leave a comment', 'inove'); ?></span>

    ALSO - the closest thing to template_comments is this code in the single.php file is :

    <?php include('templates/comments.php'); ?>

    ANY IDEAS?

  3. jrbcalendar
    Member
    Posted 5 years ago #

    the link that appears when I click on the post to add a comment goes to http://..../wordpress/blogpost name/#response .

    the #response link does not appear to exist. Any thoughts where this link should be?

  4. jrbcalendar
    Member
    Posted 5 years ago #

    I finally got set on track. The issue was one that the .htaccess file was not created when WordPress was installed.

    Under SETTINGS is the Permalinks area that is used to identify the URL for your blog posts. There are a variety of selections there. Since I am hosting WordPress on my own, apparently WP is unable to add or update this area automatically (like it does on adding Plugins). So one has to update the .htaccess file yourself. NOTE: It does say this cryptically at the bottom of the Permalinks page - but for a newbie like me - I just did not get it until I read the ALL ABOUT PERMALINKS section of the WP documentation.

    I created a 1.htaccess file copying the code suggested at the bottom of the Permalinks page. Then I ftp'd the file to into my WordPress directory, changed the name to .htaccess ... and suddenly I was able to post comments.

  5. daniellejosh
    Member
    Posted 4 years ago #

    I am still unclear about what you did to resolve your problem? I am having issues with my "Leave a comment" links... on every page EXCEPT my homepage. My website is http://iphonecustoms.com. Could you possibly look and see if it is similar to the problem you were having? I am new to WordPress also...

Topic Closed

This topic has been closed to new replies.

About this Topic