WordPress.org

Ready to get started?Download WordPress

Forums

Comments not working (18 posts)

  1. elliotlee
    Member
    Posted 9 years ago #

    Under Leave a Reply it says

    Logged in as . Logout »

    Example:

    http://www.intelliot.com/blog/archives/2005/02/23/upgraded-to-wordpress-15/

    I don't want to require users to register/login to post a comment.

    Comments were working under 1.2

  2. Go to Options/General and uncheck "Users must be registered and logged in to comment".

  3. elliotlee
    Member
    Posted 9 years ago #

    It is unchecked.

  4. elliotlee
    Member
    Posted 9 years ago #

    To clarify, yes, I had already unchecked it. It still does not appear to be working - see the site for example.

  5. elliotlee
    Member
    Posted 9 years ago #

    I also tried re-upgrading WordPress (downloaded the 1.5 zip, uploaded all files, copied my config.php, regenerated my .htaccess) and still no go.

    Again, "Users must be registered and logged in to comment" is unchecked.

  6. Run /wp-admin/upgrade.php .

  7. Elliot, on your blog you mention deleting the section of code which controls whether or not registered users can post. I highly suggest that you replace your copy of /wp-content/themes/default/comments.php with a fresh copy from a new WordPress download.

  8. elliotlee
    Member
    Posted 9 years ago #

    I have replaced it with the original version. I am using a fresh copy from a new WordPress download (wordpress-2.5-strayhorn.zip).

    Deleting the section of code allowed the name and email boxes to show up, however, they did not work. Filling them out had no effect (it posted as Anonymous).

  9. elliotlee
    Member
    Posted 9 years ago #

    To clarify, the blog is now using the default WordPress install with the original /wp-content/themes/default/comments.php.

    I realized my code edit, although it made the name, email, and website boxes appear, did not cause them to actually function. The blog is now reverted back and the WordPress files are the original ones. The only change from a default install is that -

    1) It is an upgrade, so the database is an old one; Yes, the upgrade.php file has been run.

    2) I am using "pretty" permalinks with a custom .htaccess file.

    That is all..

  10. Out of curiosity, will comments work if you enable the Classic theme?

  11. elliotlee
    Member
    Posted 9 years ago #

    Good idea. Unfortunately, it's the same result:

    Logged in as . Logout »

    I'll leave it on Classic for now, so you can see.

    Note that it's the same with the default (new) theme.

  12. 0_0 Wow. I'm out of ideas, sorry. Anyone else?

  13. elliotlee
    Member
    Posted 9 years ago #

    Looking at the code, I think a value must be getting into $user_ID somehow. Where is this variable initialized?

  14. elliotlee
    Member
    Posted 9 years ago #

    Where is get_currentuserinfo() ?

  15. jonnyboy
    Member
    Posted 9 years ago #

    I'm facing the same problem; I'm pretty sure that something has failed during the database conversion process for 1.2.1/1.2.2 users.

  16. jonnyboy
    Member
    Posted 9 years ago #

    In short, I've had to simply turn comments off because people kept replying into the db_blackhole :)

  17. elliotlee
    Member
    Posted 9 years ago #

    I've fixed it (sort of). I had to hack up:

    wp-content/themes/default/comments.php
    wp-comments-post.php

    Basically, I removed all the stuff that checks if you're a user, registered, login, user info, that sort of thing. Commenting works now (test it). This solution, while it isn't pretty, works for me because I don't want to require users to register.

  18. jonnyboy
    Member
    Posted 9 years ago #

    elliotlee, is your solution applicable to everyone else?

    Has anyone posted a working solution?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.