WordPress.org

Ready to get started?Download WordPress

Forums

Comments not an option on blog posts (6 posts)

  1. markerette
    Member
    Posted 1 year ago #

    Hi,

    So I'm having an issue with my wordpress site. I think I may have deleted some coding last year but I can't remember. I had a business site that I added a blog to. So when I first set it up I didn't want comments on posts but now I do. However, I can't seem to get them to show up on any of my blog posts only on the About page! The site is:

    http://esquescript.com/esque-blog/

    Any advice would be much appreciated!!

    Thanks,

    Molly Margaret

  2. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    have you checked all dashboard settings regarding comments/discussion?

    does your theme's single.php contain a line with comments_template(); ?

  3. markerette
    Member
    Posted 1 year ago #

    Yeah, in the dashboard comments/discussion section it's all set up for comments to occur. When I write a blog post selecting to allow comments isn't even visible though. And yes, the comments_template();? is there:
    <?php
    /**
    * @package WordPress
    * @subpackage Showcaser Theme
    */
    ?>
    <?php get_header(); ?>
    <div class="post clearfix">

    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>

    <div id="page-heading">
    <h1><?php the_title(); ?></h1>
    <div class="post-meta">
    <span class="meta-date"><?php the_time('j'); ?> <?php the_time('M'); ?>, <?php the_time('Y'); ?></span>
    <span class="meta-category"><?php the_category(' '); ?></span>
    <span class="meta-author"><?php the_author_posts_link(); ?></span>
    <span class="meta-permalink">" title="Permalink"><?php _e('Permalink'); ?></span>
    </div>
    <!-- END post-meta -->
    </div>
    <!-- END page-heading -->

    <div class="entry clearfix">
    <?php if ( has_post_thumbnail() ) { ?>
    <div class="post-thumbnail">
    <?php the_post_thumbnail('single-image'); ?>
    </div>
    <!-- END post-thumbnail -->
    <?php } ?>
    <?php the_content(); ?>
    <div class="clear"></div>

    <?php wp_link_pages(' '); ?>

    <div class="post-bottom">
    <?php the_tags('<div class="post-tags">',' , ','</div>'); ?>
    </div>
    <!-- END post-bottom -->

    </div>
    <!-- END entry -->

    <div id="post-author" class="clearfix">
    <?php echo get_avatar( get_the_author_meta( 'user_email' ), apply_filters( 'platformbase_author_bio_avatar_size', 50 ) ); ?>
    <h4><?php _e('About The Author') ?></h4>
    <?php the_author_meta('description') ?>
    </div><!-- END post-author -->

    <?php comments_template(); ?>

    <?php endwhile; ?>
    <?php endif; ?>

    </div>
    <!-- END post -->
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

  4. JonWicks25
    Member
    Posted 1 year ago #

    Just to check and point out the obvious. Have you got the settings enabled

    Dashboard > Settings > Discussion

    If not enabled enable them. You may also need yo 'bulk edit' current blog posts to allow commenting to do this

    Dashboard > Posts > All Posts >

    Tick/check posts you want to enable commenting on then where 'Bulk Actions' is select edit and click 'Apply' On the new bulk area that has appeared by comments select 'Allow' and update.

    This may already be set correctly just a good starting point to check for the basic settings are enabled

  5. markerette
    Member
    Posted 1 year ago #

    Jon, Yes, I had the comments enabled in the "Dashboard > Settings > Discussion" section but they still were not showing. Then I did your All posts edit and they showed up. So all that to say I think you found me problem! I appreciate your help!!!

  6. JonWicks25
    Member
    Posted 1 year ago #

    Your welcome. Just double check you have "Allow people to post comments on new articles" turned on in
    Dashboard > Settings > Discussion

    or you will have to select allow posts for every new blog post. Unless you want it that way

Topic Closed

This topic has been closed to new replies.

About this Topic