WordPress.org

Ready to get started?Download WordPress

Forums

Comments links broken - help! (7 posts)

  1. naomijps
    Member
    Posted 5 years ago #

    So far, I only have three posts on my blog (http://www.jpsblog.org/blog), but the "comments" links under each of the three posts is broken - when I click on "comments", I am taken right back to my blog page, as if I hit the reload button (except the page title then becomes "Nothing found for %request_words%").

    All the proper settings have been turned on in Discussion Settings (I've allowed people to post comments, etc). Also, I've checked off "allow comments on this post" for each individual post as well. I don't know what could be the problem. What do I do?

    Thanks!

  2. blogmum
    Member
    Posted 5 years ago #

    The link's actually fine - it's just that where the link is trying to go to isn't there.

    Does your theme have a single.php file? It seems like everything's on index.php from what I can see. So when the link from the front page tries to go to the comments section of the single post page (which is what your links point at), that's not there.

    Have a look at WP Admin > Appearance > Editor: what files do you see listed to the right of the big text box?

  3. naomijps
    Member
    Posted 5 years ago #

    Hi blogmum,

    These are the files listed in the editor:

    Templates

    * Archives (archive.php)
    * Comments (comments.php)
    * Footer (footer.php)
    * Header (header.php)
    * Main Index Template (index.php)
    * Page Template (page.php)
    * Search Form (searchform.php)
    * Search Results (search.php)
    * Sidebar (sidebar.php)
    * Theme Functions (functions.php)

    Styles

    * Stylesheet (style.css)
    * reset-fonts-grids-tabs.css (reset-fonts-grids-tabs.css)

  4. naomijps
    Member
    Posted 5 years ago #

    What exactly is a single.php file, and how do I add it?

  5. blogmum
    Member
    Posted 5 years ago #

    single.php is the file that displays a single post with its comments. So it looks like that's missing from your theme.

    Can you go back to the person who wrote your theme and get them to do it?

    Otherwise, you'll need to do a bit of editing of PHP/HTML: either to add the comments into your index file (probably will get very messy very quickly - you don't want comments all over the front page, do you?) or to add in single.php. The latter would be my preferred option: copy single.php from WordPress default and edit it to fit your current theme.

  6. broynow
    Member
    Posted 4 years ago #

    Blogmum! Hello...

    I have a similar issue with Comments on my Theme. At the top of my blog/theme for http://www.broynow.com you see the link "Comments" !?! Well when you click on the link...Notta, Just takes you to a broken page-"Comments for BRN http:/broynow.com...etc".. It doesn't actually show comments users have made. -Note: its a new blog and I only have one comment :)

    Any Ideas? Thanks :)

  7. nakikim
    Member
    Posted 4 years ago #

    Well, I did my serch up and solved my problem.

    First, you got to check your permalink.
    If you don't have .htaccess file or know what it is.
    Dig to know .htaccess.

    If you are done with .htaccess, then change your permalink structure to
    one of provided formats instead of custom one. It is my way of solving problem.

Topic Closed

This topic has been closed to new replies.

About this Topic