WordPress.org

Ready to get started?Download WordPress

Forums

Comments link only refreshes page (45 posts)

  1. chymx2
    Member
    Posted 9 years ago #

    Hi
    http://www.ominousblog.com
    I just finished installing 1.5
    When you click on the comments link it just seems to refresh the page? Any Idea what I need to do?

  2. oriecat
    Member
    Posted 9 years ago #

    Same thing happens if you click on your permalinks, it shows everything instead of just the one post. What kind of theme are you using?

  3. chymx2
    Member
    Posted 9 years ago #

    I had created my own "theme" but then just decided to use one that came with it to see if it would work so rigt now I am usign that "kuberic" one

  4. chymx2
    Member
    Posted 9 years ago #

    oh and all of my comments can be view in the admin area

  5. philpeeps
    Member
    Posted 9 years ago #

    copy the 2 comments files from the classic theme and replace your themes files...and presto, they will work....

  6. chymx2
    Member
    Posted 9 years ago #

    I tried that and no luck, just seems to refresh the page

  7. Kafkaesqui

    Posted 9 years ago #

    This has something to do with the way your site's server is handling default page queries. For example, this:

    http://www.ominousblog.com/?p=6

    Just takes you to the main page, but:

    http://www.ominousblog.com/index.php?p=6

    opens the post.

  8. chymx2
    Member
    Posted 9 years ago #

    wow! any ideas how I could alter this?

  9. chymx2
    Member
    Posted 9 years ago #

    if I click on teh categories links they are listed as http://www.ominousblog.com/index.php?cat=2 so they are adding that index.php part wonder why the comments section is not doign that?

  10. Keng
    Member
    Posted 9 years ago #

    Hi.
    I seem to have the same problem as him.
    The only difference is, my WP files are in a different directory (I didn't put it in my root folder to organize my domain).
    I have tried calling the index.php file from WP's directory (http://www.turbo-geek.org/domain/blog/) in the main index.php file that's in my root folder. It shows my posts, but the comments, however, are not.
    Any solutions?

  11. Keng
    Member
    Posted 9 years ago #

    Solved.

  12. Jabbok
    Member
    Posted 9 years ago #

    So, how did you solve it?

  13. chymx2
    Member
    Posted 9 years ago #

    How was it solved?

  14. chymx2
    Member
    Posted 9 years ago #

    My issue isnt solved so if someone can help me out I would appreciate it =)

  15. NuclearMoose
    Member
    Posted 9 years ago #

    Keng,
    You came to this forum looking for help, and it is only fair that you reciprocate and give something back to the other users. Please post your solution so that others may benefit. If you can't do that, you will likely find that people will not be helpful to you in the future.

  16. Joshua Sigar
    Member
    Posted 9 years ago #

    There's no guarantee that the original poster will check this resolved thread. If reply-notification feature were existant we could probably resurrect this thread conversation.

  17. McArt144
    Member
    Posted 9 years ago #

    I have the same problem and will try to describe it:
    This is not theme-dependant. My blog is in a subdirectory - don't think it matters.
    When I click the comment link at the bottom of a post, while I am on the index.php page (link usually says "no comments"), the URI indicated is "http://www.highcacres.com/hcafriends/?p=9#comments"
    The page that is 'opened' is actually "http://www.highcacres.com/hcafriends/index.php#comments"
    I'm guessing that the "?p=9#comments" should have in its entirity been appended to "index.php", so the page should have been
    "http://www.highcacres.com/hcafriends/index.php?p=9#comments"
    because if I type this in manually, my comment form loads. This also happens for the category selection, and I'm pretty sure it will happen with "/?anything" on my server.
    Any clues as to server settings that may make this happen? My host just 'upgraded' - still Apache I believe.

  18. chymx2
    Member
    Posted 9 years ago #

    yep that is very similar to my issue still no answers though =( it;s leaving off the index.php part but on when clicking on cmments

  19. elvenbook
    Member
    Posted 9 years ago #

    same problem here ...quite annoying :-/

  20. Joshua Sigar
    Member
    Posted 9 years ago #

    Not a solution but, maybe someone could email that "Keng" who has resolved similar issue. Make sure to post back the result.

    I myself haven't taken a look at this issue, but when I do have time I'll do some experiment.

  21. Keng
    Member
    Posted 9 years ago #

    I apologize for not checking back here sooner. -_-

    What I did was I uploaded the index.php file of WP1.5 (the short and sweet one) and just changed the directory of wp-blog-header.php from ./wp-blog-header.php to domain/blog/wp-blog-header.php. The reason (I think) why I was getting errors was because I had pointed the specific URL of the file (so instead of just domain/blog/, I put in http://www.turbo-geek.org/domain/blog/ instead). I have no idea why this messed up my index file, but it did, and changing what I had put in earlier for the URL of the file worked out for me somehow.

    Once again, I apologize for not doing what was expected of me. Sorry.

  22. McArt144
    Member
    Posted 9 years ago #

    . . Solution?
    My problem was because of bad server settings on the one week old 'upgraded' server. My provider addmitted it, but said they wouldn't get around to fixing it anytime soon. What I think would have worked as a work around would be to use permalinks. Tried it, but my provider had deteriorated to the point of requiring my to submit a request to customize an htaccess file. And after doing that, I realized their mod_rewrite wasn't set up correctly. I jumped ship (changed hosts) and WP1.5 was up and running error free in 5 minutes max on the new host. I have since taken my other three domains off of the old provider's 'upgraded' system.

  23. luiscamino
    Member
    Posted 9 years ago #

    keng's solution didn't help me either so this last one could be my problem too. how can i access mod_rewrite and how should it look like? (i have a dedicated server).

  24. McArt144
    Member
    Posted 9 years ago #

    I'm well past the limits of knowledge on this stuff as far as 'why' goes, but here is what worked for me until other matters shut it down:
    Go to options - permalinks - and paste one of the example structure strings into the 'structure box, hit "Update Permalink Structure" - either your htaccess will br rewritten or you will be supplied with the text to put into your htaccess file. Your link structure will be such that you will avoid ".../?..." in your URI strings, I think, and that is what was not making my ex-host's server happy.

  25. YuBoy
    Member
    Posted 9 years ago #

    Hi all,

    After upgrade from WP 1.2.2 to 1.5 following as closely as possible to Podz' instructions I also have the issue where index.php is never prepended to the URL argument.

    Thus, mydomain.com/blog/ is blank but mydomain.com/blog/index.php loads.

    Also, categories work (i.e. index.php is inserted in the URL) but comments and archives do not. If index.php is added to the URL in the correct place the page.loads correctly.

    Is there an path somewhere that should be edited? Or is this a server issue as suggested by McArt144?

    Possibly relevant info:
    - I do not have Permalinks set up
    - The blog is on an IIS server under httpdocs/blog rather than simply under /blog
    - I have managed to place WP files in both locations (/blog and /httpdocs/blog) creating some confusion and I'm afraid to delete /blog until I'm certain of what's going on

    Possibly irrelevant info:
    - WP does not seem to have the authorization to write to files, e.g. index.php (this might be an SQL issue arising from the upgrade, don't know)

  26. kyla
    Member
    Posted 9 years ago #

    anyone figured this out yet? i'm having the same problem

  27. georgianlady
    Member
    Posted 9 years ago #

    Are y'all using the virtual site structure without .htaccess?

    If so, do you have /index.php/ in the front of the virtual site structure?

    If so, also, then the box below that has a space to put a category custom prepend. In 1.2 I had to have /archive/ in there to make it work right site-wide.

    In 1.5 that was making things not work right.

    I've found that just putting nothing in there is right. Be sure to have /index.php/ in front of any other site structure. Try that setup to see if IT works, instead of using nothing.

    That's all just stuff to check out, not that it's the problem for anyone here. It could be something connected to it.

    -----------------
    Second Issue, more important:

    Also, if you are using a converted index.php be sure to look at changing things in the way of features. Get into your Theme Editor and go to the Classic or the Default and look at codes in the main file and the comments.php and such, and compare them to your own converted theme, replacings things exactly as show in the 1.5 Themes.

    Check out the codex here: Moving from 1.2 to 1.5 Using Themes for help with your index.php upgrading.

    I found that I needed to update several pieces of info on different spots on index.php and in comments.php (formerly wp-comments.php), just little things to make codes consistent with the whole setup.

    Hope that helps someone. I don't claim to have the right answers, just pointing out possible issues and where to look for some help. :)

  28. mattmce
    Member
    Posted 9 years ago #

    I noticed most of these posts are from February. Did anyone here find ever a good solution to the problem of why some links are leaving out the "index.php" part?

    I'm running into exactly the same thing here, and it's driving me crazy.

  29. MiStACoRn
    Member
    Posted 9 years ago #

    hmm.. I noticed somebody posting something about virtual site structure as opposed to .htaccess? I'm moving my install from a windows server to a unix server... could that be why I'm running into problems? If so, could somebody explain this a little better and maybe offer a possible solution?

  30. redshoes
    Member
    Posted 9 years ago #

    Ok, I'm having this same trouble (after changing servers and domains and importing the modified sql file), and while I have it narrowed down to the table field that is causing the problem, I don't know how to make an edit that will affect every post rather than editing each one individually (which I am quite sure is not the proper way of doing it).

    In wp_posts the ID line has a field called "guid". In the "guid" field, the url is giving me only the url and post title but omitting the index.php part of the url (if that makes any sense).

    For example:
    http://enkuechen.clawz.com/recipes/?p=4
    instead of
    http://enkuechen.clawz.com/recipes/index.php?p=4

    The same thing exists in the post_title table.

    What do I edit in order to make that guid field pull the whole url?

    I seriously won't be able to sleep until I figure this out. I'm on 28 hours with no sleep yet, so as you see, the situation is dire. :)

    Thanks in advance.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.